no sound on X17 cyber-system

Hy guy’s
my name is marcus and since two days I am an openSuSe user:)
It works but I have still one problem. There is no sound and my notebook manufacturer gives only drivers for windows.

Cyber-System - Cyber-System X17 Core Duo Treiber neu

here is the link to my system.
If I start my notebook there is the message “HDA Intel(ALC880 Analog)” does not work

many thanks

Hi marcus, welcome to openSUSE forums.

The ALC880 hardware audio codec is supported by Alsa. For example, I note it listed in the HD-Audio-Models.txt file for 1.0.20 of alsa Linux Kernel Documentation :: sound : alsa : HD-Audio-Models.txt and I suspect earlier versions of alsa also support it.

In my post below I am assuming you are using openSUSE-11.1. If not, and if you are using an earlier version of openSUSE, then please advise.

You could try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

If that guide does not help you, then please read on … Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation.

I have suse 11.1
many thanks for the fast reply I will work through this now

marcus@linux-ospo:~> rpm -qa | grep alsa
marcus@linux-ospo:~> rpm -qa | grep pulse
marcus@linux-ospo:~> rpm -q libasound2
marcus@linux-ospo:~> uname -a
Linux linux-ospo #1 SMP 2009-07-01 15:37:09 +0200 i686 i686 i386 GNU/Linux
marcus@linux-ospo:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.zdZSfW+JcaD:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

here the lines you wanted me to post

marcus@linux-ospo:~> rpm -q alsa alsa-utils alsa firmware
package firmware is not installed
marcus@linux-ospo:~> su
linux-ospo:/home/marcus # zypper install alsa-firmware
Daten des Repositorys laden…
Installierte Pakete lesen…
Paketabhängigkeiten auflösen…

Das folgende NEUE Paket wird installiert:

Gesamtgröße des Downloads: 2,0 M. Nach der Operation werden zusätzlich 7,5 M belegt.
Fortfahren? [JA/nein]: ja
Paket alsa-firmware-1.0.17-1.42.noarch wird abgerufen (1/1), 2,0 M (7,5 M installiert)
Einhängen von cd:///?devices=/dev/sr0 auf /var/adm/mount/AP_0x00000001 fehlgeschlagen: No medium found (mount: No medium found on /dev/sr0)

Abbrechen, wiederholen, ignorieren? [A/w/i]:

this is what came when I tried to install the new alsa firmware

That means you still have your installation CD/DVD enabled as a software repository and it can not find that CD/DVD. All you needed to do was insert that installation CD/DVD.

If your laptop has reasonably good internet access, then I recommend you disable that as a repository, and instead keep 4 software repositories: OSS, Non-OSS, Update and Packman. There is guidance for setting up those 4 repositories here: Repositories/11.1 - openSUSE-Community Note, I recommend ONLY those 4. No others. Please note that OSS provides the rpms/applications that are on your CD/DVD.

Please do not forget to run the diagnostic script, as recommended above (and quoted below):

Hey I have sound lol!

I installed the step 4 updating alsa. I am not sure what I did but that does not interest me it worked.

Many thanks for the fast replay again^^

Congratulations !! Glad to read this.

Glad to read the troubleshooting guide worked.

I wrote the guide (and try to maintain it) so its always nice to read of a success story.

Now that you have audio, you are going to want to setup your multimedia for playing videos and music.

I typically recommend, that as soon as one has their openSUSE PC on the Internet, that the first thing openSUSE users’s do is NOT use the one-click, but rather setup their software package management with 4 repositories. Just 4. Those 4 are OSS, non-OSS, Update, and Packman. Just those 4. There is guidance for that here: Repositories - openSUSE-Community The chances are that OSS, non-OSS, and Update are already in place. So one just needs to add Packman. I typically disable the CD/DVD as a respository (and instead rely on the Internet to provide the OSS). Note:

  • OSS - provides what is on the installation DVD
  • Non-OSS - provides packages that are not on the DVD, may include some proprietary (but not many)
  • Update - contains all “official openSUSE” updates made since the distribution version was released
  • Packman - 3rd party repository with lots of non-crippled multimedia applications and 3rd party codecs

Again, just those 4. If one adds others, there can be conflicts between repositories resulting in dependency errors, or simply resulting in applications not working properly. Many new users add both Packman and videolan and that causes many problems. So again, just OSS, Non-Oss, Update and Packman.

Once those 4 are added, one goes to YaST > Software > Software Management, and select the applications/codecs they want. I typically recommend to start with the Packman packaged versions (replacing any Novell/SuSE-GmbH versions) of amarok, amarok-xine, amarok-packman, libxine1, xine-ui, smplayer, mplayerplug-in, vlc, libffmpeg0, ffmpeg, w32codec-all, libquicktime0, libxvidcore4 . Note the last 4 provide codecs:

  • libffmpeg0 - its dependencies provide codecs. It does not itself
  • w32codec-all - libffmpeg should provide most codecs, but this may add some extra
  • libquicktime0
  • libxvidcore4
    I’m going by memory so I may have the precise package name off by a letter or number.

Note one can tell the packman packaged versions by the “pm” in the version number. Note the Novell/SuSE-GmbH packaged versions are typically crippled for multimedia, in keeping with the opensource philosophy. And so typically if a multimedia application does not work, check to see if there is a Packman packaged version. Packman web site: PackMan :: home … and again while the Packman web site provides a “one-click-install” link, I do not like that approach. I prefer to install via the Software Package Manager directly, with the repositories tightly limited and controlled as I noted.

Also, it is likey worth while to brush up on openSUSE concepts here: Concepts - openSUSE

Good luck !