No sound on Totem

I use Totem 2.24.2. It is not playing sound for .mp4 format anymore. Everything was fine until today , when i decided to install the recommended multimedia packages at Multi-media and Restricted Format Installation Guide - openSUSE Forums.
The audio of Totem is set to stereo (infact it was always this)
Xine, Mplayer, Smplayer, Vlc all play great - both audio & video for .mp4.

Posting the output of my multimedia.

Please help !:frowning:

rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' MPlayer '*vlc*' | grep -v avahi | sort
banshee-1-backend-engine-gstreamer-1.4.3-1.2.1
gstreamer-0_10-0.10.23-42.pm.1
gstreamer-0_10-ffmpeg-0.10.7-42.pm.1
gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.1
gstreamer-0_10-lang-0.10.23-42.pm.1
gstreamer-0_10-plugins-bad-0.10.8-6.6.1
gstreamer-0_10-plugins-bad-lang-0.10.8-6.6.1
gstreamer-0_10-plugins-base-0.10.23-42.pm.1
gstreamer-0_10-plugins-base-lang-0.10.23-42.pm.1
gstreamer-0_10-plugins-good-0.10.10-3.22.1
gstreamer-0_10-plugins-good-extra-0.10.10-3.22.1
gstreamer-0_10-plugins-ugly-0.10.12-42.pm.1
gstreamer-0_10-plugins-ugly-lang-0.10.12-42.pm.1
gstreamer-0_10-schroedinger-1.0.5-42.pm.4
gstreamer-0_10-utils-0.10.23-42.pm.1
gstreamer-utils-0.10.23-42.pm.1
libavc1394-0-0.5.3-129.3
libavcodec52-0.5-0.pm.3
libavdevice52-0.5-0.pm.3
libavformat52-0.5-0.pm.3
libavutil49-0.5-0.pm.3
libgstinterfaces-0_10-0-0.10.23-42.pm.1
libgstreamer-0_10-0-0.10.23-42.pm.1
libpostproc51-0.5-0.pm.3
libswscale0-0.5-0.pm.3
libvlc2-1.0.1-0.pm.0
libvlccore2-1.0.1-0.pm.0
libxine1-1.1.16.3-0.pm.3
libxine1-codecs-1.1.16.3-0.pm.3
MPlayer-1.0rc2_r29116-2.pm.2
python-gstreamer-0_10-0.10.15-42.pm.1
vlc-1.0.1-0.pm.0
vlc-aout-pulse-1.0.1-0.pm.0
vlc-gnome-1.0.1-0.pm.0
vlc-mozillaplugin-1.0.1-0.pm.0
vlc-noX-1.0.1-0.pm.0
vlc-qt-1.0.1-0.pm.0
xinetd-2.3.14-129.28
xine-ui-0.99.5cvs-20090203.pm.0821

I don’t use gnome but I have a feeling it’s something to do with the gstreamer packages. Maybe someone else can confirm?
Most gnome users don’t use Totem (I think). SMPlayer is probably the best player for openSUSE.

The quicktime based sites seem to pickup totem as my default player. Also, i like totem - simple player for all needs.

Check here and up and down thread from it
SLED11 restricted format - Page 2 - openSUSE Forums

I know it’s about SLED but it related to Totem. May help

Ok . I found this post Opensuse 10.3 Totem No Sound / Mplayer Ok - openSUSE Forums , which points to a totem_config file. I have searched this file all over google and every link points to location “~/.gnome2/totem_config”. However, i am not able to locate this within .gnome2.

I went to yast to check the file list of totem,but the totem_config file wasn’t listed there either. Seems totem has got this file in a new location now.

Any directions?

Could be in .gconf

Not anywhere in root. I have grep-ed for the pattern ‘audio.driver’ but couldn’t locate it in any file.

ddas4 adjusted his/her AFDB on Saturday 15 Aug 2009 07:26 to write:

>
> Not anywhere in root. I have grep-ed for the pattern ‘audio.driver’ but
> couldn’t locate it in any file.
>
>

Should not be in root, the ~/.gnome2 and ~/.gconf are in your home dir ( the
~ means user home )

HTH

Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

Try plaing around with the sound settings in Control Center. I found with my sound chip I have to use the oss decoder. You can play a test sound for each option.
Once set, right click the speaker launch in the desktop panel and choose preferences. Try using the oss mixer and set the sound level for each.
If this is still not running, go to yats>hardware>sound and set the sound there.

Baskitcase: Totem is the default suse gnome player.

This is what it contains:

blahblah:~ # pwd
/root
blahblah:~ # ls
.adobe         .exrc            .kbd                 .viminfo
.AntiVir       .gconf           .macromedia          .xauthI95Q5s
.bash_history  .gconfd          .mozilla             .xauthNHmzpu
bin            .gnome2          .nautilus            .Xauthority
.config        .gnome2_private  .recently-used.xbel  .xauthyYCAAF
.dbus          .gnupg           .Skype
Desktop        .gstreamer-0.10  .suse_register.log

None of the above have the file i am looking for!

@whych: i tried playing test sound - it plays fine. I am having issues with .mp4 only and that too with totem alone. All other media players play it fine. Totem used to play it fine earlier too !

Please also see my totem --debug output :

** Message: don't know how to handle audio/mpeg, mpegversion=(int)4, framed=(boolean)true, codec_data=(buffer)1290, rate=(int)32000, channels=(int)2
** Message: Missing plugin: gstreamer|0.10|totem|MPEG-4 AAC decoder|decoder-audio/mpeg, mpegversion=(int)4, framed=(boolean)true (MPEG-4 AAC decoder)
** Message: Automatic missing codec installation not supported (helper script missing)

Any clues what all i need to install to resolve this ??

You need to add the gstreamer mpeg codecs. Go to yast>software andchoose the packman repo. Filter on gstreamer and add the missing codecs.

ddas4 adjusted his/her AFDB on Saturday 15 Aug 2009 08:26 to write:

>
> This is what it contains:
>
>
> Code:
> --------------------
> blahblah:~ # pwd
> /root
> blahblah:~ # ls
> .adobe .exrc .kbd .viminfo
> .AntiVir .gconf .macromedia .xauthI95Q5s
> .bash_history .gconfd .mozilla .xauthNHmzpu
> bin .gnome2 .nautilus .Xauthority
> .config .gnome2_private .recently-used.xbel .xauthyYCAAF
> .dbus .gnupg .Skype
> Desktop .gstreamer-0.10 .suse_register.log
>
> --------------------
>
>
> None of the above have the file i am looking for!
>
>

Why are you looking in /root you need to look in your own home directory.

You should not be anywhere near /root and /root should not have any
preferences for media players or anything.

If you have been doing all these installs and configs while logged in as
root then DO NOT do it, you will and I mean WILL b0rk your system.

you should never login as root and especially in a GUI, one wrong bit of
coding in a program ( a simple error ) will cause all types of unrecoverable
stuff which will be hard if not impossible to fix and a complete wipe and
re-install will have to be done as no-one would be able to say that the
system is safe or secure.

Linux is not another OS who shall remain nameless.

:slight_smile:

HTH

Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

I have not installed anything as root or even through it’s GUI. I was going by the instructions in another post on this forum (Opensuse 10.3 Totem No Sound / Mplayer Ok - openSUSE Forums). This post talks about totem_config file which i have not been able to locate so far.

I have even looked in my /home/linux/ directory ; but nothing so far. Isn’t this the right location ?

Searched everywhere in /home/username/ directory. There are instructions to modify the totem_config file on google too ; but cannot find this file. There are couple of people who haven’t been able to find this file either like Totem_Config and Fiesty Fawn? [Archive] - Ubuntu Forums.

Does some additional package needs to be installed in order for this file to appear ?

I upgraded all my gstreamers to 0.10.12 or higher and totem audio works fine now. No need for any config file.

And best of all apple trailers play like a charm !!

ddas4 adjusted his/her AFDB on Saturday 15 Aug 2009 18:26 to write:

>
> I upgraded all my gstreamers to 0.10.12 or higher and totem audio works
> fine now. No need for any config file.
>
> And best of all apple trailers play like a charm !!
>
>

must have been a bug in the installer script for the earlier version, can
you confirm that the totem_config is now where it should be?


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

totem_config file is still not present.