no sound on sony vaio vgn fs715w

Hi all. I installed Suse 11.1 today on my sony vaio vgn fs715w after running the live cd for a few days. One issue I have (besides not being able to adjust screen resolution, which is posted in another thread) is that i am getting no sound out of either the laptop speakers or the headphone jack

i imagine i don’t have the correct driver installed, and the system is reverting to it’s own default driver for the screen.

if this were xp, i’d know what to do and where to go. but i want to be DONE WITH WINDOWS FOREVER!!!

any help pointing me to the correct driver, and with the installation of said driver would be most appreciated!

thanks.

The way sound is handled in Linux is a bit confusing, as it is a bit of an anarchy due to the free software opensource way of doing things. There are some concepts for sound here that are guaranteed to put you to sleep and likely not help in anything directly practical to your problem, but in case you are curious the link to it is here: Sound-concepts - openSUSE

In essence, alsa is the driver that is used for sound, where in Linux drivers are often kernel modules. Hence alsa provides kernel modules for sound for various sound devices, where only the correct sound kernel modules should be loaded upon boot.

Note also in openSUSELinux, there is a mixer that is loaded upon boot (kmix in kde, and I think alsamixer in gnome) that can be muted, and one may have to go in to that mixer and unmute PCM, Master, and Speaker volumes.

But if your hardware is relatively new, its quite possible your hardware was not correctly configured upon boot, and that you may need to manually configure it, or may even possibly have to update your alsa version.

You could try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole

/usr/sbin/alsa-info.sh

Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation as to how about you could get your laptop’s sound working.

ok, before i start the sound tests, i was looking around on my installed applications and found the pulseaudio manager applet. when i play something with sound (youtube video, etc), and i look at the pulseaudio volume meter, i see the bars jumping all around, but still hear nothing. i’m having trouble finding the mixer tho.

anyway, i’ll run the sound tests now. thanks

[QUOTE=oldcpu;2029658]
Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole

/usr/sbin/alsa-info.sh

Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

ran tests first, no sound.
here’s the url: http://www.alsa-project.org/db/?f=052e5f467f6433bc9e2cb7f0c9f496a2390720a3

here are the outputs for the commands:

linux-dqlr:/home/eggertdeggert/Desktop # rpm -qa | grep alsa
alsa-1.0.18-8.7
alsa-plugins-pulse-1.0.18-6.12
alsa-plugins-1.0.18-6.12
alsa-utils-1.0.18-6.4
alsa-firmware-1.0.17-1.42
alsa-oss-1.0.17-1.37

linux-dqlr:/home/eggertdeggert/Desktop # rpm -qa | grep pulse
pulseaudio-0.9.12-9.6
pulseaudio-module-zeroconf-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
libpulse0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
pulseaudio-module-lirc-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-gconf-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6

linux-dqlr:/home/eggertdeggert/Desktop # rpm -q libasound2
libasound2-1.0.18-8.7

linux-dqlr:/home/eggertdeggert/Desktop # uname -a
Linux linux-dqlr 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

linux-dqlr:/home/eggertdeggert/Desktop # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.pEJFnZjN46E:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

ok, from what I can see your PC has an ALC260, running a 32-bit openSUSE-11.1 with the 2.6.27.7-9-default kernel (ie you have not yet updated the kernel).

I looked at your mixer settings and they appear ok … I did note some things highlighted in red below, which likely do not matter, but you could check them to see if changing their setting helps:
!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [Intel]
Card hw:0 ‘Intel’/‘HDA Intel at 0xb0000000 irq 16’
Mixer name : ‘Realtek ALC260’
Simple mixer control ‘Master’,0
Mono: Playback 64 [100%] [0.00dB] [on]
Simple mixer control ‘Headphone’,0
Front Left: Playback 64 [100%] [0.00dB] [on]
Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control ‘PCM’,0
Front Left: Playback 255 [100%] [0.00dB]
Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control ‘Front’,0
Front Left: Playback 0 [0%] -64.00dB] [off]
Front Right: Playback 0 [0%] -64.00dB] [off]
Simple mixer control ‘Mono’,0
Mono: Playback 0 [0%] -35.00dB] [off]

If a do a search on the alsa web site for the ALC260 I note:
Search results ALC260 - AlsaProject

… in particular it appears the ALC260 auto-probe mode was not working as the update from 1.0.18 to 1.0.19 of alsa suggests that:

260: : ALSA: hda - Fix missing ADC list in ALC260 auto-probe mode
275: : ALSA: hda - Fix ALC260 hp3013 master switch
2704: : - ALSA: hda - Fix missing ADC list in ALC260 auto-probe mode
2708: : removed the ADC check for ALC260 auto-probe mode accidentally.
2709: : Re-added to patch_alc260() again.

Hence you could try to force an alsa cofiguration for your ALC260. The model options for that are here from the HD-Audio-Models.txt file:

ALC260
======
  hp		HP machines
  hp-3013	HP machines (3013-variant)
  hp-dc7600	HP DC7600
  fujitsu	Fujitsu S7020
  acer		Acer TravelMate
  will		Will laptops (PB V7900)
  replacer	Replacer 672V
  basic		fixed pin assignment (old default model)
  test		for testing/debugging purpose, almost all controls can
		adjusted.  Appearing only when compiled with
		$CONFIG_SND_DEBUG=y
  auto		auto-config reading BIOS (default)

So lets say one wishes to try the option “hp” (which may work with more than just “hp” machines):

So to force the setting “hp”, open /etc/modprobe.d/sound with root permissions and a text editor, in

  • kde with: kdesu ‘kwrite /etc/modprobe.d/sound’

  • gnome with:** gnomesu gedit /etc/modprobe.d/sound**

and add a line to the start of the file so that /etc/moprobe.d/sound looks like:

options snd-hda-intel model=hp
options snd slots=snd-hda-intel
# u1Nb.pEJFnZjN46E:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel

save the change, and restart the alsa sound driver with su -c ‘rcalsasound restart’ and restart your mixer (kmix in kde and alsamixer in gnome) and test your audio.

Please use all of the tests I noted above in a previous post.

If “hp” does not work, replace it with the next item in the list which is “hp-3013” and try each (ie save, restart alsa, restart mixer, test sound). Try that for each item in the list.

My guess is “auto” may work, but you probably need to try each to find the best. Some will give you nasty warnings.

If none of those work, then we can try an update of alsa from 1.0.17/1.0.18 to 1.0.20, and I can give you the commands for those.

ok, here’s something that might mean something…or something.

I tried hp first, then hp-3013, and both times when trying to restart the alsamixer, this happened: (i am pasting a bit more than that)

linux-dqlr:/home/eggertdeggert/Desktop # gnomesu gedit /etc/modprobe.d/sound
linux-dqlr:/home/eggertdeggert/Desktop # su -c ‘rcalsasound restart’
Shutting down sound driver done
Starting sound driver: hda-intel done
linux-dqlr:/home/eggertdeggert/Desktop # su -c ‘alsamixer restart’
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

same thing with both hp and hp-3013. before i go thru all of them, is there a problem restarting my mixer, or am i using an incorrect command (su -c ‘alsamixer restart’)?

by the way, here is a shot of my sound settings…i’ve had them all on autodetect, and also tried all of the other options.

ImageBam - Fast, Free Image Hosting and Photo Sharing

ALSA lib pulse.c:272pulse_connect) PulseAudio: Unable to connect: Connection refused

PulseAudio can be a problem for some users. I’m going to direct you to two past threads on disabling it should it be problematic:

How to safely remove/disable pulse audio? - openSUSE Forums

How to uninstall Pulseaudio and install esound - openSUSE Forums

Worth checking out anyway…

Edit: Another discussion about openSUSE 11.1 pulse audio problems (and other issues) here. Sorry, not a Gnome user, so never experienced the pain.

I’m not a gnome user, but I note you are trying to restart your alsamixer as root.

I recommend you restart alsa as root
su -c ‘rcalsasound restart’
but resart your mixer as a regular user with just
alsamixer
or if you have more than one audio card, and if alsamixer by itself is not working, then one can specify which card with the " -c " option …
alsamixer -c 0
for card 0. … However I should qualify the above by noting I’ve deduced that " -c " setting by a quick skim of “man alsamixer”, and that as a KDE user I do not have experience with alsamixer.

Do NOT run alsamixer as root.

Here’s something i noticed: When i removed pulseaudio and then tried to zypper in esound, it couldn’t find esound.

but when i looked at my alsa info, i found that the esound daemon was installed but not running. Here:

!################################
!!ALSA Information Script v 0.4.57
!!################################

!!Script ran on: Sun Aug 23 15:01:22 UTC 2009

!!Linux Distribution
!!------------------

Welcome to openSUSE 11.1 - Kernel \r (\l). openSUSE 11.1 (i586)

!!DMI Information
!!---------------

Manufacturer: Sony Corporation
Product Name: VGN-FS715

!!Kernel Information
!!------------------

Kernel release: 2.6.27.7-9-default
Operating System: GNU/Linux
Architecture: i686
Processor: i686
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: 1.0.17
Library version: 1.0.18
Utilities version: 1.0.18

!!Loaded ALSA modules
!!-------------------

snd_hda_intel

!!Sound Servers on this system
!!----------------------------

ESound Daemon:
Installed - Yes (/usr/bin/esd)
Running - No

!!Soundcards recognised by ALSA
!!-----------------------------

0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xb0000000 irq 16

so, is this the issue? the esound is installed but not running?
if so, how do i run esound? i am working thru the audio troubleshooting guide, but i want to stop here in case something needs to be done regarding esound. (i’ll try something done like “run esound” in root, but that’s probably not right.

thanks for your patience!

Sorry, but I won’t begin to try help here. I typically recommend NOT to remove pulse. I concede some users have found removing pulse got their sound working, and good on 'em for finding a solution, but I have NO IDEA as to its consequences. Hence once a user removes pulse, they need to get the person who advised them to remove pulse to help (because I can’t).

ok, i figured out how to turn esound on, restarted and viola, i have sound! Awesome. Thanks to all! OK, on to the ‘usb’ thread!

Glad to read its working … :slight_smile:

Congratulations.

ok, i figured out how to turn esound on, restarted and viola, i have sound! Awesome. Thanks to all! OK, on to the ‘usb’ thread!

Good result. Your perseverance paid off! Unfortunately, it looks like PulseAudio (in its current development) dies not play nicely with some hardware (or at least their drivers), so removal has been key to getting sound working.

Another thread which may help those searching for help with this.