No sound on openSUSE 11.1 (Realtek ALC660)

Hello, I have a great problem with my sound on SUSE. The first time I’ve installed it, the sound worked only at startup and on log-off… I tried to install driver from Realtek website… but during installation, it removed previously soundcards and from that… sound DISAPPEARS!!! I have tried to reinstall following the “sound troubleshooting page”, but, often, appears this:

“FATAL: module hda-snd-intel not found”.

What can I do?

I find more users fail when trying to install the RealTek drivers, than those who succeed. You could remove the Realtek driver best you can, and then re-install your alsa applications.

When sound “only” works on log on and log off, that typically has NOTHING to do with your alsa driver, and has everything to do with your media players and your codecs. Typically, openSUSE comes “crippled” as delivered for media players and codecs, as most codecs now adays are proprietary, and openSUSE does not “out of the box” support proprietary codecs.

Hence one typically has to install 3rd party media players and codecs to do this. There are various guides and posts (by myself and others) on this forum explaining how to do this. Basically (once your basic sound is functioning) install only OSS, Non-OSS, Update and Packman (and no others) as software repositories to your Software Package Manager and then update your media players to Packman packaged versions, and install the necessary codecs from Packman.

Can you post the output of this command

run as root

modprobe snd-hda-intel



I believe that it may have something to do w/ Alsa Drivers
from some searching…

Alsa and probing snd-hda-intel -

Sorry if you’ve already tried this…

Doing this appears this:

FATAL: Module snd_hda_intel not found.
sh: /sys/bus/pci/drivers/snd-hda-intel/new_id: No such file or directory
FATAL: Error running install command for snd_hda_intel

I still recommend you remove the Realtek drivers, and re-install the alsa drivers.

To determine if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times.

To assist your alsa configuration, after you have removed the Realtek drivers, then I will need more information if I am to make a recommendation … So can you provide more very detailed information so a good recommendation can be given? You can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing:
/usr/sbin/alsa-info.shthat will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. (Just the URL) It may be that you need to run that script with root permissions. Please note that I need that output to understand better your PC’s configuration.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/soundI also need that output.

I still recommend you remove the Realtek drivers, and re-install the alsa drivers.

This is the problem. Realtek drivers aren’t a rpm package or something, is a compiling package, so, I have no idea how to uninstall it… I’ve tried to reinstalla alsa drivers, but the problem persists :frowning:

I can give you the commands to re-install a different set of alsa drivers (newer) that likely will work. But first I need to see what you have installed, so please, run what I asked above. Thankyou.

speaker-test -c2 -l5 -twav

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM default
Playback open error: -2,No such file or directory

Alsa info gives me this:

rpm -qa | grep alsa
rpm -qa | grep pulse

rpm -q libasound2

uname -a
Linux linux-2eln #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux
cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel
options snd-hda-intel model=3stack-660
# 5Dex.IOFetRyhSn6:Realtek ALC660
alias snd-card-0 snd-hda-intel

This is the complete output :smiley:

I note this from the diagnostic script output:

!!ALSA Version

Driver version:     
Library version:    1.0.18
Utilities version:  1.0.18

Clearly, your alsa driver is not recognized.

You reported this:

which as you note did not do the trick. …

Lets try updating to the latest alsa, to see if by installing that it will over-write the realtek drivers. This is not the best method (where the best method is to remove the realtek) but since you can not remove them, then I do not see any other viable approach without doing a complete re-install.

So please open a gnome terminal or a kde konsole and type “su” (no quotes and enter root password when prompted) and then with your PC connected to the internet copy the following 6 zypper commands, one at a time, in sequence, into that same gnome terminal or kde konsole:

zypper ar multimedia 
 zypper install alsa alsa-utils alsa-tools alsa-tools-gui alsa-plugins-pulse alsa-plugins alsa-oss alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia
 zypper install alsa-driver-kmp-pae
zypper rr multimedia

and then restart your PC and test your sound with the sound test:
speaker-test -c2 -l5 -twavYou should (hopefully) hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Be certain to check your mixer during this test, moving up both PCM and master volume to 95% or so (you should back off that volume level to a lower level once your basic sound is functioning).




My understanding is you only obtained sound after applying the zypper update to alsa? Is that correct?

Yes… I think.