No sound on onboard speaker

I’m using SUSE 13.2 with GNOME and I can’t hear any sound, neither testing nor in video or audio playback.

lspci returned

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

I set my audio card in YAST and it says

7 Series/C210 Series Chipset Family High Definition Audio Controller

  • Configured as sound card number 0
  • Driver snd-hda-intel

I don’t know if it’s normal, but when I try to turn the volume up and down there is a “Dummy Output” above the volume bar.

This is my first post, so sorry if I made any mistake. I will appreciate any help.

On 2015-08-17 00:26, kevin ol wrote:

> I’m using SUSE 13.2 with GNOME and I can’t hear any sound, neither
> testing nor in video or audio playback.

There may be a slight confusion, because the term “on board speaker”
typically refers to a tiny speaker or beeper soldered to the mother
board, or perhaps on the same box, connected with a small cable. In
Linux it can only “beep”.

I suppose you don’t mean that. Guessing, I think that you have a laptop,
and that its sound does not work.

Have you used YaST to set up sound? There is a test button there. Any

Is “pulse” enabled or disabled?

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

You’re right!

Sound is set, PulseAudio is enabled, but I still got nothing on Yast tests.

More info about your hardware and configuration would be useful.

Please run the diagnostic script as described in this guide:…_to_run_script

Then share the link that it generates here.

Here it is

Your detected sound config reports


**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

!!Amixer output

!!-------Mixer controls for card 0 [PCH]

Card hw:0 'PCH'/'HDA Intel PCH at 0xf7e00000 irq 44'
  Mixer name	: 'Intel PantherPoint HDMI'
  Components	: 'HDA:10ec0269,12972033,00100100 HDA:80862806,80860101,00100000'
  Controls      : 31
  Simple ctrls  : 12

Some questions:

1.Is your display connected via HDMI? If so, can you get sound via HDMI as well?
2.Can you get sound via headphones?

Others may need to further dissect this output.

  1. No, it isn’t, but I just tested and got no sound
  2. Yes, I can

That’s a start I suppose. Anyway, I recommend installing/using ‘pavucontrol’ as it gives more control over available sources and sinks.

I note a 64-bit openSUSE-13.2 with the 3.16.7-24-desktop kernel, and 1.0.28 of alsa, using the snd_hda_intel alsa module. Hardware audio codec is an alc269vb.

The mixer appears ok, although you could try disabling 'automute:

Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'

I recommend you follow the suggestion to install ‘pavucontrol’ and see if you can use it to tune your audio.

wrt the ALC269VB, I see no specific ALC269VB model config, although in the HD-Audio-Models.txt I do note the ALC269 in this list:

  laptop-amic        Laptops with analog-mic input
  laptop-dmic        Laptops with digital-mic input
  alc269-dmic        Enable ALC269(VA) digital mic workaround
  alc271-dmic        Enable ALC271X digital mic workaround
  inv-dmic        Inverted internal mic workaround
  headset-mic        Indicates a combined headset (headphone+mic) jack
  lenovo-dock       Enables docking station I/O for some Lenovos
  dell-headset-multi    Headset jack, which can also be used as mic-in
  dell-headset-dock    Headset jack (without mic-in), and also dock I/O

where the above is something we can keep in mind if pavucontrol tuning does not work.

Have you tested to see if sound works as user root ? ie in an xterm type:

speaker-test -c2 l5 -twav

or if you have a .wav file try:

aplay -vv somefile.wav

Try that with both regular user and root permissions.

I downloaded pavucontrol and tried to play an audio file, but nothing yet, although it says that there is sound being played.

It is now disabled

I also tried that and I know that it works regardless of the user, but I could only confirm that using the headphones, as there’s still no sound output on the speakers.

“tried to play” is a picturesque description but it leaves me wonder exactly what you tried. I scratched my head, and decided there was no way from that description that I could tell what you applied in pavucontrol, to ensure you conducted a correct setting.

Take a look at my laptop’s pavucontrol settings, that send sound to the speakers:](


How does that compare to the settings you applied ?

In addition, I could not find your answer to the HDMI question you were asked.

You have two places for the sound to go (headphone and speaker) use pavulcontrol to set where you want the sound to go. You can adjust that also in your desktop for default values.

I double clicked an audio file, I guess that the default player is “Videos”, and tried the terminal method too. The pavucontrol settings are exactly the same as those on the screenshots.
My laptop is not connected via HDMI, but I tested on my TV and also got no sound.

Typically double clicking on an audio file of unspecified type/codec, and only guessing at the video player, does not inspire confidence in one trying to help (such as myself) as to that being a good test for basic sound functionality - as it could be a codec issue or an application issue, and our recommendations could be off the mark.

Can you confirm by this double clicking, to launch some ‘guessed’ video player, does give sound with your headphones ?

The next things to try , may be to tune the 50-sound.conf file … but this will require some effort (on your part) and before I potentially waste your time, could you answer my confirmation request ?

I didn’t think that this information was useful, as sound is not working anywhere in my system when using the speakers, I’m sorry.
I tried with a .mp3 file, then with a .wav file using Videos as player in both times, and one last time with the .wav using the aplay command that you suggested. I also tried some videos on YouTube - I use Firefox 39 - but I couldn’t hear anything. All this gave sound with my headphones.

Have you actually added the codecs need to play mp3??

instructions here

One more dumb question on my part. Can you please confirm you unplug your headphones when you test your speaker sound ? Plugging in one’s headphones (in GNU/Linux) mutes the speakers on most laptops.

Yes, I have.

I didn’t know that, but I did unplug the headphones everytime.

Ok … then can you do one more test for me … and that is to send this command from an xterm and see if it produces sound from your speakers. Try as a regular user, and also try with root permissions:

aplay -vv -d hw:0,0 /usr/share/sounds/alsa/test.wav

That is "- v v " (with no spaces) and not a -w .

Please advise which, if any, errors you get when you send that command. Do you get any sound without headphones ? With headphones ?

I specified " hw:0,0" to be 100% certain sound is not routed through your HDMI output, which is “hw:0,3”.

I should note thou, I believe that pulse audio will over rule that command and send audio to the HDMI if inappropriately set in pavucontrol.