no sound on new Suse 11.1 ?

Thank you opdcpu, here is the URL you asked me for:

http://www.alsa-project.org/db/?f=7d5e3e5c0a3739506b6a118ebe71806ba46f8339

And the symptoms of my problem: no sound at all. I tried almost everything and I’m certainly missing something, but I’m not new to Linux at all… Even plugging external headphones doesn’t help. No sound at all but, the worst thing, no error logged anywhere at all…

You hel will be really appreciated, thank you!

P.S.: Please, ignore the line

snd-hda-intel: model=lenovo

in my ALSA Information Script, it was just a (desperate) test :wink:

OK, but you understand that a wrong model option will possibly affect the output of the script, and thus possibly give misleading information?

What laptop do you have? A dell ? an Acer ? an HP ?

You could try updating your alsa to the latest cutting edge rpms (which are newer than those that come with openSUSE-11.1) following the guidance here: Alsa-update - openSUSE Please read that carefully, and note there are 6 zypper commands you must send, and not just 3 (which some users mistakenly do). Also note you must restart your PC after an alsa update.

After updating alsa, you could also try updating your /etc/modprobe.d/sound file with an appropriate option, with such as something like:

options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
options snd-hdal-intel model=dell-m4-1
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel 

then restart alsa by either rebooting, or typing in a terminal with root permissions “rcalsasound restart” and launch your mixer again and test your audio.

Note I obtained “dell-m4-1” from the ALSA-Configuration.txt file, which states:


	STAC92HD71B*
	  ref		Reference board
	  dell-m4-1	Dell desktops
	  dell-m4-2	Dell desktops 

Instead of “dell-m4-1” one could also try “dell-m4-2” in the /etc/modprobe.d/sound file.

I note HP DV5 laptop users with the same hardware audio codec instead to use:

options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
options snd-hdal-intel model=hp-m4 enable_msi=1
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel 

The mixer is also very sensitive so be careful with setting up the mixer. For example, take a look at this thread:
No sound, openSUSE 11.1 on HP dv5-1030en - openSUSE Forums

Ok dear oldcpu,

I did everything you told me, but unfortunately with no results.

So I set back everything as after the fresh installation, rebooted and relaunched alsa-info.sh:

http://www.alsa-project.org/db/?f=2815cf3c42302b94fc585f1c2985a5218223f17e

My laptopo is a HP Pavilion DV5 (AMD Turion X2 Dual-Core Mobile RM-72). Hope not annoying you :shame:

Have a nice day,

ZioVanja

My experience in helping users with the HP DV5 is audio works.

Please:

a. update your alsa per this guide here: Alsa-update - openSUSE Read the guide carefully. Note you need to send 6 zypper commands (do not make the mistake of sending only 3, which some users do).

b. then add the option line “options snd-hdal-intel model=hp-m4 enable_msi=1” to your /etc/modprobe.d/sound file, like I already suggested,

c. restart your PC, then test your sound. PAY CAREFUL ATTENTION to your mixer. Various HP DV5 users have done steps a and b, and then complained their sound still did not work, when in fact all that was blocking them was a misconfigured mixer.

No way, I actually did everything, followed your instruction and also others’ one, but no sound at all. Maybe a PulseAudio issue. :expressionless:

OK, then I would like to do a quality check on what you state you have done.

Please, with your pc connected to the internet, open a gnome terminal or a konsole, and send the following command:/usr/sbin/alsa-info.sh that will give you a URL. Please post that URL here.

And also, please send the following commands, one at a time, in a gnome-terminal or a konsole, and copy the output here:rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Here I am:

http://www.alsa-project.org/db/?f=f506ae6de199c7e87f36ace81c21d4ded212a0b0

abulafia:~ # rpm -qa | grep alsa
alsa-tools-1.0.18.git20081201-1.5
alsa-oss-32bit-1.0.17-1.37
alsa-plugins-pulse-1.0.18-6.13
alsa-1.0.18.git20081212-1.1
alsa-firmware-1.0.17.git20081202-2.3
tsalsa-20080914-0.pm.1
alsa-utils-1.0.18.git20081122-1.7
alsa-oss-1.0.17-1.43
alsa-plugins-1.0.18-6.13
alsa-driver-kmp-default-1.0.18.20081221_2.6.27.7_9.1-1.1
abulafia:~ # rpm -qa | grep pulse
libpulse-browse0-0.9.12-9.5
libpulsecore4-0.9.12-9.5
pulseaudio-0.9.12-9.5
alsa-plugins-pulse-1.0.18-6.13
libpulse0-32bit-0.9.12-9.6
pulseaudio-module-gconf-0.9.12-9.5
libpulse0-0.9.12-9.5
libpulse-mainloop-glib0-0.9.12-9.5
pulseaudio-utils-0.9.12-9.5
abulafia:~ # rpm -q libasound2
libasound2-1.0.18.git20081212-1.1
abulafia:~ # uname -a
Linux abulafia 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux
abulafia:~ # cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
options snd-hdal-intel model=hp-m4 enable_msi=1
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel

Thank you!

ZioVanja

OK, the model option was not accepted with the syntax we provided. I note this:

!!Loaded sound module options
!!--------------------------
!!Module: snd_hda_intel
bdl_pos_adj : 32,32,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
enable_msi : 0
model : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,

enable_msi of 0, and no model option.

So maybe we need to try a different syntax. Try this in your /etc/modprobe.d/sound file:


options snd slots=snd-hda-intel,snd-hda-intel
options snd-hdal-intel model=hp-m4 enable_msi=1
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel

reboot and test your sound.

Nothing at all: PulseAudio seems to detect everything correctly - I mean, PulseAudio applet allows me to high and low volume, and also shows me processes and devices, although it’s not clear at all to me which and what they are - but no sound at all in my speakers nor headphones.

Googleing around makes me think that I’m not the only one, a lot of people are requesting assistance on this issue. I’m starting to think is a release bug somewhere. I could try to install the good old 11.0, but it would be a pity: sound is the only issue - and 3D acceleration, but I don’t need it, since I use my laptop for professional purpose only.

Anyway, I want to really thank you for your kind help!

ZioVanja

Hmmm… I’m not quite willing to give up on this …

Try instead this (I moved the additional entry up to 1st line) in the /etc/modprobe.d/sound file:

options snd-hdal-intel model=hp-m4 enable_msi=1
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel 

reboot, test your sound, check your mixer. Use the sound test I recommended.speaker-test -c2 -l5 -twav

Then if that does not work, use this instead (dell-m4-1):

options snd-hdal-intel model=dell-m4-1 enable_msi=1
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel 

reboot, test your sound, check your mixer. Use the sound test I recommended.

And if that doesn’t work, use instead (dell-m4-2):

options snd-hdal-intel model=dell-m4-2 enable_msi=1
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel 

reboot, test your sound, check your mixer. Use the sound test I recommended.

After making the edits to the /etc/modprobe.d/sound file, instead of rebooting, you can also type:su -c ‘rcalsasound restart’
entering root password when prompted.

If those do not work, run:rpm -qa | grep pulseand record what pulse applications you have installed. Then remove pulse (you can always re-install them, as you have a list now as to what was installed) and go through the above 3 different /etc/modprobe.d/sound files, to see if one works.

When testing your mixer, move the volume levels up to 95% or so. That will possibly cause distortion, but at this time we are not looking for optimal sound. We are looking for basic sound. After you get sound functioning you can back off the volume levels to a more optimal setting.

I can’t seem to get the sound to work.
Any help wold be appreciated.
HP MINI 1000 running suse 11.1.
Thanks.
Jim

Your ALSA information is located at http://www.alsa-project.org/db/?f=0797c17aef53b246653c712f17d773ebe45755a8

Please inform the person helping you.

linux-k4kq:~ #
linux-k4kq:~ # cat /etc/modprobe.d/sound

options snd-hda-intel single_cmd=1
options snd slots=snd-hda-intel

u1Nb.MjZApDJ7QzC:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel
linux-k4kq:~ # uname -a
Linux linux-k4kq 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux
linux-k4kq:~ # rpm -qa |grep alsa
alsa-utils-1.0.18-6.4
alsa-tools-1.0.18-1.13
alsa-firmware-1.0.17-1.42
alsa-oss-1.0.17-1.37
alsa-plugins-1.0.18-6.12
alsa-1.0.18-8.7
linux-k4kq:~ # rpm -qa |grep pulse
pulseaudio-module-zeroconf-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-jack-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
pulseaudio-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
pulseaudio-module-x11-0.9.12-9.6
linux-k4kq:~ # rpm -q libasound2
libasound2-1.0.18-8.7
linux-k4kq:~ #

Hi Jim, … this is a tough one to sort out. I did a search for this and came up with a few hints, but not much. Overall, I can not find much in the way of support (under the alsa driver) for the IDT 92HD75B2X5 hardware audio codec that comes with your HP mini 1000.

I did note this in your /etc/modprobe.d/sound file:

Could you point out your reference/reason for using “single_cmd=1” ?

I do note that some Ubuntu users of the HP min 1000 managed to get sound to work by doing a modification to their alsa-base file (which is similar conceptually, albeit coded with a different philosophy, to the openSUSE /etc/modprobe.d/sound file). How about trying the Ubuntu approach. To do that, please change your /etc/modprobe.d/sound file to the following:
options snd-hda-intel model=ref
options snd slots=snd-hda-intel

u1Nb.MjZApDJ7QzC:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel then restart your PC and test your sound. Ensure in your mixer that PCM, Master, and Front volume are up to about 95%. Once you get sound, you should then back them off to lower levels to avoid distortion.

Ubuntu references:

The sound test that I recommend you use is this (copy and paste it into a gnome terminal or a kde konsole): speaker-test -c2 -l5 -twavyou should hear a ladies voice say ‘Front left’, ‘Front right’ five times.

Good luck.

Thanks for your help.
made changes…no sound., and lost PCM.

Changed back. I noticed I can’t un-mute master PCM in Kmix.

i’ll keep playing with it.

OK, … I have another suggestion. I note your laptop has a IDT 92HD75B2X5 hardware audio codec, which is pretty new. You could try updating to the very latest, cutting edge version of alsa.

openSUSE-11.1 does not quite have the latest alsa version, although it is a fairly new version. To install the very latest alsa version, send (copy and paste) the following six zypper commands in sequence in a konsole or gnome terminal with root permissions (ie type ‘su’ and enter root password) with your PC connected to the internet:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.1/ multimedia 
zypper install alsa alsa-utils alsa-tools alsa-plugins alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1/ multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

and then reboot your PC and test your sound. Try that with, and with out, the update to the /etc/modprobe.d/sound file.

My reference for the above updating commands is here:
Alsa-update - openSUSE

Good luck.

jjenkins2000 wrote:

>
> Thanks for your help.
> made changes…no sound., and lost PCM.
>
> Changed back. I noticed I can’t un-mute master PCM in Kmix.
>
> i’ll keep playing with it.
>
>

I had no sound and then dumped the 64-bit installation and replaced it with 32-bit. Still quite a few problems but at least I have sound.

To un-mute the master, I found I first had to set a master by right-clicking the icon and choosing “select master channel” - not that this had any effect on the sound but it made the icon show the volume on hover instead of 0%.


Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy

Dear oldcpu,

I just want to let you know that I found out how to make sound work on my laptop, in the end! Just a few simple steps:

  1. Go to Yast > Hardware > Sound
  2. Disable Pulse support (!!!)
  3. Use the settings you provided (see below) for /etc/modprobe.d/sound
  4. Access Kmix and switch off Analog Loopback (both channels)
  5. Restart sound (rcalsasound restart)

Here are the settings for /etc/modprobe.d/sound:

options snd-hda-intel model=dell-m4-1 enable_msi=1
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel

Everything seems to work OK, and that’s pretty enough for me, after days (and nights…!) of struggling… But I must be honest, there are lots of other minor bugs that make me think OpenSUSE 11.1 was not mature enough to be released yet, not at all. Nevertheless I’ll go on preferring OpenSUSE for desktop and productivity, other linux distro for servers.

Oldcpu, THANK YOU for the precious help you gave me!!! I wish you a very happy new year :slight_smile:

ZioVanja

oldcpu,
I was able to update…
but no sound… I agree this is new hardware and I’ll have to wait until ALSA supports this hardware.
Thanks Jim

PS: What is this.
Git statistics for Linus’ kernel tree

ALSA: hda: Add support for 92HD73xxx codecs

@@ -4298,10 +4320,11 @@ struct hda_codec_preset snd_hda_preset_sigmatel] = {
{ .id = 0x838476a5, .name = “STAC9255D”, .patch = patch_stac9205 },
{ .id = 0x838476a6, .name = “STAC9254”, .patch = patch_stac9205 },
{ .id = 0x838476a7, .name = “STAC9254D”, .patch = patch_stac9205 },

  • { .id = 0x111d7603, .name = “92HD75B3X5”, .patch = patch_stac92hd71bxx},
  • { .id = 0x111d7608, .name = “92HD75B2X5”, .patch = patch_stac92hd71bxx},

REF ----upgrade installation…

Password:
linux-k4kq:~ # zypper ar Index of /repositories/multimedia:/audio/openSUSE_11.1 multimedia
Adding repository ‘multimedia’ [done]
Repository ‘multimedia’ successfully added
Enabled: Yes
Autorefresh: No
URI: Index of /repositories/multimedia:/audio/openSUSE_11.1

linux-k4kq:~ # zypper install alsa alsa-utils alsa-tools alsa-plugins alsa-firmware libasound2
Retrieving repository ‘Packman Repository’ metadata [done]
Building repository ‘Packman Repository’ cache [done]
New repository or package signing key received:
Key ID: F54EB54C20F035D8
Key Name: multimedia:audio OBS Project <multimedia:audio@build.opensuse.org>
Key Fingerprint: F293D117CA0C96D2BFF429B1F54EB54C20F035D8
Repository: multimedia

Do you want to reject the key, trust temporarily, or trust always? [R/t/a/?]: a
Building repository ‘multimedia’ cache [done]
Loading repository data…
Reading installed packages…
Resolving package dependencies…

The following packages are going to be upgraded:
alsa alsa-firmware alsa-plugins alsa-tools alsa-utils libasound2

The following packages are going to change vendor:
alsa alsa-firmware alsa-plugins alsa-tools alsa-utils libasound2

Overall download size: 4.9 M. After the operation, additional 1.3 M will be used.
Continue? [YES/no]: y
Retrieving package alsa-firmware-1.0.17.git20081202-2.3.noarch (1/6), 2.3 M (8.5 M unpacked)
Retrieving: alsa-firmware-1.0.17.git20081202-2.3.noarch.rpm [done (107.3 K/s)]
Installing: alsa-firmware-1.0.17.git20081202-2.3 [done]
Retrieving package libasound2-1.0.18.git20081212-1.1.i586 (2/6), 343.0 K (1.2 M unpacked)
Retrieving: libasound2-1.0.18.git20081212-1.1.i586.rpm [done (69.9 K/s)]
Installing: libasound2-1.0.18.git20081212-1.1 [done]
Retrieving package alsa-plugins-1.0.18.git20081122-1.10.i586 (3/6), 45.0 K (119.0 K unpacked)
Retrieving: alsa-plugins-1.0.18.git20081122-1.10.i586.rpm [done]
Installing: alsa-plugins-1.0.18.git20081122-1.10 [done]
Retrieving package alsa-utils-1.0.18.git20081122-1.7.i586 (4/6), 965.0 K (1.7 M unpacked)
Retrieving: alsa-utils-1.0.18.git20081122-1.7.i586.rpm [done (107.9 K/s)]
Installing: alsa-utils-1.0.18.git20081122-1.7 [done]
Retrieving package alsa-tools-1.0.18.git20081201-1.5.i586 (5/6), 171.0 K (554.0 K unpacked)
Retrieving: alsa-tools-1.0.18.git20081201-1.5.i586.rpm [done (54.0 K/s)]
Installing: alsa-tools-1.0.18.git20081201-1.5 [done]
Retrieving package alsa-1.0.18.git20081212-1.1.i586 (6/6), 1.1 M (1.4 M unpacked)
Retrieving: alsa-1.0.18.git20081212-1.1.i586.rpm [done (104.0 K/s)]
Installing: alsa-1.0.18.git20081212-1.1 [done]
linux-k4kq:~ # zypper rr multimedia
Removing repository ‘multimedia’ [done]
Repository ‘multimedia’ has been removed.
linux-k4kq:~ # zypper ar Index of /repositories/multimedia:/audio:/KMP/openSUSE_11.1 multimedia
Adding repository ‘multimedia’ [done]
Repository ‘multimedia’ successfully added
Enabled: Yes
Autorefresh: No
URI: Index of /repositories/multimedia:/audio:/KMP/openSUSE_11.1

linux-k4kq:~ # zypper install alsa-driver-kmp-default
Building repository ‘multimedia’ cache [done]
Loading repository data…
Reading installed packages…
Resolving package dependencies…

The following NEW package is going to be installed:
alsa-driver-kmp-default

Overall download size: 1.5 M. After the operation, additional 5.5 M will be used.
Continue? [YES/no]: y
Retrieving package alsa-driver-kmp-default-1.0.18.20081228_2.6.27.7_9.1-2.1.i586 (1/1), 1.5 M (5.5 M unpacked)
Retrieving: alsa-driver-kmp-default-1.0.18.20081228_2.6.27.7_9.1-2.1.i586.rpm [done (108.5 K/s)]
Installing: alsa-driver-kmp-default-1.0.18.20081228_2.6.27.7_9.1-2.1 [done]
linux-k4kq:~ # zypper rr multimedia
Removing repository ‘multimedia’ [done]
Repository ‘multimedia’ has been removed.
linux-k4kq:~ #

Congratulations! Thankyou for sharing your solution.

I understand the sentiment, but honestly, given your PC’s hardware, I do not think sound will work under any other openSUSE version. It needs both the new kernel and the cutting edge alsa for the sound to work.

New releases alway tend to be a bit buggy (I can not remember one that was not) and it takes a couple of months for them to be ironed out.

Oldcpu, THANK YOU for the precious help you gave me!!! I wish you a very happy new year :slight_smile:

ZioVanja[/QUOTE]

jjenkins, you need to reboot to test your sound. Its also possible you need to make an edit to the /etc/modprobe.d./sound file.

I am getting very frustrated with this entire thread. Too many users put their sound in the one thread, and to solve problems with this relatively cutting edge hardware takes iterations, … which means I have to hunt back and forth, and try to see which each person has done in the past … Everyone thinks their problem is the same, and its NOT ! Everyone’s problem IS different which means different data, and different research and different answers …

It takes me a fair amount of effort to research and try to give good answers, and multiple users asking for help in a thread REALLY complicates my life. I know eventually I will confuse users and make a mistake (or multiple mistakes). On more than one occasion I’ve been tempted to ignore users who make multiple posts in a thread, … anyway … < rant OFF > . …

Anyway, I managed to hunt back in the thread, and confirm your PC has a Codec: IDT 92HD75B2X5 and then re-read my previous research. I note it is not covered by the ALSA-Configuration.txt file

Did you change your /etc/modprobe.d/sound file to:

options snd-hda-intel model=ref
options snd slots=snd-hda-intel
# u1Nb.MjZApDJ7QzC:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel

and then restart your PC? Check your mixer !

If you can not get sound, then after doing the above, please post the output URL (with your PC connected to the internet) provided by :
/usr/sbin/alsa-info.sh
do NOT post all the info , here. Just the URL. This thread is incredibly hard for me to follow with input, where EVERYONE’s hardware is different.

Also, please run the following as a quality check, and post here the output:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q padevchooser pavucontrol pavumeter paman paprefs
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

… and finally, can you please refresh my memory - are you using KDE3 or KDE4 or Gnome ?

Thanks! Apologies for the grumpiness. I have to dash to work now before I am late.