no sound on my Aspire 5720z

I have an Acer Aspire 5720z laptop, and I recently installed SUSE. It seems to be working fine except for the sound. I’ve tried everything I know and nothing is working.

Any thoughts?

Could be a number of things. A number of users who had sound working, found it stopped upon a recent kernel update, and some are waiting for a alsa driver update. But for the moment, until we know otherwise, lets assume you are not in that situation.

For helping users with non-functioning sound, I typically recommend that they try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

Don’t forget to try YaST > Hardware > Sound to configure your sound card. Also, don’t forget to try ‘alsaconf’ in a konsole/terminal if YaST does not help you.

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

NOTE: Try those speaker-tests as both a regular user, and with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming after your trying to get sound working, after having gone through each applicable step in the troubleshooting guide, and if still no sound, can you provide more very detailed information so a good recommendation can be given? If using openSUSE-11.1, you can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing “su” (no quotes - enter root password) and then and typing and executing twice :
/usr/sbin/alsa-info.shthe first time it will ask to update. Select YES for the update. The second time that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. JUST the URL.

If using openSUSE-11.0 or earlier, then instead copy and paste this command into a konsole/terminal, and again provide the URL that it gives you when it is complete:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation (as opposed to a guess).

I note this is your first post here. WELCOME to openSUSE forums!

Thank you. I’m still having problems with it, but the sound tests work now.

Strangely,

speaker-test -Dplug:front -c2 -l5 -twav

does not work, but


speaker-test

and

speaker-test -c2 -l5 -twav

do work.

All I can tell that I did to get those to actually work was install the “alsa-firmware” package.

I can hear those two tests very clearly. I can also hear the sounds when KDE starts up and shuts down. But I’ve yet to hear a sound in some other applications.

I tried installing a few different gstreamer packages to see if that would get Amarok to work, but no go so far. No sounds in youtube or pandora either. I can, however, hear the pings that Kopete makes when I get a new IM.

Not so strange. That happens most of the time on PCs that I test. Thats why I typically recommend one try 3 different speaker tests.

maybe all you needed was the firmware.

This is a codec issue most likely.

Another thing is some users tend to be very stubborn in getting their application of choice to run, rather than start off doing something that “just works”. I’m not saying that is your case, but I have encountered that many times and it unfortunately turns off some users to Linux because they are not flexible.

Anyway, take a look at my post here (and my apologies for my pontification):
openSUSE Forums - View Single Post - sound problems on Gateway M-6874h

I use the xine engine for amarok-1.4.10. Note the URL I provided above. I also found the “pulse” setting did not work for me under amarok (settings > congure amarok > engine), and I changed the output plugin to “alsa” which does work. YMMV.

Awesome, thank you. I read over your page. And followed your instructions.

I did not install the amarok from packman. Instead I opted to install the package kde4-amarok and it’s working.

I installed everything else you suggested however, and now have good video players installed :slight_smile: Thank you.

But, I still don’t have any sounds with flash. Neither youtube nor pandora play sounds.

Any thoughts?

For flash I find it important one does NOT install too many plugins in firefox. Typically I install flash-player and the Packman packaged MPlayer and mplayerplug-in, and flash “just works”.

So no guarantee that sound is going to work? It’s still not. I’m searching google to look for solutions too.

I don’t understand.

What sound works? Does any sound on any application? Does the sound test work (that I explained how to run in my first post) ?

Please be specific when you state “no guarantee that sound is going to work” because I don’t have a clue as to what you mean. I know its obvious and frustrating to you, but such statements does not help to solve things and it just clouds the issue. You need to be SPECIFIC !

I mean in flash player. Everything else is working great. Perfect sound. But flash is not playing sounds.

You said “and flash “just works””, which I took as meaning you’re resolved to it “just working” or barely getting by…

Sorry for the confusion.

OK, thanks for the update. I was afraid we had “regressed” :slight_smile: … I need to know a bit more, … ie I want to see what you have installed.

So please, can you copy and paste the following command into a terminal or konsole and post here the output:

rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' '*layer*' '*vlc*' | grep -v avahi | sort

This comes from RedDwarf’s guide Check your multimedia problem in ten steps - openSUSE Forums and it should give us a handle on what you have installed and what you might be missing.

Also, please, can you advise as to what plugins and what enhancements you have selected for your firefox browser ?

amarok-xine-1.4.10-26.2.1
flash-player-10.0.22.87-0.1.1
gstreamer-0_10-0.10.23-42.pm.1
gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.1
gstreamer-0_10-lang-0.10.23-42.pm.1
gstreamer-0_10-plugins-bad-0.10.8-6.5
gstreamer-0_10-plugins-bad-lang-0.10.8-6.5
gstreamer-0_10-plugins-base-0.10.23-42.pm.1
gstreamer-0_10-plugins-base-lang-0.10.23-42.pm.1
gstreamer-0_10-plugins-good-0.10.15-42.pm.1
gstreamer-0_10-plugins-good-lang-0.10.15-42.pm.1
gstreamer-0_10-schroedinger-1.0.5-2.19
gstreamer-0_10-utils-0.10.21-3.11
gstreamer-utils-0.10.21-3.11
libavc1394-0-0.5.3-129.3
libavcodec52-0.5-0.pm.3
libavdevice52-0.5-0.pm.3
libavformat52-0.5-0.pm.3
libavutil49-0.5-0.pm.3
libgstinterfaces-0_10-0-0.10.23-42.pm.1
libgstreamer-0_10-0-0.10.23-42.pm.1
libpostproc51-0.5-0.pm.3
libswscale0-0.5-0.pm.3
libvlc2-0.9.9a-0.pm.1
libvlccore0-0.9.9a-0.pm.1
libxine1-1.1.16.3-0.pm.2
libxine1-codecs-1.1.16.3-0.pm.2
libxine1-gnome-vfs-1.1.16.3-0.pm.2
libxine1-pulse-1.1.16.3-0.pm.2
MPlayer-1.0rc2_r29116-2.pm.2
mplayerplug-in-3.55-0.pm.1
phonon-backend-gstreamer-0_10-4.2.0-40.18
phonon-backend-xine-4.1.3-4.2.9
pullin-flash-player-11.1-1.1
smplayer-0.6.7-0.pm.1
vlc-0.9.9a-0.pm.1
vlc-noX-0.9.9a-0.pm.1
vlc-qt-0.9.9a-0.pm.1
xinetd-2.3.14-129.28
xine-ui-0.99.5cvs-20090203.pm.0821

And lets see… Firefox is running:
DivX Browser Plug-in
Google VLC multimedia plugin 1.0
Icedtea Web Browser plugin
mplayerplug-in 3.55
OpenSC Signer plugin
QuickTimePlug-in 7.4.5
RealPlayer 9
Shockwave Flash
Windows Media Player Plug-in

And they’re all enabled. I tried disabling everything except the icedtea and flash and it’s still no go.

I placed in red some apps that I believe you should have installed packman packaged versions instead. I placed in purple a couple of apps that I do not undertand why you installed. them. … Maybe to solve some dependencies? I don’t use them. But I do not think any of those apps will impact your sound playback for flash, although they WILL impact amarok and they will impact other players that you have.

Keep them enabled. I have the same and mine are are enabled. I also have NPAPI Wraper 1.2.2 - nspluginwrapper is a cross-platform NPAPI plugin viewer, in particular for linux/i386 plugins. This software is available under the terms of the GNU General Public licence … I think thats because I have a 64-bit openSUSE installed. Is your openSUSE-32 bit or 64-bit? If 64-bit, I hope you have not been mixing 32-bit packages.

If 64-bit, then missing that NPAPI Wrapper is your problem.

Specifically, what web site(s) can you NOT play?

I went through and changed them all to the packages from packman. Thank you.

To answer your questions: 1)I am on a 32 bit machine. And 2) I cannot play sounds on youtube, pandora, or other random sites I found that play different sounds through flash (like soundrangers.com)

What extensions do you have installed in your firefox? Have you restarted your PC since updating your sound?

Victory! Restarting did the job.

I guess I thought that since it’s Linux, just restarting the browser would take care of it…

I tried restarting a couple times early in the process, but didn’t after any of the later major changes.

Thanks oldcpu, for all the effort put into this. I really appreciate it.

It looks like everything is working now. :smiley:

Congratulations. Glad to read its working now.

Its not always that painful. Typically within an hour of a fresh installation I have all my multimedia setup. Once one knows how to setup their repos, and what applications to put in place, it is very smooth and quick.