No Sound on HP ENVY x360 13

I have updated to the latest BIOS and updated the Kernel, added alsa-firmware as advised. I’ve now gotten to the point that I can play a sound file and see the bar under the volume level in Pulseaudio>Output Device go back and forth in time to the music, but no sound is audible.

Your ALSA information is located at http://www.alsa-project.org/db/?f=676a9be6a4d20abf889084b909244d4994159377

Please inform the person helping you.

**linux-19m3:~ #** uname -a     
Linux linux-19m3.suse 4.11.3-1.g7262353-default #1 SMP PREEMPT Thu May 25 17:55:04 UTC 2017 (7262353) x86_64 x86_64 x86_64 GNU/Linux
**linux-19m3:~ #** cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k4.11.3-1.g7262353-default.
**linux-19m3:~ #** cat /proc/asound/modules
 0 snd_hda_intel
**linux-19m3:~ #** cat /proc/asound/cards   
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xdf328000 irq 144
**linux-19m3:~ #**

almost forgot: KDE

and When PC dual boots into windows 10 sound is OK

After a quick examination of the ALSA layer from your diagnostic information, it looks ok to me (but I might be wrong about that). I assume that you’re trying to play sound through the internal laptop speakers (as opposed to HDMI outputs)?

Let’s have a look at your PA configuration…

pactl list sinks

Thanks for the quick reply

:~> pactl list sinks
Sink #0
        State: SUSPENDED
        Name: alsa_output.pci-0000_00_1f.3.analog-stereo
        Description: Built-in Audio Analog Stereo
        Driver: module-alsa-card.c
        Sample Specification: s16le 2ch 48000Hz
        Channel Map: front-left,front-right
        Owner Module: 6
        Mute: no
        Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                balance 0.00
        Base Volume: 65536 / 100% / 0.00 dB
        Monitor Source: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
        Latency: 0 usec, configured 0 usec
        Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY  
        Properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "CX8200 Analog"
                alsa.id = "CX8200 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xdf328000 irq 144"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "9d71"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "384000"
                device.buffering.fragment_size = "192000"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                alsa.mixer_name = "Conexant CX8200"
                alsa.components = "HDA:14f12008,103c82b7,00100101 HDA:8086280b,80860101,00100000"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        Ports:
                analog-output-speaker: Speakers (priority: 10000)
                analog-output-headphones: Headphones (priority: 9000, not available)
        Active Port: analog-output-speaker
        Formats:
                pcm
:~> 

(I will be slow to reply again, off to bed soon)

Ok, that looks as expected for analog sound output.

This might be significant, although I don’t see anything in your amixer showing a relevant mixer level being muted…

Node 0x10 [Audio Output] wcaps 0xc1d: Stereo Amp-Out R/L
  Control: name="Headphone Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Control: name="Headphone Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Device: name="CX8200 Analog", type="Audio", device=0
  Amp-Out caps: ofs=0x4a, nsteps=0x4a, stepsize=0x03, mute=1
  Amp-Out vals:  [0x80 0x80]
  Converter: stream=1, channel=0
  PCM:
    rates [0x540]: 48000 96000 192000
    bits [0xa]: 16 24
    formats [0x1]: PCM
  Power states:  D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x11 [Audio Output] wcaps 0xc1d: Stereo Amp-Out R/L
  Control: name="Speaker Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Control: name="Speaker Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-Out caps: ofs=0x4a, nsteps=0x4a, stepsize=0x03, mute=1

The settings also look ok to me - although there is a LOT in the diagnostic script output I am not familiar with. The dmesg has your audio being restarted 3x within 15-minutes of boot, but I assume that is something you are doing manually ?

Can you try this command in a konsole, as both a regular user and with root permissions:


pasuspender -- aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav

Do you get any sound from either ?

The idea here is to bypass pulse audio and see if sound plays directly with alsa.

quite likely something I did manually

Can you try this command in a konsole, as both a regular user and with root permissions:

pasuspender – aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav

Do you get any sound from either ?

The idea here is to bypass pulse audio and see if sound plays directly with alsa.

I now have sound, though not because I “fixed” anything. I have no confidence that will last. A few minutes ago I had occasion to reboot into BIOS setup. (I made no changes, it was only a lookup.) When I rebooted I had sound for the first time. l’m reasonably certain that will fail again soon, and when it does I will post the results you’re looking for.

I was right it did fail again, only about 20 minutes after I posted the above.

Can you try this command in a konsole, as both a regular user and with root permissions:
Code:
pasuspender – aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav
Do you get any sound from either ?

The idea here is to bypass pulse audio and see if sound plays directly with alsa.

:~> pasuspender -- aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin  
Hardware PCM card 0 'HDA Intel PCH' device 0 subdevice 0
Its setup is:
  stream       : PLAYBACK
  access       : RW_INTERLEAVED
  format       : S16_LE
  subformat    : STD
  channels     : 2
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 16
  buffer_size  : 24000
  period_size  : 6000
  period_time  : 125000
  tstamp_mode  : NONE
  tstamp_type  : MONOTONIC
  period_step  : 1
  avail_min    : 6000
  period_event : 0
  start_threshold  : 24000
  stop_threshold   : 24000
  silence_threshold: 0
  silence_size : 0
  boundary     : 6755399441055744000
  appl_ptr     : 0
  hw_ptr       : 0
# +                                                | 02%


Sound is audible. Similar result with root permissions

ALSA information for the other identical laptop (the one with working sound) is located at http://www.alsa-project.org/db/?f=a9de6edf438179003ba764c4defe22ce56c6ecae

Note: you may notice that the PC with sound has a 4.10.x kernel and the one that does not has 4.11.x however all symptoms were the same when both were on 4.10.x

EDIT: not sure how valid the above test with pasuspender is, as I just realized that sound is working again. Unfortunately I had not rechecked before running the command. (#@$&%^!!) I will have to wait 'til it fails again to be sure of running a valid test. I wonder if the test altered the environment in some way that allowed sound to work. (?) I guess I won’t know until I can reproduce the sequence of events after a failure.

In the above, your PC mixer is misconfigured. Look at this:


Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 74
  Mono: Playback 74 [100%] [0.00dB] **[off]**
....
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Mono:
  Front Left: Playback 74 [100%] [0.00dB]** [off]**
  Front Right: Playback 74 [100%] [0.00dB] **[off]**

“OFF” setting here means the Master volume is muted. If it is muted, sound is not likely.

Further the ‘speaker’ is also muted in the mixer. The same is true. If it is muted sound is not likely.

Try to be as logical as possible wrt tests. The command “pasuspender”, from what I have read, only suspends pulse audio for the command on the same command line. It is not to have any permanent settings.

I have the sense something was done either by an app, or by yourself, to put the master volume on mute, and put the ‘speaker’ volume on mute. It should NOT happen randomly.

Anyway, it reads like progress is being made - we just need to go the extra mile to find “cause and effect” wrt why you have your sound stop functioning at times (and not functioning at other times).

I noticed all the factors you’ve mentioned, and I can not disagree with your logic for a moment, however I have scrupulously watched pavucontrol every time I’ve lost sound and found that nothing is shown to be muted all throughout this whole process. It’s clear that something is being muted at random, though I’m at a loss to know what since I’ve only found an indication in pavucontrol that the master volume was muted one time (two weeks ago, and I can account for that occasion through operator carelessness).

Of course what I’ve reported above makes no sense, but I’ve checked and rechecked numerous times. It would be so much easier to figure this out if the issue was consistent and repeatable, but that’s not the case here.

The good news is that I’ve now had sound for almost 48 hours. (??) Unfortunately that’s also bad news from the point of view of getting a diagnosis.

What are your thoughts on what tests I should run now,while I have sound, and then again should I lose it again? Tests that might yield valid results for comparison.

When you lost sound, check to see if it is a mixer setting. You can do so (and have a record afterward) by running the diagnostic script in a konsole as a regular user (NOT as root):


/usr/sbin/alsa-info.sh

If after looking at that, you see nothing incorrect wrt the mixer settings, then check to see if you have sound via command line in a konsole as a regular user:


aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav

Make note of any error you get when sending the above.

Then if after trying the above and you get no sound, try the same command with pulse audio suspended in a konsole as a regular user:


pasuspender -- aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav 

Again, make note of any error you get when sending the above - and see if it gives a clue as to why sound is not working.

Been out of country caring for a human thought to be at EOL, so this project fell down on the priority list. Thankfully she surprised us all and bounced back somewhat (at 103 yrs), so I’m back home now.

I’ve now been without sound again for two weeks, so:

http://bit.ly/2tFjAZx

greyshark@linux-19m3:~> aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav

aplay: main:786: audio open error: Device or resource busy
greyshark@linux-19m3:~> 

greyshark@linux-19m3:~> pasuspender -- aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav  
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin  
Hardware PCM card 0 'HDA Intel PCH' device 0 subdevice 0
Its setup is:
  stream       : PLAYBACK
  access       : RW_INTERLEAVED
  format       : S16_LE
  subformat    : STD
  channels     : 2
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 16
  buffer_size  : 24000
  period_size  : 6000
  period_time  : 125000
  tstamp_mode  : NONE
  tstamp_type  : MONOTONIC
  period_step  : 1
  avail_min    : 6000
  period_event : 0
  start_threshold  : 24000
  stop_threshold   : 24000
  silence_threshold: 0
  silence_size : 0
  boundary     : 6755399441055744000
  appl_ptr     : 0
  hw_ptr       : 0
#+                                                 | 00%
greyshark@linux-19m3:~> 


still no sound

Again, make note of any error you get when sending the above - and see if it gives a clue as to why sound is not working.

Note: when I first posted the previous entry something scrambled the whole thing quite spectacularly. I was most of the way through fixing it with edits when my time to edit expired. Sorry for any confusion.)

Your pc has a Conexant CX8200 - thats a new hardware audio codec for me. I recall a year 2015 patch by Takashi noting “It’s supposed to be equivalent with CX20724” (reference: https://patchwork.kernel.org/patch/7733061/).

On your PC the output of the ‘pasuspender’ command giving no audio suggests to me this is an underlying alsa problem and not a pulse audio problem.

As far as I can tell from the thread you never confirmed deano_ferrari’s request that you confirm you are trying to send sound throught the audio speakers and not the HDMI.

This surprised me in the diagnostic script:


!!Loaded sound module options
!!---------------------------

!!Module: snd_hda_intel
    align_buffer_size : -1
    bdl_pos_adj : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    beep_mode : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
    enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
    enable_msi : -1
    id : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
    index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    jackpoll_ms : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
    model : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
    patch : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
    position_fix : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    power_save : 0
    power_save_controller : Y
    probe_mask : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    probe_only : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
    single_cmd : -1
    snoop : -1

Did you create a custom /etc/modprobe.d/50-sound.conf file ? Is there such a file and what is its contents ? I ask because I did not expect to see any “sound module options” and I am asking myself if you set something up there which is possibly incorrect.

If no /etc/modprobe.d/50-sound.conf file, then my next question is did you try to configure the audio with YaST hardware sound ?

through the speakers only, haven’t tried an HDMI connection yet.

Did you create a custom /etc/modprobe.d/50-sound.conf file ?
no custom file, just the one created on install, and that was empty

Is there such a file and what is its contents ?

If no /etc/modprobe.d/50-sound.conf file, then my next question is did you try to configure the audio with YaST hardware sound ?

Yesterday I was advised to delete the file, reboot then use YAST to configure the audio. I did delete and reboot, but when I entered YAST>Sound I found that the only ‘card model’ detected was only id’d as “Intel Corporation” and it was not configured. At that point I realized I had no idea what to do next. Not wishing to make things worse I held off until I get some guidance.

I’ll be grateful for any suggestions you might offer.

Intel is ok. Look at the script output you provided in the 1st post:


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xdf328000 irq 144

So go ahead and configure via YaST. YaST will likely create an /etc/modprobe.d/50-sound.conf file, and it will then restart your PC audio (alsa) and restart pulse audio.

Give that a try and lets see if it works.

One can always delete any /etc/modprobe.d/50-sound.conf file if one wishes undo what YaST has done for the sound configuration.