No sound on HP dv7-1080ew (Intel 82801I ICH9 Family)

I have no sound on a HP Pavilion dv7-1080ew laptop with the “Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)” (as reported by “lspci”) running OpenSUSE 11.1 with KDE4.1.

Running

speaker-test -c2 -l5 -twav

from Konsole both as a standard and root user gives no sound.

Output of

sudo /usr/sbin/alsa-info.sh

is located at http://www.alsa-project.org/db/?f=d71bc811de370b122ba4df3e0826afd1968466fa

~> rpm -qa | grep alsa
alsa-driver-kmp-default-1.0.19.20090122_2.6.27.7_9.1-2.1
alsa-firmware-1.0.19.git20090120-1.1
alsa-plugins-pulse-1.0.18-6.12
alsa-tools-1.0.19.git20090120-1.3
alsa-oss-1.0.17-1.37
alsa-utils-1.0.19.git20090120-1.3
alsa-plugins-1.0.18-6.12
alsa-1.0.19.git20090122-1.1
~> rpm -qa | grep pulse
pulseaudio-module-zeroconf-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-jack-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
pulseaudio-module-lirc-0.9.12-9.6
pulseaudio-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
pulseaudio-module-x11-0.9.12-9.6
~> rpm -q libasound2
libasound2-1.0.19.git20090122-1.1
~> cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=1 model=hp-m4
~> uname -a
Linux nut 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

I hope that’s enough information :slight_smile:

From what I can see, your sound should be working. …

I note you have this:

~> rpm -qa | grep alsa
alsa-driver-kmp-default-1.0.19.20090122_2.6.27.7_9.1-2.1
alsa-firmware-1.0.19.git20090120-1.1
alsa-plugins-pulse-1.0.18-6.12
alsa-tools-1.0.19.git20090120-1.3
alsa-oss-1.0.17-1.37
alsa-utils-1.0.19.git20090120-1.3
alsa-plugins-1.0.18-6.12
alsa-1.0.19.git20090122-1.1 

there was an update to alsa done earlier today. Give that a try. Specifically, with your PC connected to the internet, type “su” (no quotes) in a gnome terminal or konsole (enter root password when prompted) and copy and paste the following six commands in sequence, executing them one at a time:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.1/ multimedia 
 zypper install alsa alsa-utils alsa-oss alsa-plugins alsa-plugins-pulse alsa-tools alsa-firmware libasound2 
 zypper rr multimedia 
 zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1/ multimedia 
zypper install alsa-driver-kmp-default  
 zypper rr multimedia 

and restart your PC and test your sound with the speaker test.

I am assuming here you keep the same /etc/modprobe.d/sound file which looks like:

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=1 model=hp-m4

I’ve seen that code work for HP DV7 users with the Codec: IDT 92HD71B7X, so I anticipate it should work on your PC. If that does not work, then replace “hp-m4” in that file with another option from the HD-audio-model.txt file:

STAC92HD71B*
============
  ref		Reference board
  dell-m4-1	Dell desktops
  dell-m4-2	Dell desktops
  dell-m4-3	Dell desktops
  hp-m4		HP dv laptops

i.e. you could try “dell-m4-1” instead of “hp-m4”, and restart your PC, test your audio. If that doesn’t work, you could try “dell-m4-2” … etc … or “ref” … or “dell-m4-3” …

But typically “hp-m4” works.

I assume sound works in another operating system (such as Vista or windows) so you are confident this is not a hardware problem ?? Please confirm!

Another syntax for the /etc/modprobe.d/sound file you could try is the one that comes from YaST (as oppposed to alsaconf). i.e. something like :

options snd slots=snd-hda-intel
options snd-hda-intel model=hp-m4 enable_msi=1
alias snd-card-0 snd-hda-intel 

… also note that running alsconf or yast > hardware > sound > edit after making the file edit will remove one’s edit from the /etc/modprobe.d/sound file (causing sound to disappear) so be careful as to what you do in what order …

For NNTP users, I did an edit to the above that may have not made the NNTP cut off, so be cautious in terms of what you read in the above post.

First of all - hardware works. I dual-boot with Vista and sound is OK there. More importantly, I had a test install of Ubuntu 8.10 before openSUSE 11.1 and sound was working fine there after I added “options snd-hda-intel enable_msi=1” to /etc/modprobe.d/alsa-base.

In openSUSE I still have no sound however. I tried all the “model” options and none worked. The only thing I noticed was a notification message after logon titled “phonon” saying something like “playback device HDA Intel (STAC92xx Analog) is not working, switching back to HDA Intel (NVIDIA HDMI)” (the translation may be innacurate because I’m using Polish locale and the message is in Polish). The message showed up most of the time, but not always (or perhaps I didn’t notice it as it was displayed for a very short time).

The other weird behaviour was some error message “ALSA lib pcm_dmix.c:975: (snd_pcm_dmix_open) unable to create IPC semaphore” when using models dell-m4-2 and dell-m4-3. It showed up when running “speaker-test -c2 -l5 -twav” only as a non-root user.

If this worked under Ubuntu, then there is a good chance we can get this to work under Ubuntu. If you still have Ubuntu installed, you could run the diagnostic script on Ubuntu, and post the output URL here, and then also run the same diagnostic script on openSUSE, and post the output URL here. I could then compare the two scripts content, and possibly come up with a change to your configuration to get sound working on openSUSE. The script is:/usr/sbin/alsa-info.sh It may be necessary to run that script with root permissions. Only post the URL that script provides. Just the URL. If you no longer have Ubuntu installed, you could boot to the Ubuntu live CD and if sound works from the Ubuntu live CD, then run the script from that.

In any event, it would be useful to see the output of that script from openSUSE, so we can do a quality check on your configuration. Also the output of:rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
cat /etc/modprobe.d/soundso we can do a quality check on that.

In addition to my previous post, sometimes, running dmesg immediately after booting one’s PC will give an indication as to what the sound problem might be. So immediately after booting your PC, with your PC connected to the internet, copy and paste the following into a gnome terminal or kde konsole:
dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a and post here the URL provided (just the URL)

I have a couple real dumb questions re: your mixer. I am not an alsa developer (I’m just a regular user like you) and I do not have your hardware. But I am puzzled by the following items in your mixer:
!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [Intel]
Card hw:0 ‘Intel’/‘HDA Intel at 0xdf300000 irq 214’
Mixer name : ‘Nvidia MCP78 HDMI’
Simple mixer control ‘IEC958’,0
Mono: Playback on]
Simple mixer control ‘IEC958 Default PCM’,0
Mono: Playback on]
Simple mixer control ‘IEC958’,1
Mono: Playback on]
Simple mixer control ‘Analog Loopback’,0
Mono: Playback on]
Simple mixer control ‘Analog Loopback’,1
Mono: Playback on]
Simple mixer control ‘Speaker’,0
Front Left: Playback 3 5%] -45.75dB] [on]
Front Right: Playback 3 5%] -45.75dB] [on]
Why do you have IEC958 (digital audio) ON ? Is it supposed to be ON ? Was that necessary for ubuntu? Why do you have “analog loopback” ON ? Should that not be OFF ? Was it necessary to switch ON in Ubuntu? Why do you have speaker at 5%? Is it supposed to be some low percentage? Is it not relevant to your laptop speaker?

It must have been one of the mixer settings. I’ve experimented with them before and left them it such state. After switching off the digital and loopback channels, sound is working fine :slight_smile:

And just for confirmation, my /etc/modprobe.d/sound looks like that:

options snd slots=snd-hda-intel
options snd-hda-intel enable_msi=1 model=hp-m4
alias snd-card-0 snd-hda-intel

and I’m using Alsa versions:

alsa-driver-kmp-default-1.0.19.20090129_2.6.27.7_9.1-1.1
alsa-firmware-1.0.19.git20090120-1.1
alsa-plugins-1.0.19.git20090123-1.3
alsa-oss-1.0.17.git20080715-2.15
alsa-utils-1.0.19.git20090120-1.5
alsa-plugins-pulse-1.0.19.git20090123-1.3
alsa-tools-1.0.19.git20090120-1.6
alsa-1.0.19.git20090129-1.1

Congratulations on getting sound to function.

Thank you also for sharing your solution that worked on your HP DV7-1080ew.