no sound on hp dv6-1250el

Hi, I have no sound on a HP Pavilion dv6-1250el laptop running OpenSUSE 11.1 with kde 3.5.10


# cat /proc/asound/card0/codec#0 | grep Codec
Codec: IDT 92HD75B3X5

Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03) 01:00.1 
Audio device: ATI Technologies Inc RV730XT Audio device [Radeon HD 4670]

Output of is located at

Do you need other output command?? can you help me??


OK, I note a 32-bit openSUSE-11.1 with the kernel and the latest 1.0.21 version of alsa. I see your HP DV6 has the IDT 92HD75B3X5 hardware audio codec.

For the HP DV6 with an IDT 92HD75B3X5 hardware audio codec, please add this line to the START of the file /etc/modprobe.d/sound :

options snd-hda-intel model=hp-m4 enable_msi=1

then restart your PC and test your sound.

You can edit the /etc/modprobe.d/sound file

  • in gnome by typing: gnomesu gedit /etc/modprobe.d/sound
    #and enter root password when prompted - in kde by typing: kdesu 'kwrite /etc/modprobe.d/sound’
    #and enter root password when prompted.

I note this worked for some other HP DV6 users

If the above does not work, please provide the output of:
rpm -qa | grep alsa
rpm -q libasound2
cat /etc/modprobe.d/sound

no…it doesn’t work :frowning: so:

# rpm -qa | grep alsa

# rpm -q libasound2
cat /etc/modprobe.d/sound
options snd-hda-intel model=hp-m4 enable_msi=1
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

No worries. Lets update alsa.

Leave that setting (in the /etc/modprobe.d/sound file) in place, and then for your kernel, send the following six commands (from a terminal with root permissions with your pc connected to the internet) in sequence:

zypper ar multimedia
zypper install alsa alsa-docs libasound2
 zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

restart your PC and test your sound.

If that does not work, then leave that in place and then update your alsa to the daily snapshots by sending (from a terminal with root permissions with pc connected to the internet) the following six zypper commands:

zypper ar multimedia
zypper install alsa alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins alsa-plugins-pulse libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

you may be told some are already installed. Continue sending that and subsequent commands anyway. Then restart your PC and test the sound.



Don’t forget when testing your sound to move your master, PCM and speaker settings up to 95%. When testing for sound, do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is “kmix” (the small speaker in right hand corner). In Gnome your mixer is “alsamixer”.

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

thanks to everybody!!! It works!!! yessssss


Great ! Congratulations !

mmm I can hear sound in avi and mp3, so it’s ok!!

I can see youtube video on firefox, but I can’t hear its sound!! why??

Typically, to see videos with firefox, one needs the application flash-player and either the application mplayerplug-in (which is being depreciated) or the application gecko-mediaplayer. Please ensure you have flash-player installed, and have either mplayerplug-in or gecko-mediaplayer.

Now, I also note your openSUSE-11.1 is a 32-bit version. Sometimes 32-bit openSUSE-11.1 users, even though they have the applications I noted installed, still have a problem with audio. This could be the problem you are experiencing. In which case, the solution that works sometimes is to remove the application libflashsupport (but keep flash-player). Restart firefox, and test.

ok, it works!! thank a lot!!!