no sound on HP DV5-1140eg

I cant get sound to work on a HP DV5-1140eg.
tsalsa output is at tsalsa.txt - (beta)

bug report is already filed, under

new alsa modules from No sound with kernel in opensuse 11 - Page 2 - openSUSE Forums are installed, it changed the output a bit but still no sound.

now i get this in dmesg:

sai:/etc/modprobe.d # rcalsasound start
Starting sound driver: hda-intel done
sai:/etc/modprobe.d # dmesg
HDA Intel 0000:00:1b.0: PCI INT A → GSI 22 (level, low) → IRQ 22
HDA Intel 0000:00:1b.0: setting latency timer to 64
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3490: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3494: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3498: hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3499: mono: mono_out=0x0
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3507: inputs: mic=0xb, fmic=0x0, line=0xe, fline=0x0, cd=0x0, aux=0x0
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/…/…/alsa-kernel/pci/hda/patch_sigmatel.c:2961: stac92xx: dac_nids=1 (0x10/0x0/0x0/0x0/0x0)
input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input51
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/…/…/alsa-kernel/pci/hda/hda_generic.c:679: hda_generic: no proper input path found
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/…/…/alsa-kernel/pci/hda/hda_generic.c:427: hda_generic: no proper output path found
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/…/…/alsa-kernel/pci/hda/hda_generic.c:1026: hda_generic: no PCM found
input: HDA Intel at 0xdf300000 irq 22 Line In at Ext Rear Jack as /devices/pci0000:00/0000:00:1b.0/input/input52
input: HDA Intel at 0xdf300000 irq 22 Mic at Ext Front Jack as /devices/pci0000:00/0000:00:1b.0/input/input53
input: HDA Intel at 0xdf300000 irq 22 HP Out at Ext Front Jack as /devices/pci0000:00/0000:00:1b.0/input/input54

I have helped HP DV5 users and HP DV7 users get their sound working, and typically I find it requires

  • 2.6.27 kernel from openSUSE-11.1 and *]latest rpm-packaged/git alsa versions and *]edit to /etc/modprobe.d/sound file

It reads to me that you have done 2 of the 3, but not the 3rd. Please, can you provide the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Now your HP DV5 has a "Codec: IDT 92HD71B7X "

In the ALSA-Configuration.txt file for 1.0.18a of alsa, it has:

	  ref		Reference board
	  dell-m4-1	Dell desktops
	  dell-m4-2	Dell desktops

In addition to that, from following various sound threads on other linux distributions, I believe there is one, and possibly two other undocumented codes (undocumented because this is very recent) which are hp-m4 and/or dell-m4 .

So, my recommendation, AFTER I get to see your /etc/modprobe.d/sound file, “MAY” be to add this line at the start of that file (ie add an extra line at the start):

options snd-hda-intel model=hp-m4 enable_msi=1

and then restart your pc and test your sound. (Its possible the end of the file is a better place to put the line - not sure).

Anyway, I’m curious to see what alsa rpms you have installed.

sai:~ # rpm -qa | grep alsa
sai:~ # rpm -qa | grep pulse
sai:~ # rpm -q libasound2
sai:~ # uname -a
Linux sai #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Lin
sai:~ # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.uI7Vp9nVK5B:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel
sai:~ #

OK, this is a problem. You should NOT have two alsa drivers.

Please remove the alsa-driver-unstable-kmp-pae and reboot.

ok, please change this file to:

options snd slots=snd-hda-intel
options snd-hda-intel model=hp-m4 enable_msi=1
# u1Nb.uI7Vp9nVK5B:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel 

In your case, I do not think the location of the line is critical. Then restart alsa with root permissions (rcalsasound restart) and test your audio.

I think the HDMI in your laptop is supported by Linux. I do not know how, but I was told on IRC #alsa that there there is a patch coming for alsa to address HDMI on your laptop’s hardware audio codec.

did both, rebooted, no change in behaviour:
no sound, same error in dmesg output…

and alsa-driver-unstable-kmp-pae gets reinstalled next time yast checks dependencies.

This does not read right to me, unless the alsa/SuSE dev has recently change the way this is supposed to work.

I have installed the alsa-driver-kmp-pae kernel before (on a different openSUSE version) and it did not require the debug as a dependency. You need to determine what package is requiring that as a alsa-driver-unstable-kmp-pae dependency.

You could try rolling back your alsa to the original version, which means removing this and your more current alsa versions. Then re-installing the latest alsa-driver-kmp-pae … hopefully you will not get that kernel this time.

The problem with your current setup is you could end up having the driver for a different (debug) kernel being used, which would mean your sound will not function. When I read your dmesg, that is suggested as a viable possibility to me.

ok, i reinstalled alsa-driver-kmp-pae after uninstalling the unstable one, then, after changing the options as suggested, rebooted… and i have sound. just with lots of static. any suggestions on how to get rid of that?

What model setting do you have applied in the /etc/modprobe.d/sound file?

Check your mixer. Back off on your volume levels to reduce the distortion. You may need to go to YaST > Hardware > Sound > Other > Volume and move those volume levels up fairly high, and move down the PCM/Master volume levels in your mixer.

Check your mixer to ensure you do not have a microphone on that is causing static.

mathias@sai:~> cat /etc/modprobe.d/sound

options snd-hda-intel enable_msi=1 model=hp-m4
options snd slots=snd-hda-intel

u1Nb.uI7Vp9nVK5B:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

i already tried to lower the mixer levels, still getting static, just not as loud.

Did you check your mic?

Can you run the script output again so I can see what you believe to be the best mixer settings? /usr/sbin/ and post here the URL it provides

I understand. … The idea was to RAISE the mixer settings in YaST > hardware > sound > other > volume, so that you could LOWER the mixer settings in your mixer (master/pcm) even more.

another lil thing i just found:

i’m using skype.

if i set the skype audio device to “HDA Intel (hw:Intel,0)” and play the test sound, i dont get static… if i set it to “pulse” (i assume that means pulseaudio) i get static.

thats what i did… max them in yast, lower them in kmix. didnt help.
but… (see previous post)

OK, … someone else will need to help you on Skype. I never use it.

Good luck.

all input channels are set to zero and are switched off.

and my comment about skype was not skype-related, only to point out that skype testsounds are staticky when i use pulseaudio output, and not staticky when i play directly to the hardware.

I don’t have your hardware, so I can only ask questions …

I note this in your PC’s mixer:

!!Amixer output
!!-------Mixer controls for card 0 [Intel]
Simple mixer control ‘Master’,0
Mono: Playback 127 [100%] [0.00dB] [on]
Simple mixer control ‘PCM’,0
Front Left: Playback 207 [81%] -9.60dB]
Front Right: Playback 207 [81%] -9.60dB]
Simple mixer control ‘IEC958’,0
Mono: Playback on]
The master volume @ 100% could cause distortion. Can you back to off to 75% to 80% or so?

Does IEC958 need to be ON ?