No sound on headphones

I have just upgraded my Gateway laptop with OpenSuSE 11.1 (clean reinstallation) and I’m having trouble with sound system:

First, if I try to play some wav file using the play line-command, I get this message:

ALSA lib pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
play formats: can’t open output file `default’: cannot open audio device

Then, I can restart alsasound and the file can be played. However, if I plug the headset, there is no sound at all.

I ran the script and got a bunch of information; so much that I’m not sure about what I can do with it:

!!ALSA Information Script v 0.4.56

!!Script ran on: Sun Feb 22 16:07:04 UTC 2009

!!Linux Distribution

Welcome to openSUSE 11.1 - Kernel \r (\l). openSUSE 11.1 (i586) LSB_VERSION=“core-2.0-noarch:core-3.2-noarch:core-2.0-ia32:core-3.2-ia32”

!!Kernel Information

Kernel release:
Operating System: GNU/Linux
Architecture: i686
Processor: i686
SMP Enabled: Yes

!!ALSA Version

Driver version: 1.0.17
Library version:
Utilities version: 1.0.18

!!Loaded ALSA modules


!!Sound Servers on this system

Installed - Yes (/usr/bin/pulseaudio)
Running - No

ESound Daemon:
Installed - Yes (/usr/bin/esd)
Running - No

!!Soundcards recognised by ALSA

0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf3300000 irq 22
HDA ATI HDMI at 0xf3010000 irq 17

!!PCI Soundcards installed in the system

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)
01:00.1 Audio device: ATI Technologies Inc RV630/M76 audio device [Radeon HD 2600 Series]

The complete output could be read at:

I’ve found lots of reports about sound problems, but I haven’t found an answer to fix my problem


The script indicates your PC has a stac9205. I searched the alsa web site and did not notice any new alsa updates for the stac92xx since 1.0.16 of alsa.

There are model options one can apply to the /etc/modprobe.d/sound file in case the auto probe upon boot did not select an optimal configuration for one’s sound driver.

Can you provide some more information on installed audio application/os software? ie provide the output of: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/soundCopy and paste the above one line at a time into a gnome terminal or kde konsole and paste here the output.

Thank you for your quick response.

The following lines show the output for the commands:

rpm -qa | grep alsa

rpm -qa | grep pulse

rpm -q libasound2

uname -a
Linux linux-660t #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

Again, thanks for your help

OK, that looks good.

Try some edits to your /etc/modprobe.d/sound file. I note from the ALSA-Configuration.txt file for 1.0.16 of alsa, the following list:

	  ref		Reference board
	  dell-m42	Dell (unknown)
	  dell-m43	Dell Precision
	  dell-m44	Dell Inspiron

So, lets start by trying “dell-m42” (I know it says dell, but often this will work with other laptop makes). … Change your /etc/modprobe.d/sound file to:

options snd-hda-intel model=dell-m42
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

save the change and restart your alsa sound drive with su -c ‘rcalsasound restart’ and enter root password when prompted, restart your mixer, and test your sound/headphones. If that does not work, then replace “dell-m42” with “dell-m43”, restart alsa, restart your mixer, and test again. Try the same for “dell-m44” and “ref” if the previous do not work.

If that fails, then we could try an alsa update to 1.0.19 of alsa. I can provide a link to some rpms for that, if we come to that.

Well, I tried the four suggestions and none of them seemed to work. So, I went back to the original file (by removing the option line) and restarted alsasound. Then I noticed that sound comes out through the computer speakers even when the headset is pluged in. That didn’t happen before; before, the sound was mute when I pluged in the headset (as it was expected, except that the sound did not come through the headphone)

Was that not there before, or simply that you did not notice it. What is the output of your dmesg after a fresh boot ? ie copy and paste the following into a terminal (with pc connected to internet) and post here the output URL:
dmesg > dmesg.txt && curl -F file=@dmesg.txt

If you wish to try an alsa update, you can do so by copy and pasting the following six zypper commands into a terminal (with root permissions) and post one at a time, in sequence:

 zypper ar multimedia 
 zypper install alsa alsa-tools-gui alsa-utils alsa-tools alsa-plugins alsa-plugins-pulse alsa-oss alsa-firmware libasound2  
 zypper rr multimedia  
 zypper ar multimedia  
 zypper install alsa-driver-kmp-pae  
  zypper rr multimedia  

After the update is done, restart your PC and test your sound and headphones.

My reference is here:
Alsa-update - openSUSE

Note you may need to try those 4 model options, one at a time, all over again.

Hi again,
No, it was there. During my testing (before opening this thread), I tried to play some files several times and sometimes, while a file being played and while the sound was being produced, I plugged in the headset and the sound stopped; then I put the headset on noticing that there was not sound.

Anyway, I ran the command and the output was this:

dmesg > dmesg.txt && curl -F file=@dmesg.txt
dmesg.txt - (beta)

I note this:

HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
HDA Intel 0000:00:1b.0: setting latency timer to 64
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3051:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055:    hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064:    inputs: mic=0xb, fmic=0x0, line=0x0, fline=0x0, cd=0x0, aux=0x0
ALSA sound/pci/hda/patch_sigmatel.c:2805: dac_nids=1 (0x10/0x0/0x0/0x0/0x0)
input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input10
vendor=8086 device=2a01
HDA Intel 0000:01:00.1: PCI INT B -> GSI 17 (level, low) -> IRQ 17
HDA Intel 0000:01:00.1: setting latency timer to 64

and I can not see anything wrong with that, although I do not know much about that sort of technical level. Sometimes one gets a real obvious message/error in the dmesg. I see none there.

Any luck with the alsa update?

I had problems after updating alsa:system turned excesive slow and I decided to reinstall the hole thing.

I noticed, however, that mixer included a channel for headphones, which was not there before. It did not help setting it high, any way.

So, the problem is still there: sound through PC speakers, but not through headphones.

I’ll keep working on that…