No sound on HDMI connection with ALC889A

Setting up a new MythTV system using a fairly new motherboard - Gigabyte GA-EG45M-DS2H that I have partial success with the sound. Sound works on the outputs I have tested so far except for the HDMI. I have read through a number of posts relating to similar issues with sound. Based on a number of recommendations I have updated to the latest ALSA drivers and so far no changes in this status. The only change I have noticed is that I now have an HDMI option to select in the Sound panel. Sound Tests with that option selected is pure silence.

I have tried a number of the model options with no change in results as well.

One other item of note is that the sound volume is greatly reduced using ALSA. Testing with the OSS output I have better sound volume defaults.

This may all simply be an issue of the hardware ahead of the software drivers as I see other issues with ALC889A posted around.

Any suggestions to enable the HDMI sound are greatly appreciated.

alsa-info posted to:

Following seem to be the generally requested info for sound issues:

rpm -qa | grep alsa


rpm -qa | grep pulse


rpm -qa | grep libasound


uname -a

Linux mythtv2 #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound

u1Nb.GDpQEAJ8ayE:GA-EP45-DS5 Motherboard

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=1 model=auto

Are you a Gnome or a KDE3 or a KDE4 user? If a gnome user, what is the output of:rpm -q padevchooser pavucontrol pavumeter paman paprefs

I do not understand this “testing with the OSS”. Can you explain please?

Indeed, that could be. HDMI audio does not work yet on my new Dell Studio 15 laptop. It was less than 6 weeks ago that I was fortunate to have an alsa dev give my laptop priority and come up with a fix for basic audio on it.

I note this in your mixer:

!!Amixer output

!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xe9700000 irq 4348’
Mixer name : ‘Intel G45 DEVELK’
Simple mixer control ‘IEC958’,0
Capabilities: pswitch pswitch-joined cswitch cswitch-joined
Mono: Playback [off] Capture [off]
Simple mixer control ‘IEC958 Default PCM’,0
Capabilities: pswitch pswitch-joined
Mono: Playback [on]
Simple mixer control ‘IEC958’,1
Capabilities: pswitch pswitch-joined
Mono: Playback [on]Does that 1st mixer control need to be on ? (a wild guess).

In truth, until I learn more about HDMI myself, I am not able to help here. Out of curiousity (and apologies if I recommended it and forgot), what made you decided on the /etc/modprobe.d/sound option settings of “options snd-hda-intel enable_msi=1 model=auto” ?

If you are using gnome, you could consider installing (if not installed) padevchooser, pavucontrol, pavumeter, paman, and paprefs, and then use them to try activate your HDMI (thats just a wild guess on my part).

Thanks for the follow up.

  1. I am a Gnome user on this system. Output requested is:

rpm -q padevchooser pavucontrol pavumeter paman paprefs


In the Sound panel I can select the device for playback and the options include entries for ALSA as well as some Open Sound System devices or OSS. I found it interesting that I have louder sound coming out of the speakers plugged in using the OSS device(s) than I do with the ALSA devices.

Is there a ALSA dev list that I should consider posting to to get this motherboard and related sound devices into the pipeline for updated drivers? Your good luck is encouraging.

Hmm - I will have to dig around and see if I can find the first Mixer control to change it from off. I am pretty sure I have everything turned on that I can find.

I am assuming that the pa*** packages are all related to Pulse Audio. I have played around a bit with them. In any case I will do some more testing as you have suggested and see if that turns up anything new.

Many thanks for your suggestions.


Realized I forgot to reply to your question about options. Having tried a bunch of different ones - mostly based on your suggestions to others - this is where it was when I grabbed the current configuration to post to this thread.

I think I found the mixer control and have turned it on - need to dump the alsa-info once more to make sure. I have also tried setting up Pulse and playing with some of those options.

Quick results so far is no change. Still no sound on the HDMI connection.

I will plan on spending some focused time working through various settings to see if I can determine something further.

Many thanks.

My understanding is there are two openSource drivers for Linux. Originally there was OSS, but it went proprietary, and the open Source community quickly dropped it in favour of Alsa, even though OSS development continued. Recently OSS was “opened up” again as opensource, but too much effort has been spent on alsa, and IMHO its highly unlikely the opensource community will go back to OSS. As far as I know, its not possible to have both the OSS and Alsa driver running at the same time. Instead the Alsa driver has an OSS emulator.

Probably is a “list server” but I stopped accessing lists servers a long time ago and I stubbornly refuse to go back. So I don’t know which nor where nor how. I do note that if you install “xchat” and join IRC chat “freenode” channel #alsa you can get very good support from a number of users. But typically you may need to ask 1/2 dozen times, at different times of the day, to catch one of the gurus.

The pa*** are pretty much gnome specific. I do not use gnome. Hence I am sort of hoping you will teach me. :slight_smile:

Good luck.