No sound on HDA-Intel Realtek ALC889


I use a Motherboard X58A-UD7 (Gigabyte) with an Intel HD Audio controller and RealTek ALC889 codec. The speakers are plug in optical output.

With this hardware configuration, an Ubuntu 12.04 LTS (with 3.2.0-37-generic kernel) can play sounds.

But, a Opensuse 13.1 (with 3.11.10-7-desktop kernel) can’t.

I remove the pulse audio server and make several tests, with no success.

I think there is a regression in the kernel, because I have error message in the dmesg buffer :

ALSA patch_realtek.c:490 realtek: No valid SSID, checking pincfg 0x4005e601 for NID 0x1d
ALSA patch_realtek.c:506 realtek: Enabling init ASM_ID=0xe601 CODEC_ID=10ec0889

I have not this message in the Ubuntu configuration.

Any help would be appreciated.


Welcome to openSUSE and to openSUSE forums.

It would be useful to understand a few things so to try and better provide you support. You note this sound works in Ubuntu but not in openSUSE-13.1. Are you using a brand new /home or is this the same /home that you had used previous in Ubuntu ? If the same /home, and with pulse audio enabled, then it would be useful to look for a /home/username/.pulse directory, and if that was there then change its name to .pulse-ubuntu. Note the ‘dot’ in front of the file name makes it a hidden file.

In fact if same /home as Ubuntu, it may even be worth while checking to see if a new user (with a new /home) has the same problem.

Note openSUSE-13.1 has no startup sound by default, so do not use that as a criteria that sound is or is not working.

Also, with pulse audio enabled, you can better configure pulse audio by installing the application pauvcontrol and configuring per the guidance given in these two blogs:

Another test with pulse audio enabled, is to try this command in a terminal/konsole (and report here any errrors):

paplay -v /usr/share/sounds/alsa/test.wav

also try these two commands to play sound directly from alsa:

aplay -v /usr/share/sounds/alsa/test.wav


speaker-test -c2 -l5 -twav

Note the dmesg entry you reference:

ALSA patch_realtek.c:490 realtek: No valid SSID, checking pincfg 0x4005e601 for NID 0x1d
ALSA patch_realtek.c:506 realtek: Enabling init ASM_ID=0xe601 CODEC_ID=10ec0889

may indicate a problem, BUT it is not a 100% certainty of such. I’ve seen that error when sound worked. Wrt the SSID settings, the alsa document gives these (from the HD-Models.txt file) as possible settings that can be forced in an appropriate configuration file if need be (and we can try each of those, one at a time, later if need be) :

  acer-aspire-4930g	Acer Aspire 4930G/5930G/6530G/6930G/7730G
  acer-aspire-8930g	Acer Aspire 8330G/6935G
  acer-aspire		Acer Aspire others
  inv-dmic		Inverted internal mic workaround
  no-primary-hp		VAIO Z/VGC-LN51JGB workaround (for fixed speaker DAC)

But before trying anything like that, it would be useful to see the content output of a diagnostic script having been run. Please with PC connected to interne in a konsole/terminal send the following command, select the SHARE/UPLOAD option, and let the script complete execution. In the konsole/terminal will be a web address/url that you are advised to pass to those trying to give you support.


with the information from that script we may have a better idea as to where support should be focussed.

Thankyou for posting on our forum, and good luck.

Thank you, and excuse me for the late reply.

I will clarify this point. In the new OpenSuse installation, I have a new fresh home directory. I can only access to the old home directory by a mount point (/mnt/oldmount …), so there is no interaction between the new an the old installation.

I think that pulseaudio can be an additional source of problems, so I disabled it.

Nothing seems to work. My PC remains silent.

Yes, i agree, but I did not have these messages with the Ubuntu distribution. There is a difference between this two distributions, certainly in the Kernel. And the problem is perhaps not important for me : I need only a functional optical output.

Yes,before this extremes solutions I try a solution of last resort.

I boot in Ubuntu mode and I dump the alsa configuration, I reboot in OpenSuse mode and I force the reload of this parameters. I have several error messages, but IT WORKS NOW !!

I did not understand the details of the solution, but I think that imperfect initialization broke the deadlock. It is strange because the alsa tools (alsa-init) doesn’t work.

I send my configuration, if you’re curious, :

Thank you very much for you precious help.

95% (maybe more ? ) of current openSUSE packagers testing is conducted with Pulse Audio enabled. So while a number of users like to disable pulse because they believe it causes them problems with their specific hardware, I don’t belong to that camp, and I believe disabling Pulse can also cause a different brand of problems.

I note with pulse audio disabled, I no longer have the expertise to help, and those who disable pulse routinely would need to help you.

Glad to read it is working now. I do not understand what parameters you are referring to when you state “this parameters”. Nor do I see in the Script output the error messages you are referring to.