No sound on Dell Studio 1737

I’ve recently acquired a Dell Studio 1737.
I’ve installed OpenSuse 11.1 (64 bit arq), all went perfect except for the sound.
I’ve no SOUND at all.
I’ve tried everything found on the web with no success.
Suse detects the following audio devides:

82801I (ICH9 Family) HD Audio Controller
Configured as sound card number 0
Driver snd-hda-intel
RV635 Audio device [Radeon HD 3600 Series]
Configured as sound card number 1
Driver snd-hda-intel

My alsa configuration URL:

I’ve tried with no success:
speaker-test -Dplug:front -c2 -l5 -twav
speaker-test -c2 -l5 -twav

My rpm -qa | grep alsa:

And pulse:

Fuc**** things like this makes people not to switch to linux. I love suse but if I don’t solve this problem I will have no choice.
Please can anybody help me?
Thanks a lot in advance.

No worries, … I have a Dell Studio 1537, which is in essence the same laptop, except a smaller 15" screen.

Sound can be made to work easily. I note this :

Which confirms your laptop has a Codec: IDT 92HD73C1X5 and the Kernel release:

I also note this:

which is the stock alsa, built against the kernel version that comes with 11.1. But there was a kernel update last week, that broke the headset sound. To address such possibly problems, as a volunteer I maintain this wiki page Alsa-update - openSUSE to help users whose sound gets broken by kernel updates. BUT there is more to this story …

Ohh yee of little faith … :wink:

… I think this can be made to work … :slight_smile:

First, I note from your mixer this:[INDENT]!!Amixer output
!!-------Mixer controls for card 0 [Intel]
Card hw:0 ‘Intel’/‘HDA Intel at 0xfc400000 irq 22’
Mixer name : ‘IDT 92HD73C1X5’
Simple mixer control ‘Analog Loopback’,0
Mono: Playback on]
Simple mixer control ‘Analog Loopback’,1
Mono: Playback on]
Simple mixer control ‘Analog Loopback’,2
Mono: Playback on]
[/INDENT]I believe at least two of these should be off, … possibly all 3. I also think this is a mute point, as these controls are removed in the 1.0.19 update of alsa.

Now whats important is the update of the kernel that was released about a week ago, broke the sound on this laptop. Anticipating this, the alsa developer released an update to alsa for the kernel, fixing the sound, but the automute on the laptop’s speakers did not work properly when a users headsets were plugged in. So I wrote a bug report on that, and within a FEW DAYS a fix was released. A FEW DAYS!! Thats an incredibly good turn around. IMHO mistakes happen, and having a fix in a few days is not something to be too upset about.

Bug report is here:

Anyway, to get your sound working, opening a gnome terminal or a kde konsole, and with your PC connected to the internet, type “su” (no quotes - enter root password when prompted) and then copy and paste the following 6 zypper commands into the terminal/konsole, in sequence, executing them one at a time, to update to the latest git 1.0.19 of alsa:

zypper ar multimedia
zypper install alsa alsa-oss alsa-oss-32bit alsa-plugins alsa-plugins-pulse alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

then restart your PC, and test your sound. Check your mixer. You may need to go to YaST > Hardware > Sound > Other > Test (although that may crash) or to YaST > Hardware > Sound > Other > Volume (that “volume” crashed on my PC, per the bug report). Also in your mixer move up PCM, Master Volume and Speaker volume to a very very high setting (I forgot initially to move up ‘speaker volume’ and my volume setting was very low).

And have faith next time. :slight_smile: … You are only a bug report away from getting a fix, and often other volunteers like myself, monitor this forum, and also the Dell Linux mailing list, looking to help users struggling with sound on openSUSE. :slight_smile:

Let me know if that does not work.

In case you were curious about the Dell Linux mailing list:
sound problem

Thank you, oldcpu. Your directions fixed the sound on my Dell Studio 1737.

So I just wanted to say thanks too. I just got a 1537 and went to install openSUSE Friday. Sound was the only thing not working, and it’s working now thanks to this thread.

Thank you, it works for VLC and others players.

But I still have no sound with flashplayer !

I installed :
flashplayer (non free)
and libflashsupport (to have pulseaudio support).

I have a Dell D630.

Am I alone ?


Upgraded to the new kernel ( and sound stopped working! :frowning:

Re-trying the fix oldcpu posted before did not fix the problem. Does anyone know what broke and how to fix it?

It is very frustrating to have sound break every time a new kernel comes out.

I have not updated to the new kernel yet. I was surprised to see Novell/SuSE-GmbH release this update a few days before the Easter Holiday (smacks of internal release schedules to me … I don’t understand why this is done a few days before a holiday period ).

I believe the openSUSE / alsa dev may be on vacation, and hence there have been no alsa builds yet for the new kernel. I’m watching it carefully here: Index of /repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update and thus far only support for the

I suspect within a week or two there should be support, as soon as the alsa / openSUSE developer returns from vacation, or alternatively when they realize there are problems.

You could write a bug report: Submitting Bug Reports - openSUSE

In doing so, you could mention the Studio 1537 laptop has the same audio hardware as the Studio 1537 laptop mentioned in these bug reports:

The problem is different, but the hardware is the same, and that may “twig” the alsa / openSUSE developers memory as to that hardware.

You should try the new kernel to see if you get the same result. :sarcastic: The worst part is I installed the update (without thinking) just before leaving town, so my laptop was without sound all weekend. :frowning: The install deleted the old kernel, so I could not fall back to something functional.

Shouldn’t there be testing before releasing the kernel update? I guess what I need to do is create a test partition/install, to test new updates before putting them on the “production” partition. For now I’m dropping back to, to try to get back to something functional.

Thanks for your help. I opened a bugzilla:

lol … I had contemplated installing the kernel, but when I saw no version of alsa 1.0.19 for the kernel, I decided to wait.

If I do decide to try out the kernel, I’ll install it the same way I did for the kernel, which is NOT install via a Software Package Manager. Rather I will first identify the kernel packages I need by typing:
rpm -qa | grep kernel
Then I’ll go to the OSS web site and download to my laptop’s hard drive the various rpms: Index of /update/11.1/rpm

I will also, before installing, back up my /boot/grub/menu.lst file

Then once identified, I will install them (from a konsole with root permissions) via the command that will be structured like (but not indentical to):
rpm -ivh A.rpm B.rpm C.rpm
where A.rpm, B.rpm, C.rpm are the various kernel rpms (I don’t have time this morning to type the names out in full). Once that is complete I’ll check the updated /boot/grub/menu.lst file to ensure it makes sence, and then reboot to the new kernel. With the updated menu.lst file, there should be a choice of two kernels to boot from since the “rpm -ivh” method was used. Note the command is “rpm -ivh” and NOT “rpm -Uvh”.

Sorry to read you were not fortunate there. If I had to leave town with sound not functioning in my laptop , I would not be a happy camper.

Possibly, but for that to happen, the community (ie you and me) have to be involved in the testing, because the alsa / openSUSE dev does not have our hardware.

The fact the new kernel was released just a day or two before the Easter Holiday period / school holiday period in many European countries, and also in North America, suggests to me there was some schedule driving the release. IMHO it makes more sense to issue such a release on the day after the holiday - but thats just my view.

Thanks for that. … I’ll take a look at it.

A comment on that bug report.

Last time I raised the bug report on the component “Kernel” (because the Kernel update broke the sound) and there was no response for 3 days. So on the 3rd day I changed the bug report “Component” from “kernel” to “sound” and I had immediate response from the alsa/openSUSE developer. It was fixed the same day.

So I do not know how bug assignments and notifications work within Novell/SuSE-GmbH, but watch for a response, and if it appears there is no progress, you could switch the component to “Sound”.

See see there is now a version of alsa built by the openSUSE alsa/dev for the kernel.

Hence you could try the new kernel and the new alsa (but be prepared to roll back both alsa and kernel if it does not work).

Accordingly, I updated the wiki:
Alsa-update - openSUSE

Installing the latest Linus 2.6 kernel (2.6.30-rc2-0.1-default) fixes sound. I don’t know what the breakage in is, but it is fixed upstream. Life is good again. :slight_smile: