No sound on-board sound card

I have installed openSUSE 13.2 64bit on my pc.
I have gigabyte z77x-ud5h motherboard and I the sound doesn’t play.

Any guess what went wrong?


Its difficult to say, without knowing some more detail. But sound should just work and I would like to try to help.

Would it be correct for me to assume your openSUSE-13.2 64-bit install is using the KDE desktop ?

What was your test criteria to confirm sound was working ? Do either of these two tests give sound as a regular user and also with root permissions (running in a konsole/xterm) ?

speaker-test -c2 -l5 -twav


aplay -vv /usr/share/sounds/alsa/test.wav

and if neither of them work, do you get any errors when you send them ?

Both the aplay and speaker-test examples above should send audio to pulse if pulse audio is installed (with the alsa pulse plugin (alsa-plugins-pulse)) and if pulse is not installed/enabled, they should send audio to the default audio device.

Have you checked your openSUSE-13.2’s mixer to ensure sound is not muted and volume turned up ?

Have you tried to install pulse audio volume control (pavucontrol) to see if it has pulse audio appropriately assigned for your PC device hardware on an application level basis. Note pulse audio allows assigning specific audio devices to specific applications.

Yes Im using KDE desktop.

I tried both commands, in standard permission and with su permission.
I didn’t get any errors but I didn’t get any sound also.

I double check that the channel isn’t in mute mode.

This is the output for those two commands.

inux-ukqm:~ # aplay -vv /usr/share/sounds/alsa/test.wav
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
ALSA <-> PulseAudio PCM I/O Plugin
Its setup is:
  stream       : PLAYBACK
  access       : RW_INTERLEAVED
  format       : S16_LE
  subformat    : STD
  channels     : 2
  rate         : 44100
  exact rate   : 44100 (44100/1)
  msbits       : 16
  buffer_size  : 22050
  period_size  : 5512
  period_time  : 125000
  tstamp_mode  : NONE
  tstamp_type  : GETTIMEOFDAY
  period_step  : 1
  avail_min    : 5512
  period_event : 0
  start_threshold  : 22050
  stop_threshold   : 22050
  silence_threshold: 0
  silence_size : 0
  boundary     : 6206523236469964800
# +                                                | 02%
linux-ukqm:~ # 
linux-ukqm:~ # 
linux-ukqm:~ # speaker-test -c2 -l5 -twav

speaker-test 1.0.28

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4                                                                                                                                                       
was set period_size = 262144                                                                                                                                      
was set buffer_size = 1048576                                                                                                                                     
 0 - Front Left                                                                                                                                                   
 1 - Front Right                                                                                                                                                  
Time per period = 4.956846                                                                                                                                        
 0 - Front Left                                                                                                                                                   
 1 - Front Right                                                                                                                                                  
Time per period = 4.955512                                                                                                                                        
 0 - Front Left                                                                                                                                                   
 1 - Front Right                                                                                                                                                  
Time per period = 4.957654                                                                                                                                        
 0 - Front Left                                                                                                                                                   
 1 - Front Right                                                                                                                                                  
Time per period = 4.957674                                                                                                                                        
 0 - Front Left                                                                                                                                                   
 1 - Front Right                                                                                                                                                  
Time per period = 4.957359                                                                                                                                        
linux-ukqm:~ #      

I think, but I’m not 100% sure, that when I was with 13.1 there was sound. also when I was working with 12.3.

It reads like you may have the same /home in 13.2 as you had in 12.3 and 13.1.

Its possible the pulse audio configuration from those is blocking the sound from your 13.2 install.

Try removing (if they exist) ~/.pulse and ~/.config/pulse then restart and test.

Note if you install the application pavucontrol (pulse audio volume control) you can assign each multimedia application on your PC to a different sound device on your PC.

If the above fails to help, can you please provide more information by as a regular user, with pc connected to the internet, run the diagnostic script in a konsole:


and do not update if asked to update it, select the SHARE/UPLOAD option, and let it run to completion. When it completes it will place in the konsole a web-address/URL where it has uploaded a copy of your PC’s audio configuration information. Please copy the URL/web-address here (just the address) and we can look at that to see if it yields any hint as to why audio is not functioning.

When I upgrade from versions I install them as a fresh installation after format.

ok - this is pretty clear that your sound card is not recognized:

!!Aplay/Arecord output


aplay: device_list:268: no soundcards found...


arecord: device_list:268: no soundcards found...

Try going to YaST > Hardware > Sound and configure your sound device.

That is what I have under Yast -> Hardware -> Sound

When you go to “OTHER” and move up the volume levels and try ‘test’, do you get any sound ?

Does that mean you keep the old /home or do you reformat and create a new /home ?