No sound on Asus A7K

I recently installed Suse 11.1 on my Asus a7k laptop. Everything is working fine, except that there is no sound. I have read through the forums, but no luck. I would appreciate any help.

The sound should work with this laptop on 11.1.

Are you using Gnome? KDE3 ? KDE4 ?

You could start by working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE Pay attention to your mixer settings. Both PCM and Master Volume should be moved up.

Please use the recommended sound test (copy and paste the following into a gnome-terminal or kde konsole): speaker-test -c2 -l5 -twavand you should hear a ladies voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ 5 times.

If after working your way through the audio troubleshooting guide, you still are not able to get any sound from the “sound-test”, then we will need more information to help you. In that case, to provide more information, with your PC connected to the internet, please copy and paste the following into a gnome-terminal or a kde konsole: /usr/sbin/alsa-info.shThat will provide you a URL. Please post here ONLY the output URL. Do NOT post all the info , here. Just the URL.

In addition to the above (if seeking more help), please run the following, and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q padevchooser pavucontrol pavumeter paman paprefs
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

If you do get sound from the “sound-test” then your problem is likely an application config/codec problem.

I have worked through the troubleshooting guide a couple of times and nothing worked. I am running KDE 3. The sound test yeilded no results. Here are the results from the other tests.

randy@linux-h5ti:~> rpm -qa | grep pulse
randy@linux-h5ti:~> rpm -q padevchooser pavucontrol pavumeter paman paprefs
package padevchooser is not installed
package pavucontrol is not installed
package pavumeter is not installed
package paman is not installed
package paprefs is not installed
randy@linux-h5ti:~> rpm -q libasound2
randy@linux-h5ti:~> uname -a
Linux linux-h5ti #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

I colour coded my post to try to make it easier for you to read, but I can not see the output (in your post) of “cat /etc/modprobe.d/sound”. Please, can you post the output of:
cat /etc/modprobe.d/sound
apologies if I missed it, but I looked at your post, and I could not see it.

Also, how many Input/Output sound/mic jacks on your PC ? (for example, my PC has 3).

I note you have a “Codec: Realtek ALC660-VD” on our PC, on a 64-bit openSUSE-11.1. I can likely recommend an edit to the /etc/modprobe.d/sound file, but I need to see that file first.

I apologize for any confusion. I have 3 input/output audio jacks on my laptop. My /etc/modprobe.d/sound is as follows.

options snd slots=snd-hda-intel,snd-hda-intel

5Dex.IOFetRyhSn6:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

NXNs.JPS6WT8bfU4:RV630/M76 audio device [Radeon HD 2600 Series]

alias snd-card-1 snd-hda-intel

OK, thanks for that. I did some research on this Asus A7K and sound, and I’ve seen complaints from Fedora, Ubuntu, Gentoo and Mandriva users, none of whom could get the sound functioning.

I note for the ALC-660-VD, the following list in the ALSA-Configuration.txt file for 1.0.18a of alsa:

	  3stack	3-jack
	  3stack-dig	3-jack with SPDIF OUT
	  6stack-dig	6-jack with SPDIF OUT
	  3stack-660	3-jack (for ALC660VD)
	  3stack-660-digout 3-jack with SPDIF OUT (for ALC660VD)
	  lenovo	Lenovo 3000 C200
	  dallas	Dallas laptops
	  hp		HP TX1000
	  asus-v1s	ASUS V1Sn
	  auto		auto-config reading BIOS (default) 

So lets try various iterative edits to your /etc/modprobe.d/sound file to see if we can find one that enables your sound functionality on your Asus A7K.

Can you please start by adding a line at the start of the /etc/modprobe.d/sound file, such that it reads:

options snd-hda-intel model=auto
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.IOFetRyhSn6:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.JPS6WT8bfU4:RV630/M76 audio device [Radeon HD 2600 Series]
alias snd-card-1 snd-hda-intel 

then restart your alsa driver in a konsole with root permissions with: rcalsasound restart #and then restart your mixer and test your sound (using the sound test):speaker-test -c2 -l5 -twavyou should hear a ladies voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times.

If that does not work, please replace “auto” in the /etc/modprobe.d/sound file with “3stack” and repeat the restart of alsa, your mixer, and sound test.

If that does not work, please replace “3stack” with “3stack-dig” and repeat the restart of alsa, your mixer, and sound test.

You noted “3 I/O plugs”, that typically corresponds to “3stack”. If one had “6 I/O plugs” then 6-stack would be more appropriate.

If “3stack-dig” does not work, keep trying every parameter one at a time from the ALSA-Configuration.txt file entry for the ALC-660-VD (I don’t think you need bother with “6stack-dig” as that is for different hardware).

Here is the alsa bug report on the sound on this laptop:
… and all we can do is hope that the suggestions I made in my previous post will work.

I tried what you asked, and there was no luck. However, I did notice a high pitched ringing during the speaker test.

Sorry to read that it did not work.

Then I recommend you write a bug report on openSUSE.

You could also (if you wished) add a comment to the alsa bug report that the sound also does not function on openSUSE. I made note of the alsa bug report here:

For raising an openSUSE bug report (which IMHO is a good idea as one of the alsa dev’s also handles the openSUSE sound bug reports) there is guidance here: Submitting Bug Reports - openSUSE

hi all,

i own as well an Asus A7K laptop with same hardware. i would like to mention that sounds does not work with any distribution i have tested so far. this includes: opensuse 11.1, fedora 10, ubuntu 8.10.

i have tried all things that i could find in forums related with sound issues but had no success. in particular this means options in modprobe.conf, deactivating pulseaudio or different workarounds mentioned in different places across forums irrespective of distro.
NO SUCCESS. I have already given up the quest for holy sound in my asus laptop.

if someone has ever managed to get sound working properly i would be really gratefull if he shares his solutions with us.


If you have the same laptop, then it might be useful adding an entry to experimenter86’s bug report. If they have not raised one yet on openSUSE, it might be worth while raising one yourself.

Novell via SuSE-GmbH fund alsa development, and by raising a bug report on openSUSE sound, any fix in openSUSE alsa packaging typically ends up in the main stream alsa to the benefit of all distributions. That is good. Unfortunately, I’m beginning to suspect the same does not occur with Ubuntu, as I am not convinced the Ubuntu packagers, who add in custom sound fixes for their distribution, also submit the fix upstream for alsa. I am beginning to think they do not (although I could be wrong in this suspicion)

You are not wrong. I remember an article on slashdot where they wrote that ubuntu is not submitting their fixes to any upstream vendor…

If true, that is enough for me to not try Ubuntu again. I have very strong philosophical feelings against a distribution that would adopt that approach.

I don’t suppose you have a link to that?

Hi all,

I too have an AK7 and have problems with audio.

I’ve submitted bug reports during 11.0 developement (also on alsa dev site in the link that oldCPU mentions earlier) and 11.1 development (bug ID 439252).

The developer has asked for anyone who is interested to assist with debugging

If the problem still persists, you could, at least, do debugging with
trial-and-error. But this would require some knowledge of HD-audio codecs.
See the document:

Wish I could have something more uplifting for NewYears but with more people testing, we’re more likely to get something working.

As an asside I tried OpenSound during 11.0 and it didn’t work. There are many asus laptop owners with different models who have chosen this route after frustrating experiences with Alsa and had success. I however was not one of them.

Good luck in your efforts. For anyone curious as to bug ID 439252, it can be found here:


Another strategy that we could try is to see if we can get someone from Asus interested in helping the developer out. Long shot I know, but I’m certain that someone within the company trolls through the forums etc. I haven’t posted anything there in ages, but perhaps one of the other posters to this thread could have a try?

Happy New Year all.

Here is a link to the asus forums if anyone is interesting in rattling their cage.

ASUSTeK Computer Inc.-Forum-

there is probably also a tech support email somewhere.
They certainly have linux developers on staff (to do stuff with the EEE) so they should be able to help.


I have also an Asus A7k, and have also sound problem under Opensuse 11.1.

But, under opensuse 10.3 with alsa-1.0.14 the sound is working. The problem is in the newer alsa drivers. Unfortunately, the alsa-1.0.14 cannot be compiled under the newer kernel…

I hope the alsa developers can solve this problem.

There have some updates to alsa since experimenter86’s post#4 above. Have you tried updating alsa per this guide ? (note you must send SIX zypper commands, and not 3 commands ) : Alsa-update - openSUSE

Its possible the bug has been fixed, and this “may” work now. But it “may” not.

Still, having read the bug report: I think the alsa/openSUSE developer (dev) could have been given more support in their effort to solve this. There was not one reply to the openSUSE/alsa dev’s post of 7-Jan-2009.

If one wishes a bug to be fixed, one needs to give the developer information. They do not have the same hardware, and with out the information they can not help.

Hi everyone with problem with ASUS G2K or ASUS A7K or with similar problem with sound with azalia HDA SBx00. I Tried almost everything and nothing helped until today. I tried alsa and also OSS and results was same (this is sample of original result ). Today someone with name dfm7a on alsa mantis bug tracing page added post which solved my problem. Original post is here

There was problem which was connected to something called GPIO. Maybe there is also way how to make it work on OSS but i did not accomplished that.

Here is my solution with alsa (with all respect to OSS)

Step 1. Install alsa 1.0.19, i suggest use of this installation script
[all variants] ALSA Upgrade Script - Ubuntu Forums]( it is working very well.
or you can download it here directly without reading text
Ubuntu Forums

1. cd <your-download-dir>
2. tar xvf AlsaUpgrade-1.0.x-rev-1.16.tar
3. sudo ./ -di

Step 2. download and set up hda-verb-0.3.tar.gz

when you got it you set it up in to right place by using

tar -xvmf hda-verb-0.3.tar.gz
cd hda-verb-0.3
sudo cp hda-verb /usr/local/sbin 

Step 3. then you have to edit gksudo gedit /etc/rc.local or with your favourite editor and add there these 3 lines before exit 0

/usr/local/sbin/hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_MASK 3
/usr/local/sbin/hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_DIRECTION 1
/usr/local/sbin/hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_DATA 1

Step 4. Restart and sound should be working

You dont need to modify /etc/modprobe.d Im just posting what i found it worked for me perfectly on Linux Ubuntu Ultimate Edition 2.0 (i saw that this was also working on Fedora 10)Thanks for help anyway