No sound on a new install

Ok I have gotten rid of WinXP as that did not seem stable and I am throwing all my eggs in one basket and I have the feeling that is not good. However, I have had several goes at install many types of Linux and really this is a last chance. I always seem to have problems with sound and I can’t for the life of me remember the comings and goings of how and why. To much water has gone under the bridge and I live on morphine which makes me brain dead. So bear with me. Ok, the sound is not working here, its an onboard integrated sound system. Its integrated in the North Bridge, Realtek ALC888codec. Opensuse has put the system drivers as 'SBx))Azalia (Intel HDA), could be why I am not getting sound here. How can I resolve this.

Just one more thing to add I have forgotten how to mount my external drives partitions which are formated NTFS. Until these matters are resolved I can’t really move on and recieve emails and do other things as it would mean setting up the system and I may be waisting my time and effort and my bandwidth. So I am really hoping that it can be resolved



I haven’t been idol and hoping for a miracle, I have given up on those years ago and I have never come across one yet. Only hard graft and pain. This is what I have so for if anyone can help
linux-ql69:/home/tony # cat /proc/asound/devices
2: : timer
3: 0- 2]: digital audio capture
4: 0- 1]: digital audio playback
5: 0- 1]: digital audio capture
6: 0- 0]: digital audio playback
7: 0- 0]: digital audio capture
8: 0- 0]: hardware dependent
9: 0] : control
10: : sequencer
linux-ql69:/home/tony # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.17

This is the package info

[Keep] alsa | Advanced Linux Sound Architecture | 1.0.18-8.7 | 1.4 M
[Do Not Install] alsa-devel | Include Files and Libraries mandatory… | (1.0.18-8.7) | 332.0 K
[Do Not Install] alsa-docs | Additional Package Documentation | (1.0.18-8.7) | 8.0 M
[Do Not Install] alsa-firmware | Firmware Data Files for ALSA | (1.0.17-1.42) | 7.5 M
[Do Not Install] alsamixergui | An FLTK-Based Front-End for alsamixer | (0.9.0rc1-584.132) | 72.0 K
[Keep] alsa-oss | ALSA-OSS Wrapper | 1.0.17-1.37 | 75.0 K
[Keep] alsa-plugins | Extra Plug-Ins for the ALSA Library | 1.0.18-6.12 | 102.0 K
[Do Not Install] alsa-plugins-jack | JACK I/O Plug-In for the ALSA Library | (1.0.18-6.12) | 41.0 K
[Do Not Install] alsa-plugins-maemo | Maemo Plug-Ins for the ALSA Library | (1.0.18-6.12) | 76.0 K
[Keep] alsa-plugins-pulse | Pulseaudio Plug-In for the ALSA Library | 1.0.18-6.12 | 77.0 K
[Do Not Install] alsa-plugins-samplerate | Samplerate Plug-In for the ALSA Library | (1.0.18-6.12) | 28.0 K
[Do Not Install] alsa-tools | Various ALSA Tools | (1.0.18-1.13) | 503.0 K
[Do Not Install] alsa-tools-devel | Include Files and Libraries mandatory… | (1.0.18-1.13) | 43.0 K
[Do Not Install] alsa-tools-gui | Various ALSA Tools with GUI | (1.0.18-1.13) | 671.0 K
[Keep] alsa-utils | Advanced Linux Sound Architecture Uti… | 1.0.18-6.4 | 1.7 M
[Do Not Install] aseqview | ALSA Sequencer Event Viewer | (0.2.7-4.148) | 60.0 K
[Do Not Install] balsa | The GNOME Mail Program | (2.3.26-1.37) | 1.7 M
[Do Not Install] balsa-lang | The GNOME Mail Program | (2.3.26-1.37) | 4.3 M
[Do Not Install] bluez-alsa | Bluetooth Sound Support | (4.22-6.1.10) | 48.0 K
[Do Not Install] FA_clalsadrv | ALSA Driver C++ Access Library | (1.1.0-2.111) | 49.0 K
[Do Not Install] gamix | GTK ALSA Audio Mixer | (1.99.p14-196.96) | 101.0 K
[Do Not Install] jaaa | JACK and ALSA Audio Analyser | (0.4.0-1.125) | 69.0 K
[Do Not Install] java-1_5_0-sun-alsa | ALSA support for java-1_5_0-sun | (1.5.0_update19-0.1.1) | 68.0 K
[Do Not Install] java-1_6_0-sun-alsa | ALSA support for java-1_6_0-sun | (1.6.0.u14-0.2.1) | 78.0 K
[Do Not Install] kalsatools | KDE Tools for ALSA | (1.5.0-499.130) | 400.0 K
[Do Not Install] kamix | KDE Mixer for ALSA | (0.0.7e-247.135) | 237.0 K
[Do Not Install] pmidi | A Command Line MIDI Player for ALSA | (1.6.0-134.91) | 72.0 K
[Do Not Install] qamix | Qt Mixer for ALSA | (0.0.7e-352.43) | 221.0 K

Shall keep clogging away, but my patients is very thin when it comes to Linux. I am surprised I have kept it going for this long

Ok I know I am talking to myself here but now I am pissed off as I have tried to access etc/fstab and wite
/dev/sdg4/media/disk ntfs-3g force 0 0
So as I cannot access my external drive. It won’t give me permission. I really hate this wasting time resolving problems. Just wish I knew what I was doing


Now all I have to do is get the external hard drive sorted.

PLEASE any help now would be appreciated, I have worked this far and its great.



On openSUSE-11.1, your external hard drive should be accessable without any entries in your fstab.

If it were me, I would remove any fstab entries that you may have added specific to your external hard drive.

Then reboot without your external hard drive plugged in.

Then plug in your external hard drive. It should be automatically mounted with read/write.

OpenSUSE-10.3 and 11.0 will require something different.

Note if your external hard drive is an NTFS formatted drive, its imperative that it was removed properly under Windows. If it was not, then you may need to go to MS-Windows, plug it in under windows, and then remove it properly under MS-Windows. Its even possibly you may need to do a chkdsk on it under MS-windows (assuming it is NTFS).