No sound modules loaded after upgrading 13.1 to 13.2

Well, you could add a comment there, or better file a new one. (this bug report is about a different sound card, so it probably is not the same problem…)

I have tried everything that this person has and to no avail. I have not tried changing the kernel and doubt that I will… I have spent hours on this and do not have the time to devote to more R&D. And yes, Yast does recognize the sound controller: Intel PCI 82801AA AC’97

So you don’t get sound?

Does the test sound in YaST work?
(Other->Play test sound)
Also make sure the volumes in there are not 0, as mentioned by gogalthorp.

Where are no sound controls at all?
You need to logout/login (or reboot) for full effect, already running applications will not notice the config change and still try to connect to PulseAudio (which will fail then).

I do not think that the alsa works because it does not respond to the command line

What exactly did you type into the command line?
You cannot run “alsa”.

although the command: rpm -q alsa alsa-utils alsa-firmware does show that it is installed… another mystery.

alsa-1.0.28-6.1.4.x86_64
alsa-utils-1.0.28-5.3.1.x86_64
alsa-firmware-1.0.28-2.1.2.noarch

That are the versions included in openSUSE 13.2. And yes, they are installed by default.

jeb@linux-7a8g:~> systemctl status alsasound
alsa-restore.service - Restore Sound Card State
Loaded: loaded (/usr/lib/systemd/system/alsa-restore.service; static)
Active: inactive (dead) since Tue 2015-08-04 21:34:40 HST; 25min ago
Process: 742 ExecStart=/usr/sbin/alsactl restore (code=exited, status=0/SUCCESS)
Main PID: 742 (code=exited, status=0/SUCCESS)

jeb@linux-7a8g:~> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: I82801AAICH [Intel 82801AA-ICH], device 0: Intel ICH [Intel 82801AA-ICH]
Subdevices: 1/1
Subdevice #0: subdevice #0
jeb@linux-7a8g:~> pactl info
Connection failure: Connection refused
pa_context_connect() failed: Connection refused
jeb@linux-7a8g:~>

The first command adds a different sound card but there are no drivers for it and you cannot “edit” it in Yast… If you go to settings / hardware /sound, there are no devices shown there. Turn off pulse, reboot = nothing.

“Where are no sound controls at all?
You need to logout/login (or reboot) for full effect, already running applications will not notice the config change and still try to connect to PulseAudio (which will fail then).”

Yes, I have done that. When it reboots the little speaker in the upper right of the top status bar is gone and settings / hardware / sound has no controls in it.

Which Desktop? GNOME?
GNOME’s audio settings probably depend on PulseAudio, but sound should work without it.

And what about YaST? Does the (test) sound work there?
Have you tried to configure the card there? Have you looked at the volume control in there?

The card seems to be detected correctly.

jeb@linux-7a8g:~> pactl info
Connection failure: Connection refused

pa_context_connect() failed: Connection refused

jeb@linux-7a8g:~>

pactl cannot work if PulseAudio is disabled.

Thank you all for your input and feedback. It should be a rudimentary function of the OS to ID the sound hardware and apply the correct drivers. I have decided to wait until the opensuse developers come out with a newer version that addresses this issue. I like opensuse and consider it to be superior to Ubuntu, which I have used in the past. When the sound issue gets sorted out it will be a good OS.

Well, it does for the majority of us. There is still not sufficient information to provide a clear picture about what the problem is. I suggest you start by running the ALSA diagnostic script

sudo /usr/sbin/alsa-info.sh

and have it upload the output to a server. It will provide a link that you can share here, and others can then review the information provided for further advice/comment.

I have decided to wait until the opensuse developers come out with a newer version that addresses this issue.

Good luck with the wait and see approach. If it was me I’d continue to make the effort with trying to find out where the problem is. If it turns out that you’re impacted by some bug, then a bug report might be needed. That’s the way it works.

I like opensuse and consider it to be superior to Ubuntu, which I have used in the past. When the sound issue gets sorted out it will be a good OS.

It is a great OS, otherwise we wouldn’t be here giving up our free time sharing information and assisting others . :slight_smile:

I would like to try and help, but I struggle a bit understanding the details of your PC’s specific problems.

Do you have identical 100.0% hardware to that user ?

Hours ? Ouch.

Sorry to read that. Don’t spend hours.

Can you spend 5-minutes and run the following diagnostic script that will provide more information ? Run it in a xterm or konsole, with PC connected to the internet, as a regular user:


/usr/sbin/alsa-info.sh

do not update if asked to update the script, select the SHARE/UPLOAD option, and let script run to completion. Then in konsole / xterm will be a URL/address that I ask you post here, as it will provide us the location where your PC audio information (assessed from the script) is uploaded.

Maybe after looking at that we will have some ideas as to your PC’s problem.

Also advise if using Gnome or KDE or other desktop. Advise EXACTLY what sound tests you tried ? ie tests such as (with user and root permissions) :


speaker-test -c6 l5 -twav

or


speaker-test -c2 l5 -twav

I may have other specific test commands after I see the script output .