No sound input with VX-3000 webcam


I’m new to linux. I just set up my Dell Inspiron 9300 to dual boot in openSUSE 11.0 and XP. I have a Microsoft VX-3000 webcam that I would like to use with Skype.

I installed the gspcav1 driver from HCL/Web Cameras - openSUSE using 1-click install. In Skype, the item “MicroSoft VX3000 (/dev/video0)” is the only item available under “Select Webcam.” With this, the video looks fine.

However, the webcam doesn’t show up in the sound device options. For the “Sound In” option, the only options are “Default device (default)”, “hdmi”, “pulse”, and variations on “Intel ICH6 (hw:ICH6,0)” and “Intel ICH6 (plughw:ICH6,0)”.

Is there a way I can use this webcam as my audio device in Skype? Thank you!

I don’t have much experience in adding a second audio device, but I can try help a bit … First I think we need to see if it is detected at all, and for that we need more information.

To provide more information, then with your PC connected to the internet, please copy and paste the following into a gnome-terminal / konsole:

wget && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following, one line at a time, into a gnome-terminal/konsole and post the output here.
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

… also, if you manually created a .asoundrc file, please post that here too (I don’t think you have created such a file … but I’m asking just in case ).

… and also (again) … can you provide the product-ID / vendor-ID for your webcam? ie ensure “usbutils” is installed, and then type in a gnome-terminal / konsole:

wget && su -c ‘bash ./tsalsa’

tsalsa.txt - (beta)

rpm -qa | grep alsa


rpm -qa | grep pulse

(no output. I deleted pulse audio because I couldn’t hear any audio whatsoever while I had it installed… Used to have sound, but lost it - openSUSE Forums)

rpm -q libasound2


uname -a

Linux linux-kl0n #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-intel8x0

r0Vg.WA_mp4nOwu3:82801FB/FBM/FR/FW/FRW (ICH6 Family) AC’97 Audio Controller

alias snd-card-0 snd-intel8x0


Bus 005 Device 002: ID 045e:00e1 Microsoft Corp. Wireless Laser Mouse 6000 Reciever
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 045e:00f5 Microsoft Corp. LifeCam VX-3000.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


I don’t suppose the manufacturer of your mouse provides an opensource free driver for openSUSE Linux? rotfl! … ok … just kidding …

I don’t see a USB sound device in the tsalsa script output. Was your webcam plugged in when you switched ON your laptop? Was your webcam plugged in when you ran the tsalsa script? I am trying to find out information on the webcam, and hence if you did not do this before, the script might give more information if you plug in your webcam with your laptop switched OFF, then switch the laptop on, and after it has booted, run the tsalsa script again, and see if there are any differences (ie is your extra mic/sound device in your Microsoft webcam listed in the script) ?

I do note that two mic’s are identified in your mixer output. I take it then you tested both those mic input’s to see if either of them might be associated with your webcam.

Yes, the webcam had been plugged in since startup when I ran the script.

How would I check the inputs of the two mics? Can I do that in alsamixer or in yast?


This effort does not look promising. I note the Ubuntu web cam wiki for your webcam:
state this:
Microsoft Lifecam VX-3000 - 7.10 - 045e:00f5 - gspca
The camera works, but the picture has abnormal colours and Skype eats 100% CPU during the video call. Skype also may hang during or after the call. The built-in microphone doesn’t work, although it is seen by ALSA.

I run KDE-3.5.x, and on KDE3 I would simply go into kmixer. I can’t answer this for gnome.

If I bought a microphone that plugged into my sound card’s mic port, would the computer pick up sound from that while set to “Default device (default)”?


I can not answer for the specific device setting you mention, but I do believe it very likely that an inexpensive microphone, that connects to your PCs line-in or mic jack/plug on your PC, should generically work with openSUSE linux. Many people have such a mic, … why not borrow one and test this?

Okay… I bought a small microphone for the microphone jack on my sound card. I know it is working because it was playing the sound from the mic through the speakers until I changed the playback mic input to 0.

However, I cannot figure out how to configure the recording mic input. How can I do this?


I’m a KDE user an not a gnome user … but some general suggestions …

To test your mic, I recommend you use “arecord”, with command lines like:
arecord -d 10 myrecording.wavandarecord -d 10 -f cd myrecording2.wavNotice “-d 10” means 10 second recording. Change it to “-d 5” and you get a 5 second recording.

You need to pay close attention to your mixer. In my case (with KDE kmix), after ensuring my “mic” was selected (for an external mic, as opposed to “internal mic” for an internal laptop mic) I also had to activate the mic in my mixer, ensure capture and volume levels (for the mic) were adequate, and ensure I had selected the “boost”, and finally, for a good 10 minute I was stumped because my kmix was mis-configured, specifically under the “switches tab” which had “surround jack mode” set to “shared” instead of “independent”. I don’t even know what that means, but it was enough to stop my capability to record audio, until I changed to “independent”.

Your experience will be different, but the point is be very careful and exact with your mixer.