No sound in Youtube(Flash)

I have a problem with sound (OpenSUSE 11.3 64bits KDE 4.6.2 “Release 3”).

Sound is working in Amarok, VLC and System-warnings, but not in any web-browsers that play youtube-videos. I have Flash that is the latest version available from Adobe.
I read somewhere that there was some problem with sound on Youtube, but i thought this was fixed.

Need help!


Did you try with an older version of Flash? I’ve read the new one has caused some troubles - and if you don’t have 11.4, it may be possible.

However, maybe you find this old thread helpful:

Flash videos in Firefox without any sound - OpenSUSE 11.1

I don’t know what happens, but after a reboot it works :slight_smile:
Maybe there was som updates that require reboot…


I also forget to reboot it after updating. Great that you solved it!

Not solved yet :frowning:

Now i see the problem. If i use Amarok to listen to Internet radio, sound in web-browsers get deactivated and i can’t activate sound without reboot.

So i boot up and access youtube in Firefox og Opera it works. Then i start Amarok and play music in it and then all sound i web-browsers disappears.
Need to reboot to get sound back again.

What is this? A bug?

On 04/29/2011 12:36 PM, riderplus wrote:
> I also forget to reboot it after updating.

it is very seldom that a reboot is required after an update…it should
tell you when it is required…otherwise, not…

[openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8 via NNTP]
HACK Everything →

Try to install Gmerlin alsamixer, then open your terminal write alsamixer and increase the sound bars.

On 04/29/2011 01:36 PM, ronnys wrote:
> Need to reboot to get sound back again.

well, first, i guess you don’t actually have to reboot…you may but i
guess you don’t–try this, instead of rebooting: right click on desktop,
pick “Leave”, next popup pick “Logout”, you will land on a log in
screen, log in as yourself, and see if youtube works again…i think it
will (without a reboot)…this is not Windows and reboots are not nearly
so often needed, and should almost never be expected to ‘fix’
anything…the reason Windows needed to reboot so often (i’m told) was
because it was so easy for the registry to get ‘confused’

> What is this? A bug?

if it is a bug i do not see it here…just now i played a youtube piece,
then started an mp3 in Amarok…it worked…then started a youtube
piece and both were paying, and both could be heard…

i guess the difference in success and failure has something to do with
my system vs yours… i’m running 11.3 32 and an older KDE, but i think
the probably REAL difference is that you are using PulseAudio and i
won’t let that pig on my machine because it messes up so much…when i
found out it wouldn’t place nice with Skype on 10.3 i deleted it there,
and then when i installed 11.3 i removed it from the list of items to be

note: i am not making a recommendation to you that you change anything
in your system…i am NOT a sound/multimedia guru…and, many of those
recommend PulseAudio…

[openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8 via NNTP]
HACK Everything →

So and I am not multimedia guru. But because I have faced the problem again in 11.3, with this way I have solved. Of course do not confuse that all multimedia problems solve with this way(This comment is not for DenverD is for new members).

This all is part of the reason why Pulseaudio was introduced in 11.4 in KDE, I guess.

And instead of a reboot the command:

su -c 'rcalsasound restart'

should “fix” the sound issues that you are facing as well. You’ll have to restart things like KMix etc, though. (However this is probably still not the way it ought to work.)

As i can see i only have PulseAudio. After i upgrade KDE to 4.6.x i got sound-problems. I change Phonon-backen from GStreamer to Xine and got the sound back. I only have Pulsaudio listet in Phonon.
If i right-click on the Volume-control the link to KMix is deactivated. If i left-click to open Master-volume, then i can click on Mixer and get into KMix.

Sound on OpenSUSE is not an easy thing! :frowning:

Try also that maybe fix this problem.

You actually have PulseAudio in openSUSE 11.3? Hmmmm, for the time that I have been running 11.3 I have never had PulseAudio.

And as an aside, PulseAudio does not replace ALSA. Instead, you have both running; PulseAudio on top of ALSA, sort of. Saying that you “only have PulseAudio” is likely wrong.

That’s normal.

Like this:](

And this:](

Also normal.



Ok! I see ALSA is installed. I conclude that KDE 4.6.x do have some problems with sound. I hope this will be fixed soon. It all worked perfect on KDE 4.4.4


Just a few comments. I had this problem until following the instructions (easy way) in Multimedia in One Click and then installing gstreamer plug-ins good through YaST2 Software Management NOT KDE package kit. which jams up frequently.

I had previously ticked [size=3]audio, pulse, and pulse-access[/size] in Security and Users>User and Group Management>[user]>Details prior to the above but it had no effect. I left the settings ticked off.

Note: kmix messed my system up so it was uninstalled. But this was after Audacity was installed. I wound up dumping both of them. The less software the better, in my experience. Any program or plug-in that affects audio can have disastrous effects.

Note: ALSA and PulseAudio are two inseperable entities, I believe…