No sound in webcam recorded video

Topic: Webcam Microphone Not Working (Solved),152015.0.html

I’ve tried (configuration si the same and modprobe snd-usb-audio)but didn’t help for me. Situation is the same. Cheese sound:yes, Webcamoid:no. Also VLC notices it.

I think I create test user…
There is something I don’t see :frowning:

I think I create test user…

Test user didn’t help. Situation is the same as before.

I have a Logitech C910 which works fine for recording audio with guvcview on openSUSE-LEAP-15.2.

I tested just now, first with a 2 month old version of Tumbleweed, then after an update (dup) to the lastest Tumbleweed version - and I can reproduce the failure you have with guvcview with both Tumbleweed versions, and I can reproduce the failure you had with the Webcamoid with the older Tumbleweed version (I did not try Webcamoid with the newer Tumbleweed). I was not thou, able to even record audio with Cheese with the older Tumbleweed.

So I suspect there is an audio record issue here, either with Tumbleweed, or with the build of these webcam apps under Tumbleweed.

I note according to pavucontrol, the audio should have been recorded - however best I can see, an audio input with absolutely zero audio content in it is in the actually audio section of the video file. I tried different video formats, and none made a difference.

As I note, this works fine under openSUSE-LEAP-15.2 - so I suspect a bug … somewhere … I just don’t know where.

It is good you can reproduce the failure, so it is not just my configuration. I tried C525 in my mother’s openSUSE Leap 15.3 but no sound with Cheese and Webcamoid (=both failed).

I, too, think this is a real bug, so I wrote about this on the Webcamoid site, although I suspect the bug is not in Webcamoid but in openSUSE.

Further to the above, I repeated my Tumbleweed test today, just to confirm it was 100% repeatable. Once again, neither guvcview nor webcamoid would record audio.

I then installed the ‘kwave editor’ and noted it would record audio. I then launched ‘cheese’, and this time, to my surprise, ‘cheese’ did record audio - and as far as I know, the only difference between this time (testing with cheese when it did work) and the last time (testing with cheese when it did not work) was installing and running the ‘kwave editor’. I did try again guvcview and webcamoid and neither would record audio under Tumblweed with my Logitech webcam.

My suspicion is something has changed wrt the audio in Tumbleweed such that guvcview and webcamoid are not sufficiently compliant with the change such that they can record audio. As to whose ‘fault’ it is wrt the audio not recording, I have no knowledge. Possible the Tumbleweed audio change was fully compliant with the pulse audio/pipewire ‘standard’ (but guvcview and webcamoid were not) or possibly the opposite, and possibly Tumblweed changed something that broke some apps audio recording (where those apps are compliant with what was advertised as working with pulseaudio/pipewire).

But in summary, on my Tumbleweed, with my Logitech 910C webcam, kwave and cheese will record audio, and guvcview and webcamoid will not record audio. …

I don’t plan to spend any more time on this, as Tumbleweed is not my main system (rather openSUSE LEAP-15.2 is my main system at present), and I have tried pretty much everything I can think of (including suspending pulse audio, which did not help).

Thanks for testing and answers.
I agree with you. I also found that I can record audio with another app (I may not even need a video).
Of course, it would be nice to know if there is the same problem with all camera brands.

I installed a new version of Mageia (Version 8) to Qemu / KVM and at the same time I tested how webcamoid works in it (HW is of course the same as before because I run Mageia in Tumbleweed).
Webcamoid recorded video and sound ok in Mageia with Webcamoid version 8.8.0 (Qt 5.12.8)
Is it time to write a fault message to openSUSE?

Yes. .

Consider writing the bug report on qt5 on LEAP-15.3 (although if you can’t test 15.3 easily then write bug report on Tumbleweed and note same issue with LEAP-15.3) … although you could also write it on the kernel.

I note guvcview app records fine in LEAP-15.2

I note in Tumbleweed cheese works. Its a gtk app.

However qt apps webcamoid, guvcview, and guvcview-qt5 (I tried all 3) don’t work under Tumbleweed. I note openSUSE-LEAP has been gradually removing QT4 support files as it now uses QT5 in LEAP-15.2, 15.3 and Tumbleweed. LEAP-15.2 kept a lot of the QT4 support files for compatibility, but I believe they have been progressively been removed in LEAP-15.3 and Tumbleweed.

I note when running Tumbleweed, guvcview (and guvcview-qt5) when set to record (but no audio recorded) gives a visual indication it is receiving the audio, with the guvcview and guvcview-qt5 ‘coloured bars for audio’ moving left/right per the USB webcam audio detected. But inexplicably audio is not recorded despite that visual indication that guvcview is receiving the audio. So that makes me in part suspicious of guvcview app and webcamoid apps, but I can’t be certain its them. The fact BOTH don’t work, makes suspicious of the openSUSE-15.3 and Tumbleweed qt5.

Its a puzzle.

Yes. I write a bug report. I can do it on LEAP-15.3 (my mother’s pc).
It will take time because the hardest part is the translation from Finnish to English. :wink:

however, I wrote a bug report about tumbleweed.

Thanks. I added my ‘2-cents’ to the bug report. The openSUSE packager who responded to your bug report is an alsa sound driver developer. So if its not openSUSE Leap, he hopefully will be able to point us who to contact next. … or he may have some tests to be attempted.

I note I can get guvcview to work fine in opensUSE-LEAP-15.2, while you can not. … Thats strange.

I’ve tried so much to figure out this problem that I’m probably confused with those versions of LEAP.

I will try my best to provide more information, but it is not always very easy because I have to try to translate the terms.
However, could the fault be in the Webcamoid / Cuvcviewer common engine, as the older (8.7. Etc.) version of Webcmaoid works. Is it possible to run an older version on LEAP-15.3 or Tumbleweed?

Use LANG=C prefix to get english output in console:

LANG=C some-command

Hi, This is really good information. :slight_smile: