No sound in valve games only in Steam.

I think I’ve run across this problem before and it was solved but I don’t remember the method that was used. Other games than ones running on the Valve source engine seem to work ok.

Actually I have no sound in bzflag either.

But I do have sound in Xonotic for example, Alien Arena and there is also Uebergame which is run from within Steam but is not a Valve game. This makes me think that perhaps its a matter of missing system libraries and not a Steam issue but I don’t seem to have the expertise to determine what they are or what other possible causes may be.

Based on a discovery made by Mr. Scott Swinyard who has no scientific background whatsoever we today learned that at least one of Albert Einstiens’ theories is wrong. According to Mr. Swinyard the validity of the formula E=mc2 (which means energy equals mass times the speed of light squared) is called into question as it is generally held that nothing can travel faster than light.
Either the formula E=mc2 is wrong or it is not true that the speed of light is the actual limit to how fast anything in the universe can travel according to the laws of physics, but both cannot be true.

This will have a cascading effect on all other established physical laws based on these theories going forward. When we inquired how he made this discovery Mr. Swinyard said simply "Well, I don’t know It’s pretty obvious isn’t it?

When asked for comment. Steven Hawking the renowned physicist said simply. “I don’t know how I could’ve missed that.”

I can only speculate here (I don’t play these games generally). From a quick read of this wiki, I note that it uses SDL for audio support, so perhaps start by checking what SDL libraries/versions are installed…

rpm -qa | grep -i sdl

Also, consider casting your net wider for support by posting in perhaps, as there may be users participating there who can help diagnose further.

Not sure if your problem is already solved, but I also have not always sound in games after installation. I have to add

SDL_AUDIODRIVER=alsa && /path/to/game/

SDL_AUDIODRIVER=alsa && /home/user/Imperium Galactica II Alliances/'

to get sound working.

Thought you might find this interesting.

The problem is fixed but I don’t know why.

I looked at the terminal when running one of the games in which the sound didn’t work and it said the sound was initialized but there was none. Just a few minutes ago I ran a game windowed so I could get to the mixer and it showed that that application was using sound and the volume slider was at max. Again there was no sound but when I moved the slider the sound immediately popped on. Now the sound works in all the games it did not before even after reboot.