no sound in toshiba tablet


i am absolutely new in linux opensuse and despite falling in love with it ,i really do not understand a lot of things about it ,but right now the main problem i have is that my toshiba protege m700 taplet has no sound at all and tried everything that i could, but still nothing .as soon as i boot ,i receive a message that says there is no sound because the computer went back to the default sound or something to that nature,could somebody please give me some help regarding this issue.thanks.mike

Please try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

To determine if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times.

If that does not work, please post here (stating your desktop (kde4, kde3, gnome) and openSUSE version) and there is a script and some rpm commands you could run to provide us more information on your PC setup, upon which a recommendation could be made.


thank you so much for your attention to this problem.I just ran that command in terminal and here is the result which i do not understand what it means.

mikearzan@linux-3sdl:~> speaker-test -c2 -l5 -twav

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
0 - Front Left
1 - Front Right
Time per period = 2.856876
0 - Front Left
1 - Front Right
Time per period = 3.007857
0 - Front Left
1 - Front Right
Time per period = 3.007993
0 - Front Left
1 - Front Right
Time per period = 3.007917
0 - Front Left
1 - Front Right
Time per period = 3.029252

meanwhile i am trying to go thru the link you put here earlier.
BTW, i am using open suse 11.1,KDE on a toshiba M700 tablet pc .please let me know what else you need.thank you again . mike

I forgot to mention ,after running that command ,i did not hear any sound or ladies voice from the speakers .mike

As I noted previous, you should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times, at the same time as you see the text.

If you have no success with the audio troubleshooting guide, then I will need more information if I am to make a recommendation … So can you provide more very detailed information so a good recommendation can be given? You can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and typing:
that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. I need that output to understand better your Toshiba’s configuration.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/soundI also need that output. Hopefully with that I can make a good recommendation.

The first command that i ran ,returned with the answere that says a newer version is available ,doyou wish to install it and when i clicked yes ,it returned with this

              │ Newer version of ALSA-Info has been   │
              │ found                                 │
              │                                       │
              │ Do you wish to install it?            │
              │         < Yes >     < No  >           │

cp: cannot create regular file `/usr/sbin/’: Permission denied
ALSA-Info script has been updated to v 0.4.52
To view the ChangeLog, please visit Git - alsa-driver.git/history - utils/
Please re-run the script

and then this the result of the other four commands.

mikearzan@linux-3sdl:~> rpm -qa | grep alsa
mikearzan@linux-3sdl:~> rpm -qa | grep pulse
mikearzan@linux-3sdl:~> rpm -q libasound2
mikearzan@linux-3sdl:~> uname -a
Linux linux-3sdl #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux
mikearzan@linux-3sdl:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.QoA91lxoybA:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

… Either select “NO” you do not want to update the script, and the current (older) version of the script still would have run, or alternatively, if you want to update the script, then you need to run the script with root permissions, as that will then update the script.

Please try again.

respectfuly ,as i mentioned before ,i really don’t knw much about linux and a lot of stuff is unknown for me,so,i do not know how to do anything with the "root permission ",would you please explain little more here.because as you said i tried NO for that script but it gave me alot of other options which makes more confused,i am just pulling my hair here as i go further and i realize the extent of my lack of knowledge about this operating system.

OK, every Linux install has at least one user, and that one user is the administrator, which is known as user “root”. However for a number of reasons, it is not safe to run one’s PC all the time with root (administrator) permissions, so every openSUSE install (and almost all Linux distributions) require one to also create at least one regular user account, where that regular user account has less permissions than the root (admin) user. One should ALWAYS login and run as the regular user, and switch to root user sparingly.

As noted, it is extremely dangerous to run as root user.

There are various ways to run the script as the root (admin) user. One easy way is to open a gnome terminal or a kde konsole, and for that terminal/konsole session ONLY, switch to root (admin) user. One can do that by typing the command to switch users, but do not specify the user you wish to switch to. If one does not specify the user to switch to, the command assumes one wishes to switch to be the administrator. One can simply do that by typing “su” (no quotes, enter root (administrator) password) and everything typed from then on in that terminal / konsole session (while it is open) will be done with root permissions. One can confirm they are ser root by typing “exit” (no quotes) which will tell you which user one is. When one no longer needs root permissions, one can then type “exit” and that will restore one to regular user permissions. If one types “exit” too many times, it will close the terminal / konsole session. Again, just type “whoami” to see which user on is. The prompt (on the left) will also change from “>” to “#” depending on one’s permissions (that is a default openSUSE setup).

Another way is to send only a single command with root permissions. The way I prefer to do this is to use the ‘su’ command, but add an option tell the command this is to ONLY be done for one single command, and no subsequent commands. So in the case of the diagnostic script, with your pc connected to the internet please type:su -c '/usr/sbin/’and enter the root password when you are asked for a password. That will switch users to root (“su”) for one command ( " -c " ) where that one command is everything between the quotes ( ’ /usr/sbin/ ’ ) . This time when you run the script, if it asks to update, and you select Y, it will be able to download the script to the directory /usr/sbin, while if you run the script with regular user permissions, it is not allowed to write to that directory . Once that is complete, run the script again, but this time as a regular user./usr/sbin/alsa-info.shthis is incredibly easy to do and it is second nature for anyone with a moderate amount of Linux experience.

I have the the same tablet as you, and to get sound, I fire up YAST. Start the sound module, click edit on the sound card popping up, and enter toshiba as the model. Voila you have sound. If you have the touch enabled version go to this page : OpenSuse on a Toshiba Portégé… for information on how to get it up and running. NOTE: supposedly the beta drivers include the patches to get touch running, but I have not tested them so I can’t say for sure.

If the model option “toshiba” works, that suggests the tablet has an ALC267/268, or an ALC861/660 or an AD1981 hardware audio codec. One of the reasons why I was pushing user mikearzan to run the diagnostic script, was it would tell me what hardware audio codec his tablet has.

For information, here are some entries from the list in ALSA-Configuration.txt file for 1.0.18a of alsa:

	  quanta-il1	Quanta IL1 mini-notebook
	  3stack	3-stack model
	  toshiba	Toshiba A205
	  acer		Acer laptops
	  acer-dmic	Acer laptops with digital-mic
	  acer-aspire	Acer Aspire One
	  dell		Dell OEM laptops (Vostro 1200)
	  zepto		Zepto laptops
	  test		for testing/debugging purpose, almost all controls can
			adjusted.  Appearing only when compiled with
	  auto		auto-config reading BIOS (default)

	  3stack	3-jack
	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack with SPDIF I/O
	  3stack-660	3-jack (for ALC660)
	  uniwill-m31	Uniwill M31 laptop
	  toshiba	Toshiba laptop support
	  asus		Asus laptop support
	  asus-laptop	ASUS F2/F3 laptops
	  auto		auto-config reading BIOS (default)

	  basic		3-jack (default)
	  hp		HP nx6320
	  thinkpad	Lenovo Thinkpad T60/X60/Z60
	  toshiba	Toshiba U205 

Hello old cpu
sorry about getting back to you so late.I was trying to take care of this problem mostly today and i can say i must have been working on it probably more than 20 hours in the past 3 or 4 days .before anything i would say you are a great person and you did everything to solve my problem ,but well sometimes ,somebody’s bad luck affects somebody elses’ good intentions.anyways ,i also tried the other gentelman’s suggestion regarding changing the sound card module to toshiba and so on but again no luck .i tried every single option in that sound troubleshooting which you reffered me to earlier,nothing again and i really do not want to bother any more and i am ready to give up.I think at this point linux is too complicated for me .BTW,your explanation about root user made a great sense to me and i learned a lot.thanks again .mike

I suspect this is solveable, … its really a matter of unfamiliarity with Linux is making this appear much more difficult than it actually is. If you can give me the output URL provided by running:


and also the output of running:

cat /etc/modprobe.d/sound

I can likely give you a recommendation to fix the sound problem.

Good luck in what ever path you go.

Hello again old cpu

ya.i’m still here,you made me to stay and don’t give up so quick.another reason is ,despite having some early problems with it which is normally not necesessary in today’s computer envoirenment (everything is ready to go right out of the box),i really like linux .
below ,you will find the two things you asked me for ,the top one is the link to the url and the second is the output,which i’m pretty sure there is no need to tell you what is what.I thank you again for the time you are spending for thiss .

│ Kernel release: │
│ Operating System: GNU/Linux │
│ Architecture: i686 │
│ Processor: i686 │
│ SMP Enabled: Yes │
│ │
│ │
│ !!ALSA Version │
│ !!------------ │
│ │
│ Driver version: 1.0.17 │
│ Library version: │
│ < EXIT > │
Your ALSA information is located at

Please inform the person helping you.

mikearzan@linux-ksiq:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.QoA91lxoybA:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Thankyou for that. I see that your Toshiba Tablet has an ALC268 audio hardware codec.

Please add a line to your /etc/modprobe.d/sound file, such that it now reads:

options snd slots=snd-hda-intel
options snd-hda-intel model=toshiba
# u1Nb.QoA91lxoybA:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel 

then restart your PC and test your sound. Please be very careful in checking your mixer.

Note you need root permissions to edit the /etc/modprobe.d/sound file. You can do this by typing: kdesu kwrite /etc/modprobe.d/soundenter root password when prompted. Make the change and save the file.

Again, to determine if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times

Brilliant my good sir.
I forgot to mention the above, in case Yast did not do the trick. Had to edit that file under 11.0, but not under 11.1 or 10.3.

A few other tips regarding that tablet. Don’t update the gstreamer packages if you add the packman repo since that makes your webcam unusable by cheese. I have no idea why, but if your interested I’m sure there are several bright heads on this site capable of explaining it.

Sax will add two input devices in your xorg.conf for the alps touchpad. Remove them both and substitute them with this:

Section “InputDevice”
Driver “synaptics”
Identifier “Mouse[1]”
Option “AccelFactor” “0.1”
Option “BottomEdge” “650”
Option “Buttons” “5”
Option “CircScrollDelta” “0.1”
Option “CircScrollTrigger” “2”
Option “CircularScrolling” “1”
Option “Device” “/dev/input/mice”
Option “EdgeMotionMaxSpeed” “15”
Option “EdgeMotionMinSpeed” “15”
Option “Emulate3Buttons” “on”
Option “EmulateMidButtonTime” “75”
Option “EmulateTwoFingerMinZ” “90”
Option “FingerHigh” “17”
Option “FingerLow” “14”
Option “HorizScrollDelta” “0”
Option “HorizTwoFingerScroll” “1”
Option “InputFashion” “Mouse”
Option “LeftEdge” “120”
Option “MaxSpeed” “3”
Option “MaxTapMove” “110”
Option “MaxTapTime” “180”
Option “MinSpeed” “0.2”
Option “Name” “ALPS;Touchpad”
Option “Protocol” “auto-dev”
Option “RightEdge” “830”
Option “SHMConfig” “on”
Option “TopEdge” “120”
Option “UpDownScrolling” “1”
Option “Vendor” “Sysp”
Option “VertScrollDelta” “20”
Option “VertTwoFingerScroll” “1”
Option “ZAxisMapping” “4 5”

Doing that will enable two finger scrolling…please remove the superfluous entry in Xorgs serverlayout. In the above text the mouse is identifed as mouse 1.

Sax won’t set up the touch screen for you, even if you aply the patch by Rene Van Paasen. Add this to your xorg.conf:

Section “InputDevice”
Driver “wacom”
Identifier “Mouse[13]”
Option “BaudRate” “38400”
Option “Device” “/dev/ttyS0”
Option “ForceDevice” “ISDV4”
Option “InputFashion” “Touch”
Option “Mode” “Absolute”
Option “Name” “portege m700”
Option “Protocol” “Auto”
Option “Type” “touch”
Option “Vendor” “TABLET PCs”

Update serverlayout accordingly.

Add the following to your boot.local (I assume you’ve seen the link provided in the previous post to get the pen working)
modprobe -a toshiba_acpi. That loads the toshiba kernel module on boot and enables you to suspend and resume without a hitch,

Dear old cpu

you are the best.Thank you very much,you are the master .Everything works now,Ichecked one radio station to make sure this is not just temproary.It is beautiful when you have sound and it is excellent when you have it after such a hard work with the guidance of a great master.


Dear friend NORDLIBRIS

thank you very much for your attention to this matter.I didn’t get a chance to check the stuff you mentioned yet,when i come back home this evening ,i will jump in to it and deffinitely let you know what was the outcome.

again thank you all.mike

Congratulations! Well done on your perserverence.

If I may make a suggestion, next time you get stumped, if it is not urgent, do not spend excessive time. Instead make a help request on this forum, and there is a reasonable chance someone may have an idea for a solution. Another venue for support is IRC on freenode channel #suse (where one can often get immediate support).

nordlibris, thankyou for your suggestion to try model=toshiba. With out that recommendation, I would have asked mikerazan to try every possible model configuration for the ALC268, which would have taken excessive time, and would have been subject to errors due to typographical syntax mistakes and frustration. Its always very nice when a user with the same hardware chips in to help. Thanks.

Yes ,thank you for the advise.Now this question might be off topic,but if i may ,as i mentioned at the beginning ,i just got to know linux and suse and basicaly know nothing and even do not know how to do the basic stuff like “how to install the files that i download”,for example i downloaded a flash file for firefox browser and still i do not know how to install it ,there are four different type of files with four different type of installing which i tried all four with the relative instructions ,but still i did not get anywhere,because sometimes after i put my password in terminal ,i receive a line at the end that says something like “have fun …” but after that again a new line starts with a blinking thing that shows i can not start my session until i put something else there which i always think ,it is waiting for me to put my password again and when i do that i receive this “wrong command or command is not known or something in that nature” which frustrates me .My computing exprience with windows and mac in the past was to do anything with couple of clicks and the rest would be done by the operating system…so,what i am trying to say is : I am really a first grade student who has to start from learning alphabet,…IS THERE ANY LINK OR SITE THAT CAN TEACH ME EVERYTHING FROM SCATCH ABOUT SUSE OR LINUX OR UBUNTU.? including how to know what type of commands i need put in terminal and how to realize when is the time to put a command to begin with.
sorry about taking some of your time with a question which is inappropriate for this topic.thanks.

I don’t know. I’ve been using Linux for so long, I’ve long since stopped looking at such sites. But I did start a concepts page for openSUSE Linux, which has been greatly improved by contributions of others in the community: Concepts - openSUSE

Reference installing software, its best IMHO to install prepackaged applications that are packaged as “rpms” (see the concepts link above). But before I can go into detail on that, some basics on openSUSE multimedia, if you let me pontificate a bit (sorry) about openSUSE philosophy. Multimedia as provided by Novell/SuSE-GmbH is mostly crippled for all proprietary codecs. This is because openSUSE is openSUSE. Note the emphasis on open. Novell/SuSE-GmbH try harder than most Linux distributions, to ensure openSUSE adheres reasonably close to the open source free software philosophy, which is to NOT PROVIDE software which is NOT free to give away, and not provide software where the source code is not available, and not provide software which is NOT free to copy, and not provide software which is NOT free to modify, and not provide software which is NOT free to give away modified copies. This means many proprietary hardware drivers, and proprietary video/audio codecs, and many price free proprietary applications (but not opensource free) are not included with Novell/SuSE’s open source Linux “openSUSE”.

But you can EASILY get 3rd party packages to work around this. EASILY. Setup your Software Package Manger with OSS, Non-OSS, Update and Packman repositories. Just those 4. No others. None. You can add others ONLY after you learn the risks and problems that exist with the others, and ONLY after you learn how to work around the dependency and other problems that can crop up as a result of adding extra repositories (repos). There is guidance here for adding repos to openSUSE Repositories - openSUSE-Community … click on your SuSE version and follow the instructions and add ONLY OSS, Non-OSS, Update and Packman. Just those 4. In particular, do NOT add videolan, as some of its apps and codecs are not compatible with packman and will cause breakage.

Now, you may have figured this out already, but just in case not, I typically recommend, after the 4 repos are added, with your PC connected to the internet, go to YaST > Software > Software Management and change the “filter” to “search” and install the packman packaged versions of smplayer, mplayerplug-in, vlc, libxine1, libffmpeg0, w32codec-all, amarok, amarok-xine. That should get your started. For openSUSE-11.0 and earlier, you will need to remove xine-lib before installing libxine1. Reference flash-player, you should get an rpm for flash-player-10 after from the “update” repository that I recommended you add.