No sound in Suse 11.1 with Cirrus Logic CS4281

I am having problems getting sound to work in Suse 11.1 with a Cirrus Logic CS4281 chipset. I believe audio was working correctly in 10.2 (using KDE 3.X) but I am not 100% sure. The output from can be found at: For a window manager, I am using the minimal x option. In general, I need sound to work without having an X server running (this is an embedded system). The motherboard is a VSBC-8 from versalogic and the manual can be found at

Here is a list of the things that I have tried:

  1. Used alsamixer to set all volumes to 100
  2. Used Yast to set all volumes to 100
  3. Used Yast to test the sound
  4. Used xmms to test playing a mp3 file
  5. Used speaker-test -c2 -l5 -twav

Can you also provide output of:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Thank you for the help. Here is the information that you requested. Pulse audio was originally installed on this machine but I uninstalled it. The uninstallation did not make a difference.

rpm -qa ‘alsa


rpm -qa ‘pulse

rpm -qa libasound2


uname -a

Linux dh089183 #1 SMP 2010-02-22 16:49:47 +0100 i686
i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-cs4281

qnJ_.8sqwwZxW3J2:Crystal CS4281 PCI Audio

alias snd-card-0 snd-cs4281

Your sound should be working. … Please try each of these speaker tests:

  • first:
 speaker-test -Dplug:front -c2 -l5 -twav
  • second, try again:
speaker-test -c2 -l5 -twav
  • third:
speaker-test -c2 -D hw:0,0 -t wav -l3
  • fourth, this next command has a volume meter at the bottom of its output with a changing number of #'s and %'s to show volume levels so run this command and tell me if the number of #'s and %'s are changing:
aplay -vv /usr/share/sounds/alsa/Front_*
  • fifth: and also:
aplay -vv /usr/share/sounds/alsa/test.wav

Do any of those give an indication of sound ?

Sound is now working. It was a hardware issue, as someone moved a cable connected to the motherboard. Thank you for the assistance.

Wow wee! I hate it >:( when that happens!