No sound in speakers but sound in headphones on Acer Travel Mate 290

Hi everyone,
I have an old Acer Travel Mate 290 with OpenSuSE 11.3 (LXDE) 30G and 240Mb RAM. I don’t have sound in the internal speakers, I only have sound through the headphones.

Here you will find the information of

When I type:

rpm -qa ‘alsa

rpm -qa ‘pulse

rpm -q libasound2

uname -a
Linux 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-intel8x0

W60f.nEL2Mvwx8t2:82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC’97 Audio Controller

alias snd-card-0 snd-intel8x0

I would be grateful if anyone could help me step by step to solve this problem.

Check the mixer and channel settings that they are not muted.

You may check my thread (SPEAKERS BUG in Lenovo Thinkpad 13 EDGE) about my laptop that, seems to me has the same problem, I’m still fighting with it.

Your hardware is NOT an ALC202 (which is the hardware in user vagasv’s PC) and hence that thread is NOT applicable, although the tests I have in post#26 of that thread are possibly useful.

vagasv, I note your volume levels are around 75%. If you move them up to 95%, does that make a difference ? Also, note the sound from speakers is supposed to be muted if the headset is plugged in. If the headset is not plugged in, then the speaker sound should work.

If you are confident your mixer levels are as high as possible, and you still have no speaker sound, then write a bug report on openSUSE-11.3 component “sound” for your hardware. There is guidance here for doing that: openSUSE:Submitting bug reports - openSUSE You can log on to bugzilla with your openSUSE forum user name and password.

It will help if you attach the diagnostic script output to your bug report. You can generate that file by typing:

/usr/sbin/ --no-upload

which creates the file /tmp/alsa-info.txt. Attach alsa-info.txt to your bug report.

This bug report will be answered by the openSUSE packager for sound who is also an alsa sound driver developer. Please follow the bug report (check every day or so for an answer) and support the openSUSE packager in solving your problem. Once your problem is solved (with your support) the fix will be sent upstream by the packager and all Linux distributions will benefit.

Good luck.

I checked this with Gmixer and Alsamixer and there’s no channel muted. Still the sound don’t come out through the speakers.

I moved the volume up to 100% and I made the tests that you posted in “SPEAKERS BUG in Lenovo Thinkpad 13 EDGE post#26” so, like a normal user and root user I don’t hear anything through the speakers but when I plug the headphones the sound come out (only in headphones) like a normal and root user.

I will send the bug report with the alsa-info.txt attachment.

Thanks for your answers guys.


I’ve changed the internal connector and now it works “out of the box”!
I love this distribution.