No sound in Source/Gold Source games in Steam

I am using steam from the games repo with Opensuse Factory. All other games the sound works perfectly. I am using the default pulseaudio configuration and I am wondering if anyone else has the same issue.

Thanks in advance.

I had a similar issue I needed to set the SDL_AUDIODRIVER environment var, from
SDL1.2: needs SDL_AUDIODRIVER=pulse
SLD2.0: needs SDL_AUDIODRIVER=pulseaudio

after this it worked fine for me.

For added help with PulseAudio:

Thank You,

II thought Valve had fixed this?

They may have, it’s been a while since i tested it, i was using it back in the pre public beta days, i think i ended up exporting it as a environment var and haven’t had a issue since.

Since 13.1 this problem has returned. :frowning:

Sound has stopped working in all Valve games.

Its not an openSUSE issue though.

Serious Sam 3 has no issues, sound is still working.
Doom 3,which I compiled myself on 12.3 ( with help ) also still works.

Pulse has always seemed to be problematic for me. I just go to YaST/hardware/sound and then select my soundcard, disable pulse, save, and reboot the system. When it comes back there are many more sound options and sound is there for everything I do.

Been doing it since OpenSuse 12.1. Just installed OpenSuse 13.1 tonight and once again no audio with Steam and a couple of other things. Works like a charm. Was playing TF2 in no time! :slight_smile:

You need to do the steps in this thread post:

That will fix the no-sound with OpenSuse 13.1.