No sound in Sauerbraten

The title says it all. Here’s some output:

init: sdl
init: enet
init: video: mode
init: video: misc
init: gl
Renderer: GeForce 7900 GS/PCI/SSE2/3DNOW! (NVIDIA Corporation)
Driver: 2.1.2 NVIDIA 173.14.09
Rendering using the OpenGL 1.5 GLSL shader path.
init: console
init: gl: effects
init: world
init: sound
sound init failed (SDL_mixer): No available audio device
init: cfg
init: localconnect
init: mainloop
read map packages/base/metl4.ogz (0.1 seconds)
Mining Station by metlslime
game mode is ffa/default
read map packages/base/mpsp9a.ogz (0.2 seconds)
Private Stan Sauer: Run & Gun Part I by MitaMAN
game mode is SP

If you have sound with other applications, it could be that you’re using oss which lets only one application at a time use the audio device. Eiither that or you’re using pulseaudio which has potential, but is still buggier than a volkswagen. Run alsaconf to reconfigure your sound card with alsa.

Well, I’m using pulseaudio. But if I run Sauerbraten with sudo, I get sound to work. Maybe it’s a permission problem, I just didn’t figure it out which permission it is.

Try adding yourself to the “audio” group.

I have tried sauerbraten on pulseaudio before. It runs okay, but there’s a slight sound lag (gun sounds play a few milliseconds after firing).