No sound in opensuse 12.1 - x32 on foxxcone 6487 mb

Hello,
I have no sound in OpenSuSe 12.1-586 x32 . I have PC with Foxxcone 6487 motherboard, I try to change settings, check muting, but I don’t get sound like on other systems. Before opensuse I installed Linux Mint Katya x32 and I also have no sound. I remember that when I used window xp I installed AC97 audio drivers. I have installed alsa-firmware package with no result.
I do not find a next step or hint in google.

  • Eldar

well … I would like to try and help.

I don’t know this hardware. Can you help me by running (with your PC connected to the internet) a diagnostic script, where that script will upload information to the alsa paste site, and give you a web/url-address where the information collected by the script is located. Post here that web/url-address. To run the script send the command in a terminal:


/usr/sbin/alsa-info.sh 

and select the share / upload option. When the script is complete it will post in the terminal the web/url address you are to provide. Copy and paste that address here.

Also, did you try installing pulse audio volume control (pavucontrol) at the same time as you run a multimedia application ? I gave some guidance on that here: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

Hello again,
I apretiate your help,
Sadly I have no internet now on this machine.
I will back when I will have a link .

Well, then instead try:


/usr/sbin/alsa-info.sh --no-upload

which will create the file /tmp/alsa-info.txt

copy that file to a usb stick. Then go to a computer with internet. And upload the content of the file to a paste site such as SUSE Paste. press ‘create’. and then copy the URL/web address given, and post it here.

But frankly, get your internet sorted. Without internet you can not download and easily install all sorts of useful multi-media apps to use a functioning sound.

Hello,
I have an internet on my machine. I run a script from a first note.
As you said this give me a next url :
http://www.alsa-project.org/db/?f=ef04fd1fcc1715c7ea5c37620331375c7f65d4d3

OK, thanks. First, can you please remove one possibility, which is the ‘master mono’ control in your mixer could be blocking sound. So unmute that … I noted there from here:


Simple mixer control 'Master Mono',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 0 **[0%]** -46.50dB] **[off]**

Please also, in addition, install the application ‘pulse audio volume control’ (pavucontrol) and use that to tune your audio for each multimedia application. I posted about that in a blog entry here: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

Hello,
I did not find it in pavucontrol,
I have used yast to configure master mono

new log :
http://www.alsa-project.org/db/?f=ecf17130c3128fe852cdc863a0b58a138f0d3933

I have no sound after changing settings, what can i check next?

Did not find what in pavucontrol ? what does that mean?

and ? Did that give you sound in YaST ?

Your kernel version is very old. Note the current current for 12.1 is 3.1.10-1.9 and your version is 3.1.0-1.2. Update your kernel, restart and test.

I am sorry to read that, but I confess I can’t understand most of what is in your post (other than that you have no sound). What test are you doing to check if there is sound ?

Did you try any of the tests noted here: SDB:Audio troubleshooting - openSUSE