No sound in opensuse 11.1

I have a dell studio 15 laptop with intel IDT 92HD73C 82801H ICH8 driver. Initially I had sound but after installing drivers for my broadcam wireless card, amarok-xine, libxinecodecs etc, I restarted my system and no sound is heard.

I tried everything mentioned in
SDB:AudioTroubleshooting - openSUSE

I got the following outputs

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.19-git20090324.
Compiled on Mar 24 2009 for kernel 2.6.27.19-3.2-default (SMP).

cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel

cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf6ffc000 irq 21
1 [HDMI ]: HDA-Intel - HDA ATI HDMI8
HDA ATI HDMI at 0xf6dec000 irq 17

vi /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

initially it had some options thing. after running alsaconfig, it became like this.

head -n 1 /proc/asound/card0/codec*
Codec: IDT 92HD73C1X5

the output of /usr/sbin/alsa-info.sh is located in this page.

http://www.alsa-project.org/db/?f=831eadfb0c8f72807de5aa0bfdafd5fbd083e95f

I have installed latest kernels as mentioned in the troubleshooting page. Plz Help.

I have a Dell Studio 15 also (although I have a different wireless). Sound works for me.

I think you failed in your efforts to update alsa, as indicated by this from the script:

!!ALSA Version
!!------------

Driver version:     1.0.19-git20090324
Library version:    
Utilities version:  1.0.18

If you were successful in following the update alsa recommendation in the guide, those both would be 1.0.19 git , and not just the one.

Please provide the output of:
rpm -qa | grep alsa
rpm -q libasound2
cat /etc/modprobe.d/sound

If you are impatient waiting for my response (to your output of the commands I asked you to run) you could also look here:
No sound on Dell Studio 1737 - openSUSE Forums

The Dell Studio 1737 has the same hardware audio codec as your laptop.

rpm -qa | grep alsa
alsa-plugins-1.0.18-6.12
alsa-plugins-pulse-1.0.18-6.12
alsa-1.0.18-8.7
alsa-driver-unstable-kmp-default-1.0.19.20090324_2.6.27.19_3.2-2.1
alsa-utils-1.0.18-6.4
alsa-firmware-1.0.17-1.42
alsa-oss-1.0.17-1.37
alsa-driver-kmp-default-1.0.19.20090329_2.6.27.19_3.2-1.1
alsa-tools-1.0.18-1.13
alsamixergui-0.9.0rc1-584.132

rpm -q libasound2
libasound2-1.0.18-8.7

cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

OK, I highlighted in red all the versions that are wrong. In particular, you MUST remove alsa-driver-unstable-kmp-default (high lighted in red BOLD). No where in the openSUSE troubleshooting guide did it say to install that.

Then update each of your alsa versions using the guidance I provided in the this thread: No sound on Dell Studio 1737 - openSUSE Forums

… and if you find that puzzling, please post here, and I’ll give you the specific commands you must send. DON’T FORGET to remove alsa-driver-unstable-kmp-default

but can u tell me how to remove that driver?

Go to YaST > Software > Software Management and change the “Filter” to “Search” and search for alsa-driver-unstable-kmp-default and select it for removal and remove it. That removal should be intuitively obvious once you find it.

ok…thorugh yast only rite??

when i tried to remove alsa-1.0.18-8.7, it was saying yast2-sound-2.17.13-1.1.i586 requires alsa

No one told you to remove alsa-1.0.18-8.7. You do have to update it, and if you do not know the commands to update it (and I gave you a thread with an example) then please advise, and I will give you the commands.

BUT I DID ASK YOU TO REMOVE alsa-driver-unstable-kmp-default. So please remove alsa-driver-unstable-kmp-default. OK ?

I’m trying to help you, but you have to read carefully what you are recommended to do.

okay… I will install all the packages mentioned and post the results … now its too late its 3 am here … :slight_smile: … so I will do it tomorrow and let you know… thanks a lot …

I wasn’t patient enough to wait till tomorrow… I followed every step but the audio is still not working… PCM slider is at the max position… there are no Master/Speaker sliders …

rpm -qa | grep alsa
alsa-utils-1.0.19.git20090319-1.2
alsa-tools-1.0.19.git20090320-1.2
alsa-firmware-1.0.19.git20090317-1.1
alsa-plugins-pulse-1.0.19.git20090303-1.10
alsa-oss-1.0.17.git20080715-2.24
alsa-driver-kmp-default-1.0.19.20090329_2.6.27.19_3.2-1.1
alsa-1.0.19.git20090304-3.1
alsa-driver-kmp-debug-1.0.19.20090329_2.6.27.19_3.2-1.1
alsa-plugins-1.0.19.git20090303-1.10
alsamixergui-0.9.0rc1-584.132

rpm -q libasound2
libasound2-1.0.19.git20090304-3.1

cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

You MUST REMOVE alsa-driver-kmp-debug !! Then restart your PC, and test the sound

still not solved… :frowning:

What are you using for a test, to determine if your basic sound works?

To determine if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:
speaker-test -Dplug:front -c2 -l5 -twav

Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 75%. Note the test for surround sound is different.

Its not uncommon that will not work, but another test will work. So if it does not work, please copy and paste the following different speaker-test into a Gnome terminal or a kde konsole:
speaker-test -c2 -l5 -twavIn either case, you should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times.

In the case of you Dell Studio 15, per the LINK I gave earlier, you may need to go to YaST > Hardware > Sound > Other > Test (although that may crash) or to YaST > Hardware > Sound > Other > Volume (that “volume” crashed on my PC, per the bug report). Also in your mixer move up PCM, Master Volume and Speaker volume to a very very high setting (I forgot initially to move up ‘speaker volume’ and my volume setting was very low).

If you have no success with that, then I need to do a further quality check on your setup … So can you provide more very detailed information so a good recommendation can be given? You can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and running twice (with root permissions):
/usr/sbin/alsa-info.shthe first time you run that it will offer to update the script. Please do so. Once the script is updated, run it again, and the second time that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

the output of /usr/sbin/alsa-info.sh is located in this page.

http://www.alsa-project.org/db/?f=83...afd5fbd083e95f

will post other details later… now I’m in office …

That URL is incorrect.

http://www.alsa-project.org/db/?f=4cd38351f72b622880711d0400159154e953b0f4

rpm -qa | grep alsa

alsa-utils-1.0.19.git20090319-1.2
alsa-tools-1.0.19.git20090320-1.2
alsa-firmware-1.0.19.git20090317-1.1
alsa-plugins-pulse-1.0.19.git20090303-1.10
alsa-oss-1.0.17.git20080715-2.24
alsa-driver-kmp-default-1.0.19.20090329_2.6.27.19_3.2-1.1
alsa-1.0.19.git20090304-3.1
alsa-plugins-1.0.19.git20090303-1.10
alsamixergui-0.9.0rc1-584.132

!!ALSA Version
!!------------

Driver version:     1.0.17
Library version:    
Utilities version:  1.0.19

There is a clear problem right there. The driver version 1.0.17 is not consistent with the utilities version, and you need a newer driver version for sound to work on this laptop with the new kernel.

So please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/soundWhen I have that, I will likely be able to see what mistake is present on the rpms that were installed.

rpm -qa | grep pulse

pulseaudio-module-jack-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
pulseaudio-module-zeroconf-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
vlc-aout-pulse-0.9.8a-16.1
pulseaudio-0.9.12-9.6
libao-pulse-0.9.3-1.185
alsa-plugins-pulse-1.0.19.git20090303-1.10
pulseaudio-module-lirc-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
libxine1-pulse-1.1.16.2-0.pm.2