No sound in Opensuse 11.1 (or any linux distro!)

I recently purchased a new Asus F8Va-B1. I have since been attempting to load a distro of Linux onto it. This laptop has many hardware support issues with common distros. After trying (no joke) at least 10 distros, I ended up attempting Opensuse. Opensuse worked flawlessly, except the sound. I hear the boot and shutdown sounds, but besides that, a nice big empty silence. The sound card is a new Azalia complient Intel chip. (I have no idea what specific type)
(While it is not entirely true, please assume that I am a complete newcomer to linux terminal commands, etc.)

It looks unlikely to work. The boot noises don’t come from the sound card/chip. I checked asus web site too and to me it looks like that laptop is very much Vista.

SDB:AudioTroubleshooting - openSUSE

work thru carefully

If you can hear the boot and shutdown sounds, then it is likely your sound works.

To confirm sound functionality, copy and paste the following speaker-test into a gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavand you should hear a lady’s voice saying ‘FRONT LEFT’,‘FRONT RIGHT’ five times. Also try that with root permissions if it fails to work with regular user permissions.

If you do have this basic sound, then its likely you have a codec problem or a media player problem. Novell/SuSE-GmbH packaged media players and codecs are very restricted in that they follow the free software movement and they do NOT support proprietary codecs. In order to play sound from proprietary codecs (which are the vast majority of available codecs) you will need to both update your openSUSE Linux software and add support for proprietary codecs from 3rd party sources.

Possibly the best way to update your software is to do so over the Internet by adding repositories to your Software Package Manager, where “repositories” (repos) are in essence file servers on the internet with software applications, in this case for openSUSE Linux. I recommend you add ONLY oss, non-oss, update and packman repositories. NOT videolan. Just those four (oss, non-oss, update and packman). No others. None. Only after you learn of the risks and problems that can happen when you add other repos, and learn how to fix the problems that can happen, should you add other than those 4.

To add those 4 repositories,follow the guidance here: Repositories/11.1 - openSUSE-Community Again, add only OSS, Non-OSS, Update and Packman.

Once those 4 are added, with your PC connected to the Internet, go to YaST > Software > Software Management and change the ‘Filter’ to “search” and then search and install the following: … replace Novell/SuSE-GmbH packaged libxine1, amarok with the Packman packaged libxine1 and amarok. Also add the packman packaged xine-ui, amarok-xine, amarok-packman, smplayer, mplayerplug-in, kaffeine, vlc, w32codec-all, libffmpeg0. The last two are to pickup any missing codecs. You can tell packman versions because they have the “pm” in the version number. Those are just example applications - but they should provide the capability to play most multimedia that you will encounter.

Pay close attention to your mixer settings. Sometimes when you start an application the PCM volume control will jump to a low level and you will need to move it back up to get your volume/sound back.

At first, the sound test failed. But then I cranked up the sound from about 70 percent to the highest possible level, and then I heard (faintly) the test. I will attempt adding the repositories you directed me to and let you know what happens.

Also, this laptop is shipped stock with a splashtop based OS where the sound works perfectly. Is there any way to import codecs/drivers from that distribution?

Thank you very much for your help!

Those repositories won’t help your volume levels. They will help provide a capability to play the most common video and audio files.

Go to YAST > Hardware > Sound > Other > Volume and move both PCM and Master volume levels up high. Then close YaST. Then go to your mixer (kmix or alsamixer) and move up your Master and PCM volume levels. Then try your volume.

If that does not work, advise, and we can check to see if there are more complex fixes that can be attempted.

I have no idea as to what a “splashtop based OS” might be.

Splashtop Instant-On Desktop from DeviceVM

Big news in many places, you are up and online in seconds.

ok ,… then based on that …

reference the question:

My guess is NO. As far as I can see, there is no way to get past the GUI front end to splashtop.

But having stated that, if splashtop is using a form of Linux, then they are required to release their source code to be compliant with the GPL. Hence there is a reasonable likelihood their drivers for sound are known, and probably already upstream and part of alsa.

The fact you can hear the startup and shutdown sound in openSUSE indicates openSUSE supports your sound.

Did you have any luck following my suggestion re:
a. your applications/codecs, and
b. improving your PC (Asus F8Va-B1) volume?

kamon8124, further to this thread, if you have had no success in improving your volume, its possible either an update to your alsa sound driver, or a fine tuning of your sound configuration, will help your audio/sound.

In order to know if that is the case, I need more information on your Asus F8Va-B1 laptop. Please, with your laptop connected to the internet, can you open a gnome terminal or a kde konsole, and run the following with root permissions (you may need to run this twice, the first time to update and the second time to get the result): /usr/sbin/ and provide here the URL that is given to you. Just post the URL.

Also, in addition to running the script above to get the URL, please copy and paste the following into a gnome terminal or kde konsole and paste here the output:rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
based on that I may be able to provide some commands to update alsa and maybe to fine tune your /etc/modprobe.d/sound file.

OldCPU, that cocktail of software did it! After installing the packages, I rebooted and checked my sound systems. First, I put the sound level to max. Then, I changed the audio output device(s) to auto-detect. And voila! Perfect sound in all media players etc! Thank you so much for your help!
Opensuse rocks!

I have a GA-MA790GP-DS4H (rev. 1.0) which has a Realtek ALC889A codec. Unfortunately sound doesn’t work for me with this board under 11.1 out of the box. What do I need to do to fix it??

GIGABYTE - Product - Motherboard - Specification - GA-MA790GP-DS4H (rev. 1.0)

johnstern, it would be better if you started a new thread. As far as I can see, your GA-MA790GP-DS4H (with an ALC889A) is not the same as the codec in an Asus F8Va-B1.

So please start a new thread, and in the thread, provide the output URL given by running with root permissions in a gnome terminal or a konsole (with PC connected to the internet): /usr/sbin/
you may need to run it twice (1st time to update and second time to get URL) as user root.

Also provide in the new thread the output of running: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

After starting a new thread, and while waiting for a reply, you could also try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE


I would assume, according to the openSuSE hardware compatibility list that support for the Realtek ALC889A has been dropped as of 11.0. If so then you are probably looking at an addon board for sound.

My understanding is that is not the case. I note this from an ALC889A search where ALC889A is mentioned in 1.0.18 of alsa, which is the alsa version that comes with openSUSE-11.1:
Search results for ALC889A - AlsaProject

I have been successful in helping users who have the ALC889A on their PC, albeit it has typically been difficult. An example (of a difficult case):
No sound with Realtek ALC889A under 11.1 - openSUSE Forums

Sometimes, one needs to apply model options to the /etc/modprobe.d/sound file from the ALC882/885 or the ALC883/888 (as there is no specific table for the ALC889A). The ALC889A is relatively new, and if one does have difficult after trying various fixes, then a bug report on openSUSE is also a viable approach. I have found the openSUSE sound developer (dev) is also an alsa sound dev, and one gets an excellent response from such bug reports, albeit often one is asked by the dev to try various fixes, run scripts, etc … to get to the root of the problem.

That should read openSUSE-11.1.

Well you sort of make my point for me though. If the ALC889A were fully supported it should be auto-detected and thus set up automatically.

You are definitely right on the point of the “audio” group membership, it’s one little point that can turn silence into a wonder.

I have noticed after looking that Realtek has linux drivers on their download page. Perhaps these might help solve the ALC889A problems.


One caution to those using Realtek drivers, … and that is there is little to no support for them on a forum such as ours. Typically the users who are successful with the Realtek drivers gleefully post they succeeded (which is understandable), and then disappear and never help others with the driver (which is disappointing). Those who fail with the Realtek drivers have a difficult time recovering from the mess the Realtek drivers leave.