no sound in opensuse 11.1 - ecs G31T-M7 motherboard


I am quite new in all this, and maybe my problem is simple, but not to me.
I simply cannot get the sound to work, which would be good if i could, because then i would just want to use opensuse, because i like the idea.

Now my soundcard according to windows hardwareprofile is VIA VT1708B 6-channel High Definition audio. The motherboard as i wrote in the top is a ecs G31T-M7 motherboard, and the sound card the one thats custom in that motherboard.

I tried shuffling around in Yast to see, but i cannot find any exact match, and the one Yast chose when installing is quite different, - 8280 16 (ICH7 family) High Definition Audio Controller.

Maybe thats the problem, maybe thats ok.

I have of course read here and there, etc, and read again, but i am not sure i can solve this alone.

But if anyone has any ideas to i would be very happy…

I would like to try and help.

Typically, I need more information in order to make a recommendation, as the hardware on everyone’s PC is different …

Are you using Gnome? KDE3 ? KDE4 ?

You could start by working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE Pay attention to your mixer settings. Both PCM and Master Volume should be moved up.

Please use the recommended sound test (copy and paste the following into a gnome-terminal or kde konsole): speaker-test -c2 -l5 -twavand you should hear a ladies voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ 5 times.

If after working your way through the audio troubleshooting guide, you still are not able to get any sound from the “sound-test”, then we will need more information to help you. In that case, to provide more information, with your PC connected to the internet, please copy and paste the following into a gnome-terminal or a kde konsole: /usr/sbin/alsa-info.shThat will provide you a URL. Please post here ONLY the output URL. Do NOT post all the info , here. Just the URL.

In addition to the above (if seeking more help), please run the following, and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q padevchooser pavucontrol pavumeter paman paprefs
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
If you do get sound from the “speaker-test” then your problem is likely an application config/codec problem.

Thank you very much for your quick respond.

I have written a lot back; it comes in two categories, 1) what i did following the guide
2)the things you asked me to.

  1. what i did following the guide

i did try the audio troubleshooting guide.
thats how i came upon checking which sounddriver Yast installed. And i also tested my sound following that.
However some of it I am not quite sure what to make of.

If i paste cat /proc/asound/cards into the console i get this answer

peter@1503022908:~> cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf9ffc000 irq 16

But it does not leave me that much wiser, because what is 0xf9ffc000? It doesn’t look like a codec or driver. But as i wrote I am not that wise in this.

I tried this text ”wget”

and got this…

peter@1503022908:~> wget
–2009-01-04 17:29:07--
Løser Main Page - AlsaProject
Connecting to||:80… forbundet.
HTTP forespørgsel sendt, afventer svar… 302 Found
Sted:;a=blob_plain;f=utils/ [omdirigeret]
–2009-01-04 17:29:12--;a=blob_plain;f=utils/
Reusing existing connection to Main Page - AlsaProject.
HTTP forespørgsel sendt, afventer svar… 200 OK
Længde: 23283 (23K) [text/plain]
Saving to: `index.html?p=alsa-driver.git;a=blob_plain;’

100%==========================================================================================================>] 23.283 --.-K/s in 0,1s

2009-01-04 17:29:13 (177 KB/s) - `index.html?p=alsa-driver.git;a=blob_plain;’ saved [23283/23283]


I tried this, bash
and got this:

peter@1503022908:~> bash
bash: Ingen sådan fil eller filkatalog

-Which puzzles me because according to yast installation i do have ALSA…?

then i tried ”wget"

and then bash tsalsa

and got quite a lot which i do not know if i should post…

I tried updating my ALSA using link: Index of /repositories/multimedia:/audio
and i think i suceeded in that.

That is how far i got, because in the rest of the guide i would need to know what to write and where. And i did not.

  1. the things you asked me to.

So here is the data you requested.

I am using the newest KDE, KDE 4.1.3 .

And I have not heard the ladies in the left or right speaker

i wrote /usr/sbin/
and got this:

but it asked if i wanted to install a new version of alsa info? I tried but didn’t succeed, so i did it again and chose not to install new version.

Then I ran the other lines you asked me to

peter@1503022908:~> rpm -qa | grep alsa

peter@1503022908:~> rpm -qa | grep pulse

eter@1503022908:~> rpm -q padevchooser pavucontrol pavumeter paman paprefs
pakken padevchooser er ikke installeret
pakken pavucontrol er ikke installeret
pakken pavumeter er ikke installeret
pakken paman er ikke installeret
pakken paprefs er ikke installeret

(er ikke installeret means: is not installed, i am danish and wanted a danish keyboard, however everything came out danish which i am kind of regretting, since it gives a language problem.)

peter@1503022908:~> rpm -q libasound2

peter@1503022908:~> uname -a
Linux 1503022908 #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

peter@1503022908:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.BXcO1cwz+ZE:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

I am quite sure that both PCM and Master Volume is be moved up, i did check that earlier.


Actually, I do not think you did succeed.

That is because is stored under /usr/sbin and one needs root permissions to write to that directory. Hence to update, one need to run it with root permissions.

Your alsa firmware version is not consistent with the rest of your alsa versions, and if alsa firmware is necessary, then it is possible that configuration inconsistency is enough to break your sound,

I think you should roll back alsa-firmware to the version of alsa-firmware that is on the nominal opensuse OSS site (for no architecture specificity). Index of /distribution/11.1/repo/oss/suse/noarch

Actually, according to the script you have this set wrong.

!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xf9ffc000 irq 16’
Mixer name : ‘VIA VIA VT1708B 8-Ch’
Simple mixer control ‘Master Front’,0
Capabilities: pvolume pswitch
Front Left: Playback 0 0%] -40.25dB] [on]
Front Right: Playback 0 0%] -40.25dB] [on]
Simple mixer control ‘Headphone’,0
Capabilities: pvolume pswitch
Front Left: Playback 18 [67%] -15.75dB] [on]
Front Right: Playback 18 [67%] -15.75dB] [on]
Simple mixer control ‘PCM’,0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Front Left: Playback 255 [100%] [0.00dB]
Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control ‘Front’,0
Capabilities: pvolume pswitch
Front Left: Playback 18 [67%] -15.75dB] [on]
Front Right: Playback 18 [67%] -15.75dB] [on]
Simple mixer control ‘Line’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Front Left: Playback 0 [0%] -40.25dB] [on]
Front Right: Playback 0 [0%] -40.25dB] [on]
Simple mixer control ‘IEC958’,0
Capabilities: pswitch pswitch-joined
Mono: Playback [off]
Simple mixer control ‘IEC958 Default PCM’,0
Capabilities: pswitch pswitch-joined
Mono: Playback [on]
Simple mixer control ‘Independent HP’,0
Capabilities: enum
Items: ‘OFF’ ‘ON’
Item0: 'ON’Your master volume is a 0%. That guarantees NO sound. You also have some other volume settings at 67%. When your sound is proven functional, then that may be the best setting, but while investigating basic sound functionality it is useful to move that up to 95%. Once you get sound, you can back off to a lower level of volume to avoid distortion.

Your IEC958 (digital audio) settings are inconsistent. In one case you have it switched OFF, and in another case you have PCM for digital audio ON, which can not work since digital audio is OFF. What is it to be? Are you trying to use digital audio?

Well… ehm, as i said i am not very wise in this…

so now i tried to install alsa-firmware-1.0.17-1.42.noarch.rpm

Some how i cannot install it - it say i already have a newer package… so how do i best roll it back?

So i got that master sound etc wrong, - and where can i possibly correct all these settings?

In the case of alsa-firmware, I do not believe it has any dependencies, nor is it a dependency of any other package. So just remove the git version and install the OSS version.

There should be an application called “kmix” which is a mixer that you use to control those settings in kde. In the case of kde4, there is a menu item in kmix that you can use to select/provide more visible controls.


Actually when I thought i had checked out the pcm and mastersound, it was because i went into Yast/hardware/sound…

Now i tried to open Kmix, which I found under programs/multimedia/Kmix – however when i open it, it does not load – i mean it appears in the bar at the bottom, and there is a ”thing” near the mouse, but then it all goes away… did i miss something or does it have a problem…? (related?)

About alsa-firmware
Remove, exactly my point, but how does one remove installed items in opensuse… i have looked for it since i started with this and so far has not found…
do i use the console or…?

With the OSS i take it that you mean the alsa firm ware provided at the page you directed me to…?

Again i thank you for your time and patience in this, Opensuse is a new OS to me… i used windows in years and years…

Hang on a moment…

Something has happened now, i went to recheck and went into yast again Yast/hardware/sound/other/

and found the place with pcm etc. Actually it was as you said, so i corrected it… and got sound!!

So what about this alsa business, is that still good to do?
And dont forget my question about how i could have removed/uninstalled the alsa stuff…
it is good for me to know when i try out things how i can undo stuff.

But thanks so far… as far as i am now was realy my planned starting point for using it full time… because thats the way i think i will learn it best. So silly as my problem probably was, it was important to me.

Then i have some questions if you have time to answer… and i know it is on its way out of the topic of hardware…

First of all, Kmix, it still wont load. I tried to install it, but its already there… Should i reinstall it, and how would i first unsinstall it…?

Now is that the sound i have now the correct sound or just a sound. (could i make it better?)

What would I gain by installing these codecs? (it is something about w32codec-all etc)

But old Cpu, you did a lot of good here…

If you look at my post#2, you will see that one of the 1st things I recommended was for you to work your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

One of the early things that that guide recommends, is for you to go to YaST > Hardware > Sound . …

I deliberately structure my recommendations sequentially, and build up on the logic that earlier attempts were properly made and constructed. If someone does an earlier attempt incorrectly, it can easily lead to an inappropriate recommendation on my part. Other than my asking continually "are you sure? " , and “are you sure” … (which typically irritates the heck out of a frustrated user) there is little that I can do. I can only work on the assumptions that my recommendations are followed.

You may know what you mean by the term “alsa business”, but I do not .

I’m thinking now it might be useful for you to brush up on some openSUSE Linux concepts: Concepts - openSUSE
and some openSUSE sound concepts: Sound-concepts - openSUSE

Again, keep in mind my recommendations are based on the assumption that early recommendations are followed properly. Which means I assume you went to YaST > Hardware > sound and tried to tune your setup, and it failed. Clearly thats not the case. Going to YaST > Hardware > Sound does work. Which means the rest of my recommendations, which are based on the assumption that you performed that, are not fully valid.

As for uninstalling, … its easy.

Just go to YaST > Software > Software Management and change the filter to “search” and search for the app you wish to uninstall. And then click next to it to uninstall.

No. Do not uninstall. Do fix alsa-firmware like I suggested.

How can I tell that? I can’t hear your sound.

That link does not work for me.

Instead, I recommend you go to our stickie for installation, and PLEASE READ IT ! In particular, look at the last post in that stickie thread: NEWBIES - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums

Anyway, glad to read you have your sound working now. Good luck in getting everything tuned.

And I thank you.

I understand your irritation, but to justify myself a bit i had been into YaST > Hardware > Sound and set all to 100%, - possibly 67%, since the guide mentioned that.
However I should have done that again today, because clearly they had changed, maybe as i installed a new alsa, or i overlooked something or did not save it in the right way.

So in the future i will adhere those who help me point by point. And express myself clearly. Points taken and lessons learned. :slight_smile:

However my sound is now working, and would not have been without this writing, your help. So i am grateful. And will run this OS as my daily pc. (i listen to a lot of music and use my pc for that.)

There are still things about the KMix and CD player but i will meddle with that and follow your last advices, following my luck and wits.

One last thing; - it took opensuse forum (you) eight hours to get my sound working on what seems to be a recalcitrant motherboard. When i installed Windows it took four reinstalls plus several returns to the hardware retailer to get sound and everything running…

Lots of points to opensuse…

Thought you might like to hear about that!! ( I like it…)

Congratulations on the determination to see this through and get it working. Typically this just gets easier the more Linux experience one has, although on occasion we all take a few steps back.