No sound in my laptop with 11.1 KDE4.2.1.

Hi I 'm using 11.1 KDE4.2.1 x86-64 in my Compaq Presario CQ40-115AU notebook. It has this problem at Dec 2008,while in 11.1 KDE4.1.3,but I solved it with the great guide from Mr oldcpu ( Thanks bro ),sound is crispy & loud.
But after I installed 11.1 KDE4.2.1 x86-64 few days ago,
sound mute again,I tried solve it with oldcpu guide on Dec 2008,it doesn’t work this time…
Anyone could help me?

The alsa info URL :

Outcome of rpm -qa | grep alsa :

Outcome of rpm -qa | grep pulse :
marcoslai@linux-sqx1:~> rpm -qa | grep pulse

Outcome of rpm -q libasound2 :
marcoslai@linux-sqx1:~> rpm -q libasound2

Outcome of uname -a :
Linux linux-sqx1 #1 SMP 2009-02-25 15:40:44 +0100 x86_64 x86_64 x86_64 GNU/Linux

Outcome of cat /etc/modprobe.d/sound :
marcoslai@linux-sqx1:~> cat /etc/modprobe.d/sound
options snd-hda-intel model=hp-m4
options snd slots=snd-hda-intel,snd-hda-intel

5Dex.L2mrBVOSK42:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

l4dC.vfAxXUx5zd4:RS780 Azalia controller

alias snd-card-1 snd-hda-intel

OK, start by taking a close look at your configuration …

If you look there you will see this:

!!ALSA Version

Driver version:     1.0.17
Library version:    
Utilities version:  1.0.19

Since 11.1 comes with an alsa 1.0.17 and 1.0.18 mix, it looks like you attempted, unsuccessfully, to update your driver to 1.0.19 (or were you only trying to update your utilities) ??

Then looking at this:

Its quite clear that you are missing alsa-driver-kmp-something …

I say something, because you have the wrong kernel installed. I note this:

That is a debug kernel. Unless you are working very closely with an openSUSE kernel developer, then IMHO you should NOT have a debug kernel. Perhaps you can explain what you are trying do do here??

I recommend you install the kernel-default (64-bit version). Be careful when you install the kernel-default that you do not break your wireless, webcam, graphic card driver (ie ability to boot to X window), your grub boot manager configuration, … etc …

Then after you have that installed, install the alsa-driver-kmp-default to the 1.0.19 version. Dependant on the date in which you do this, you may or may not have to update all of your other alsa apps and libasound2 to the latest 1.0.19 version.

There is guidance for that here: Alsa-update - openSUSE

Note those instructions are openSUSE version specific, and also kernel version specific. When one updates alsa, one should send 6 zypper commands (and not just 3).

I can only get my wifi work with that Debug kernel,as it won’t work in Default kernel.
Last night there was an update for Default kernel,I updated it & there’s some conflict,I remember I chose to uninstall something related to alsa…
One thing,since I’ve made that Debug kernel to boot default,my ATI driver also installed in Debug kernel,boot into other kernel would result in weirld crash screen,and I don’t know whether the new updated kernel would work with my wifi,if I wanna try to boot with new kernel,HOW DO I RESOLVE THE GRAPHIC CARD DRIVER ISSUE? HOW TO UNINSTALL IT?
Thanks bro :slight_smile:

I use openGL drivers. I picked hardware that works well with openGL drivers.

You need another thread, with help from users who mess with hardware that is more difficult to sort (than the hardware I choose) in order to address your graphics and wireless issues.

You can still follow my advice, and use the debug kernel.

But instead of installing alsa-driver-kmp-default, you need to install alsa-driver-kmp-debug.

Thanks for yr patient,well I’ve reinstalled 11.1 KDE4.2.1 x86-64,now everything is fresh.
My current kernel version is,is it the latest stable version? I’m planning to get my sound work on this kernel,with yr guide,and install ATI driver for my Radeon HD3200 graphic card. As for wifi,I’ll search for other solution instead of mess with Debug kernel. Once I get these 2 thing settle,is it ok to lock the current kernel from newer kernel update? Coz I don’t wanna mess with it again. :slight_smile: