no sound in msi laptop

lspci

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
05:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
06:00.0 VGA compatible controller: nVidia Corporation GeForce 9500M GS (rev a1)

i tried everything, i uninstall the pulseaudio, i reinstalled the alsa, i change the audio settings, i compile the alsa

and there is no result

please help me

post su terminal result of

lspci -k

SDB:AudioTroubleshooting - openSUSE

idan22, per caf4926’s post, typically the first thing I recommend is that users (who have basic sound problems) try working their way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF either of those tests gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Try those speaker-tests as both a regular user, and with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? If using openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and typing “su” (no quotes - enter root password) and then and typing and executing twice :
/usr/sbin/alsa-info.shthe first time it will ask to update. Select YES for the update. The second time that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. JUST the URL.

If not using openSUSE-11.1, please advise, and we can tell you of another way to run the diagnostic script.

Also, for either openSUSE version, in addition to the diagnostic script, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation (as opposed to a guess).

speaker-test 1.0.19

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
0 - Front Left
1 - Front Right
Time per period = 2.899544
0 - Front Left
1 - Front Right
Time per period = 3.008111
0 - Front Left
1 - Front Right

http://www.alsa-project.org/db/?f=04d9dd0ec4ebea11f40d87495333dea87f5dee97

rpm -qa | grep alsa
alsa-utils-1.0.19.git20090416-1.2
alsa-firmware-1.0.19.git20090317-1.1
alsa-plugins-1.0.19.git20090303-1.14
alsa-tools-1.0.19.git20090320-1.4
alsamixergui-0.9.0rc1-584.132
alsa-oss-1.0.17.git20080715-2.26
alsa-1.0.19.git20090410-1.1
alsa-plugins-samplerate-1.0.19.git20090303-1.14
alsa-plugins-pulse-1.0.19.git20090303-1.14
rpm -qa | grep pulse
libpulse0-0.9.12-9.6
alsa-plugins-pulse-1.0.19.git20090303-1.14
rpm -q libasound2
libasound2-1.0.18-8.7
uname -a
Linux linux-m7vj 2.6.27.21-0.1-default #1 SMP 2009-03-31 14:50:44 +0200 i686 i686 i386 GNU/Linux

I’m afraid you have confused me by that.

The script indicates

Kernel release:    2.6.27.7-9-default

yet uname -a gives this:

They are inconsistent. So what is your kernel? 2.6.27.7-9 or 2.6.27.21 ??

Did you update your kernel and forget to reboot? Or did you simply run the script on one day, change your configuration, and then run the rpms at a different time? … In truth, its VERY DIFFICULT to give you a good recommendation in such a case. …

VERY difficult. Please, try to be consistent.

Now, if I am to take the script at face value … and I suspect its wrong because the kernel version does not match, then the rpm output, gives a hint as to at least one of the problems with your PC setup. The script indicates this:

!!ALSA Version
!!------------

Driver version:     1.0.17
Library version:    
Utilities version:  1.0.18

and yet the rpms indicate 1.0.19 … That does not make sense, …

Then, looking at the rpms you have installed:

Where is alsa-driver-kmp-default ? Without that, the git versions of alsa you installed are not likely to work.

You should install alsa-driver-kmp-default and reboot.

But you also need to give consistent outputs. Providing some output, then changing your configuration, and then providing more output, simply confuses the situation. >:(

ops… sorry, it’s older alsa-info

this is the new one

http://www.alsa-project.org/db/?f=9da8fff3a57d1d34c505c641385516208d2a37f1

i’ll try to install alsa-kmp-default

That makes more sense with:

Kernel release:    2.6.27.21-0.1-default

and

!!ALSA Version
!!------------

Driver version:     1.0.17
Library version:    
Utilities version:  1.0.19

As you can see, without alsa-driver-kmp-default, you still have the older 1.0.17 alsa driver (which is actually a module inside the new 2.6.27.21 kernel). To update the driver, you need alsa-driver-kmp-default, PLUS the other 1.0.19 git alsa apps you installed.

i installed the package but noting happened

You need to reboot afterward. And you need to test your audio with the speaker-test. Don’t forget to go to YaST > Hardware > Sound to configure/tet your audio.

If that does not work, I need to see the script output (again) with the alsa-driver-kmp-default installed. ie output url from
/usr/sbin/alsa-info.sh

and also the output of
rpm -qa | grep alsa
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

http://www.alsa-project.org/db/?f=dac45ca1c482640673053607afa82b06994cb580

rpm -qa | grep alsa
alsa-utils-1.0.19.git20090416-1.2
alsa-firmware-1.0.19.git20090317-1.1
alsa-plugins-1.0.19.git20090303-1.14
alsa-tools-1.0.19.git20090320-1.4
alsamixergui-0.9.0rc1-584.132
alsa-oss-1.0.17.git20080715-2.26
alsa-driver-kmp-default-1.0.19.20090418_2.6.27.21_0.1-1.1
alsa-1.0.19.git20090410-1.1
alsa-plugins-samplerate-1.0.19.git20090303-1.14
alsa-plugins-pulse-1.0.19.git20090303-1.14
linux-m7vj:/home/idan # rpm -q libasound2
libasound2-1.0.18-8.7
linux-m7vj:/home/idan # uname -a
Linux linux-m7vj 2.6.27.21-0.1-default #1 SMP 2009-03-31 14:50:44 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.u_BNWJ+LvyF:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

I’m going to look at the script.

In the mean time, you should update libasound2 to a 1.0.19 git version, just like the other alsa apps. It is not logical to have a 1.0.18 library with 1.0.19 alsa versions.

after reconfing

ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

alsamixer: function snd_ctl_open failed for default: Connection refused

:frowning:

Something else you could do to provide more information, is immediately after rebooting, run the following (with your PC connected to the internet):

dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a

That will give you a URL - post the URL here. Just the URL.

Have you check to listen if your headphones are giving any sound?

yes, headphones works

OK, according to the script, your PC has an ‘Realtek ALC1200’

Thats a relatively new codec. Searching on the alsa web site gives this: Search results - AlsaProject
I note it states the ALC1200 is amost compatible with the ALC888.

There are no model options for the ALC1200. But there are for the ALC888. You could try some ALC888 model options in your /etc/modprobe.d/sound file, in the hope that they might work for the ALC1200.

The list from the ALSA-Audio-Models.txt file for 1.0.19 of alsa is as follows:

ALC883/888
==========
  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  medion	Medion Laptops
  medion-md2	Medion MD2
  targa-dig	Targa/MSI
  targa-2ch-dig	Targs/MSI with 2-channel
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  auto		auto-config reading BIOS (default)

So you could try EACH of those, ONE at a TIME, restart your alsa sound driver and restarting your mixer, and thoroughly testing your sound and checking your mixer (as regular user, as root, with and without headphones) after each edit attempt.

For example, lets say the next item in the list you plan to test is “targa-dig”. Then to test that, you would change the /etc/modprobe.d/sound file to:

options snd-hda-intel model=targa-dig
options snd slots=snd-hda-intel
# u1Nb.u_BNWJ+LvyF:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

and then restart alsa with su -c ‘rcalsasound restart’ enter root password when prompted for a password, and then restart your mixer and test your sound thoroughly. If that fails, chnage “targa-dig” with another model option, and restart your alsa sound driver, restart your mixer, and test your sound … etc … etc … for each item in the list .

That gives me confidence that one of the edits to the /etc/modprobe.d/sound file will work.

Good luck.

Don’t forget to double check your speaker cables. :slight_smile:

options snd-hda-intel model=targa-2ch-dig
options snd slots=snd-hda-intel

u1Nb.u_BNWJ+LvyF:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect: Connection refused

You need to keep trying each model option, one at a time, until hopefully you find one that works.

The error messages don’t (and won’t) mean anything to me (they might to an alsa developer).

Hopefully one of them will work.

What did the dmesg (with no model options) give?

options snd-hda-intel model=3stack-dig
options snd slots=snd-hda-intel

u1Nb.u_BNWJ+LvyF:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

seem it’s work now

thank you :wink:

Great ! Congratulations in finding the correct option for your PC. Thankyou for sharing your solution.

Please, to satisfy my own curiousity, what model MSI laptop are you using?