No sound in headphones

I was running on a 10.3 which i inherited and recently updated to 11.2. But since the update im unable to get any sound output to my headphones (connected by jack’s) which is connected to a pair of front plugs.

When i adjust the volumes it only seem to influence the front speaker

I read some other posts and did following :


rpm -qa ‘alsa

rpm -qa ‘pulse

rpm -qa ‘libasound2

uname -a
Linux jka #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/50-sound.conf
options snd slots=snd-hda-intel

u1Nb.VuErAdw+2mB:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

whats wrong/missing ?

Check in the mixer settings that headphones Channel is active and not muted.

The headphone channel is active and not muted.
The reason that it may seem muted or not active (which i cant see)
in the info i posted, is that it just happened to be muted when i last tried to play around with various settings in the mixer.

Take a look at this from the script:
Simple mixer control ‘Master’,0
Mono: Playback 19 [30%] -45.00dB] [on]
Simple mixer control ‘Headphone’,0
Mono: Playback 65 [100%] [30.00dB] [on]
Simple mixer control ‘PCM’,0
Front Left: Playback 109 [43%] -29.20dB]
Front Right: Playback 109 [43%] -29.20dB]
Simple mixer control ‘Front’,0
Capabilities: pvolume pswitch
Front Left: Playback 47 [73%] -17.00dB] [on]
Front Right: Playback 32 [50%] -32.00dB] [on]
Simple mixer control ‘Line’,0
Capabilities: pvolume pswitch
Front Left: Playback 45 [69%] [10.00dB] [off]
Front Right: Playback 45 [69%] [10.00dB] [off]

Now if that is not the setting you had applied, then rerun the script. Running the script in a non representative configuration is no help.

The alsa sound driver was not developed by one person. Rather it was developed by contributions by many different people, and hence there is NOT a uniform standard in terms of how audio controls are implemented, despite the best efforts made to have comonality.

I assume when you plug your headset in, that your speakers are muted. Is that correct?

If correct, then take a look at your Master Volume and PCM volume controls. Those are way too LOW IMHO. Also, look at your mixer control for line, … for some hardware audio codecs that needs to be ON (not for all hardware audio codecs, only for some).

I also did a search for the ALC260 hardware audio codec, that is in your PC, and I do not see any updates to alsa driver relevant to it: Search results for ALC260 - AlsaProject

I re-ran the script with no channels muted and volume settings way up. The result :

But still only (very loud) music in front speakers and no sound in headphones.

When i mute the ‘headphone’ channel in the mixer, its actually the sound in the front speaker that is muted.

Regarding the not about the ALC260 hardware audio codec, im not quite sure what to do about this info ?!?

I’m not sure if that is what I meant when asking if speakers are muted. I mean all speakers.

When you plug the headphone jack in, ALL of your speakers should immediately be muted, with no need to touch the mixer. Does that happen?

If that does not happen, it is a clear sign of an alsa sound driver misconfiguration, and knowing this fact will help narrow down what needs to be investigated.

This is in the alsa documentation.

Knowing that the hardware audio codec is an ALC260, one can then apply a custom model setting to force the alsa sound driver to a specific configuration upon boot (or upon restart of the sound driver). If I look at the alsa documentation (the HD-Audio-Models.txt file) for the ALC260 I note this list of model options that can be forced:

  hp		HP machines
  hp-3013	HP machines (3013-variant)
  hp-dc7600	HP DC7600
  fujitsu	Fujitsu S7020
  acer		Acer TravelMate
  will		Will laptops (PB V7900)
  replacer	Replacer 672V
  favorit100	Maxdata Favorit 100XS
  basic		fixed pin assignment (old default model)
  test		for testing/debugging purpose, almost all controls can
		adjusted.  Appearing only when compiled with
  auto		auto-config reading BIOS (default)

Note that an “hp” or “replacer” option may in fact apply to completely different hardware. Typically the option label only applies to the 1st machine that the alsa developer got this working on.

So lets say you wish to try the model option “hp” and force that upon boot/alsa-driver restart. You would do that by adding a line/changing the /etc/modprobe.d/50-sound.conf file to:

options snd-hda-intel model=hp
options snd slots=snd-hda-intel
# u1Nb.VuErAdw+2mB:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel

then restart alsa with su -c ‘rcalsasound restart’ and then restart your mixer and test your sound/headphone behaviour.

If ‘hp’ does not work, try the next item in the list, replacing ‘hp’ in the /etc/modprobe.d/50-sound.conf file with ‘hp-3013’ and restart alsa and restart the mixer and test.

In some cases sound will not work at all even in speakers. In other cases there will be no difference. Try each item in the list until you find one that works, or that you have gone through the entire list.

Even if this works, you are likely in bug reporting terroritory: (1) if it does not work only an alsa developer can help (and openSUSE has an alsa developer who can help) and (2) if it does work, it would help if you would advise the alsa-developer (via a bug report) as to what work, so that they can update alsa to automatically configure your PC for other users.

Before writing a bug report, please advise here, and I can give you guidance that will help you (and the alsa developer) get the most out of the bug report.

Thanks a million!!
It worked with the ‘hp’ setting added to the

The sound in the speaker does not mute when i plug in the
headphone/jack’s but that acceptable when im able to mute
the speakers through the mixer settings.

Thanks again

This REALLY should work properly. :slight_smile: … You could keep trying the other options other than “hp”.

And even if one of the other options work, or if none work, if you have time it would help the Linux community if you wrote a bug report on this problem, and then watched/supported the evolution of the bug report resolution.

We are lucky in openSUSE that the packager for sound for openSUSE is also an alsa developer. Hence if he fixes a problem that you have encountered, he will send the fix upstream and ALL Linux distribution users (and not just openSUSE) will benefit.

There is guidance on how to raise a bug report here: Submitting Bug Reports - openSUSE You can log on to bugzilla with your openSUSE forum user name and your openSUSE forum password. Please raise the bug report against component “sound” (no quotes). Please note that the openSUSE packager/alsa-developer will NOT read a forum thread. Hence it is important that your bug report include all salient/relevant information. Hence please attach a copy to the bug report of the output of running the diagnostic script. You can do this with the command:

/usr/sbin/ --no-upload

which will create the file /tmp/alsa-info.txt. Just attach the file alsa-info.txt to your bug report (in addition to a good description of the problem and the work around / solution you have applied).

Headset functionally should work automatically with your computer, and if it does not work automatically then it needs to be fixed.

Thankyou for any help you can provide.