No Sound in Fresh 11.4 Install

Just installed OpenSUSE 11.4, and so far I love everything about it, the only thing that’s not working is the sound. :frowning:

I have my sound card setup in YaST -> Sound like I always have, and it recognizes it as M-Audio Delta Audiophile 24/96. I also installed alsa-tools-gui to get Envy24Control for ICE1712 chipsets, and I unmuted all the outputs, and raised the DAC volume. My speakers are on, and all the cables check out. Here is all my multimedia information:

matt@linux-idfu:~> LC_ALL=C zypper ve
Loading repository data...
Reading installed packages...

Dependencies of all installed packages are satisfied.
matt@linux-idfu:~> rpm -qa --queryformat '%{NAME} -> %{VENDOR}
' | grep -i VideoLAN
matt@linux-idfu:~> rpm --verify --query --all 'libav*' 'libpostproc*' 'libswscale*'
matt@linux-idfu:~> rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' libxine1 libxine1-codecs
libxine1-1.1.19-2.pm.45.16-x86_64 -> http://packman.links2linux.de
libxine1-codecs-1.1.19-2.pm.45.16-x86_64 -> http://packman.links2linux.de
matt@linux-idfu:~> rpm --verify --query --all '*xine*'
matt@linux-idfu:~> rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' gstreamer-0_10-ffmpeg gstreamer-0_10-fluendo-mp3 gstreamer-0_10-fluendo-mpegdemux gstreamer-0_10-fluendo-mpegmux gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly
gstreamer-0_10-ffmpeg-0.10.11-999.pm.1000.2-x86_64 -> http://packman.links2linux.de
gstreamer-0_10-fluendo-mp3-0.10.14-42.pm.43.1-x86_64 -> http://packman.links2linux.de
gstreamer-0_10-fluendo-mpegdemux-0.10.57-42.pm.43.1-x86_64 -> http://packman.links2linux.de
gstreamer-0_10-fluendo-mpegmux-0.10.4-43.pm.44.1-x86_64 -> http://packman.links2linux.de
gstreamer-0_10-plugins-bad-0.10.21-999.pm.1011.21-x86_64 -> http://packman.links2linux.de
gstreamer-0_10-plugins-base-0.10.32-999.pm.1000.6-x86_64 -> http://packman.links2linux.de
gstreamer-0_10-plugins-good-0.10.27-999.pm.1002.15-x86_64 -> http://packman.links2linux.de
gstreamer-0_10-plugins-good-extra-0.10.27-999.pm.1002.15-x86_64 -> http://packman.links2linux.de
gstreamer-0_10-plugins-ugly-0.10.17-999.pm.1001.6-x86_64 -> http://packman.links2linux.de
matt@linux-idfu:~> rpm --verify --query --all '*gst*'
matt@linux-idfu:~> rpm --verify MPlayer
matt@linux-idfu:~> rpm --verify --query --all '*vlc*'
matt@linux-idfu:~> rpm --verify w32codec-all
matt@linux-idfu:~> rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' MPlayer '*vlc*' | grep -v avahi | sort        
gstreamer-0_10-0.10.32-1000.pm.1002.6.x86_64
gstreamer-0_10-ffmpeg-0.10.11-999.pm.1000.2.x86_64
gstreamer-0_10-fluendo-mp3-0.10.14-42.pm.43.1.x86_64
gstreamer-0_10-fluendo-mpegdemux-0.10.57-42.pm.43.1.x86_64
gstreamer-0_10-fluendo-mpegmux-0.10.4-43.pm.44.1.x86_64
gstreamer-0_10-plugin-gnomevfs-0.10.32-999.pm.1000.6.x86_64
gstreamer-0_10-plugins-bad-0.10.21-999.pm.1011.21.x86_64
gstreamer-0_10-plugins-base-0.10.32-999.pm.1000.6.x86_64
gstreamer-0_10-plugins-good-0.10.27-999.pm.1002.15.x86_64
gstreamer-0_10-plugins-good-extra-0.10.27-999.pm.1002.15.x86_64
gstreamer-0_10-plugins-ugly-0.10.17-999.pm.1001.6.x86_64
kdebase4-runtime-xine-4.6.0-4.9.1.x86_64
libavc1394-0-0.5.4-2.1.x86_64
libavcodec52-0.6.201102261447git-1.pm.2.2.x86_64
libavdevice52-0.6.201102261447git-1.pm.2.2.x86_64
libavfilter1-0.6.201102261447git-1.pm.2.2.x86_64
libavformat52-0.6.201102261447git-1.pm.2.2.x86_64
libavutil50-0.6.201102261447git-1.pm.2.2.x86_64
libgstapp-0_10-0-0.10.32-999.pm.1000.6.x86_64
libgstbasevideo-0_10-0-0.10.21-999.pm.1011.21.x86_64
libgstinterfaces-0_10-0-0.10.32-999.pm.1000.6.x86_64
libgstphotography-0_10-0-0.10.21-999.pm.1011.21.x86_64
libgstreamer-0_10-0-0.10.32-1000.pm.1002.6.x86_64
libgstsignalprocessor-0_10-0-0.10.21-999.pm.1011.21.x86_64
libgstvdp-0_10-0-0.10.21-999.pm.1011.21.x86_64
libpostproc51-0.6.201102261447git-1.pm.2.2.x86_64
libswscale0-0.6.201102261447git-1.pm.2.2.x86_64
libvlc5-1.1.7-1.pm.12.1.x86_64
libvlccore4-1.1.7-1.pm.12.1.x86_64
libxine1-1.1.19-2.pm.45.16.x86_64
libxine1-codecs-1.1.19-2.pm.45.16.x86_64
libxine1-gnome-vfs-1.1.19-2.pm.45.16.x86_64
libxine1-pulse-1.1.19-2.pm.45.16.x86_64
MPlayer-1.0rc4_r33030-1.pm.1.1.x86_64
PackageKit-gstreamer-plugin-0.6.12-1.4.1.x86_64
phonon-backend-gstreamer-0_10-4.4.4-3.1.x86_64
phonon-backend-xine-4.4.4-3.1.x86_64
vlc-1.1.7-1.pm.12.1.x86_64
vlc-noX-1.1.7-1.pm.12.1.x86_64
vlc-qt-1.1.7-1.pm.12.1.x86_64
xinetd-2.3.14-152.1.x86_64
matt@linux-idfu:~> 

Thanks for the help!

Make sure you have the sound card you want to use set as default card in Yast > sound
Make sure you have the mixer settings correct and volume sliders ON

I don’t mean to be rude, and I understand that today is a busy day for OpenSUSE and it’s team, but I mentioned in my post that I did both of those things already.

In Yast it’s the only configured sound card, and thus the default. And unmuting all the outputs was the first thing I did in both KMix and Envy24Control.

EDIT: I’ve gotten it so that the Test Sound plays in YaST -> Sound, but then Amarok (Which uses Phonon) and Firefox each don’t play sound. When I look at my device list in Phonon itself, my card doesn’t show up like it usually would.

Go to Yast–>system settings–>multimedia–>phonon
And check sound with gstreamer, vlc, xine

http://img695.imageshack.us/i/36908801.png/

I just tried that, and when I went in the first time the only option I had was “PulseAudio Sound Server” which I knew couldn’t be right, so I rebooted, and now I have the usual options:


However, when I try to play a test sound through it, I don’t hear anything. (Unlike when I play the test sound from YaST -> Sound, and I’m able to hear the test.)

The GF100 “soundcard” is my NVidia graphics card, and it hasn’t been setup under YaST -> Sound, so there is no way it could be confusing the two.

Open terminal and install alsamixer

su
# zypper install alsamixer

then in terminal write

alsamixer

and increase sound bars.

What backend are you using?
Try installing and using either the vlc or gstreamer phonon packages

and or try doing an alsa restart as su: rcalsasound restart

Restarting alsa didn’t help. And so far I’ve tried all three: GStreamer, Xine, and VLC backends with no luck or change.

My only hint I guess is that when I open AlsaMixer, it defaults to “Card: PulseAudio”. I can change the mixer to show my M-Audio card, but I don’t think it is playing through it.

In KDE I disable pulse audio in the Yast > Sound >Other

Hi,
As a test try disabling pulseaudio in yast. After disabling pulseaudio, go back to the kde sound settings and you will notice the sound device numbers will show up and test which one will work

Have you checked that?

Doesn’t P/A work then on your G550? What’s the problem.

That picture doesn’t look like “Yast>system settings”. It looks like KDE system settings. :slight_smile:

Yes you are right
Start menu–>system settings–>multimedia–>phonon
Sorry for my rush.:slight_smile:

In Gnome Yes
KDE doesn’t seem to like it.

openSUSE-11.4 has pulse audio enabled for the first time by default in KDE.

My experience with 11.4 (testing it on 6 different PCs during the milestone and release candidate phase) is this has different impact on different hardware. In some cases pulse audio JUST works. In other cases it did NOT work, and it was difficult for me to find a quick solution to get sound working.

I did find that installing the application “pavucontrol”, and then running “pavucontrol” helped sometimes when pulse audio was not cooperating with my hardware to get basic sound functioning. I also found in another case that I need to run:

su -c 'rcalsasound restart' 

in order to break the hold that some application had on the sound device, after which sound in pulse worked.

My experience is on all 6 PCs, the YaST > Hardware > Sound > other > test (or volume) did not always provide a solid reliable indication of sound functionality. Pulse Audio has introduced another layer into the sound equation, and YaST by itself is no longer IMHO adequate for testing the functionality of one’s sound.

It would be nice if all PCs acted the same here, so we could provide one nice set of advice, but with 6 different PCs, I encountered 6 different types of behaviour.

The PC that gave me the hardest time was my PC with a USB webcam. If I installed openSUSE-11.4 milestone/RC (or booted the openSUSE-11.4 milestone/RC liveCD) with my webcam plugged it, then the webcam would invariably be configured as the first sound device (due to it having a mic). Unfortunately that meant the desktop tried to play sound through the USB webcam device which only has a mic. … That was not so easy to recover from, as just reversing the sound device order in YaST no longer did the trick (like it did in previous versions).

There are glitches here unfortunately, and all I can say is keep the faith and keep trying. Eventually you will stumble on a solution specific to your hardware.

So try pavucontrol and maybe that will help.

Best of luck and stay well.

It’s ok here (82801I (ICH9 Family) HD Audio Controller and Driver snd-hda-intel) on standard KDE. Maybe you have a different audio device/driver on your Lenovo?

hi,

i think i screwed my sound up.
Upon installation i disabled pulseaudio, but after installation is was there.
No sound.

So now, i am thinking, may be it is the best just to reinstall the sound drivers. Can someone tell me how i can do it via zypper to install the drivers freshly?

Thanks…

edit > nevermind. i didn’t realize that it was muted… oh man…

Here’s a picture of everything I could think to take a picture of :stuck_out_tongue:
http://i.imgur.com/ekz29.jpg](http://i.imgur.com/ekz29.jpg)

So, when I click the test sound in the KDE Settings, or listen to music via amarok, I don’t hear anything, but the sound meter in pavucontrol goes up and down as though it’s getting sound.

The test sound in YaST -> Sound works fine, whether or not I’ve enabled Pulse Audio Support in Other.

I’ve tried reinstalling everything related to phonon, pulseaudio, and alsa, but to no avail.

I’ve seen that happen when one has 2 sound devices. …ie mother board and a PCI card. If that is the case, plug in speakers to the unused sound device. Maybe sound is coming out thru that.