No sound in Flash videos

Hi all,

After a fresh installation of 11.3 KDE, I followed the Multi-media and Restricted Format Installation Guide and I also used the mmcheck to follow every advice and install packages that were recommended.

I also spent a few evening this week digging everywhere I could to get sound when playing videos in Firefox without any success. I have the Shockwave Flash 10.1 r102 extension installed in Firefox. I also tested in Chrome that also had the flash plugin and I still had no sound.

I would be very glad if anyone can help. I don’t know where to look at anymore…

I forgot to mention I also made sure nothing is on mute on each channel in Kmix.

Which desktop environmet in which version do you use?

Hello Gropiuskalle,

I just installed 11.3 with KDE4.

Do you have sound outside of your browser functioning?

Assuming you do so, typically, for KDE users, when flash does not work it is because:

  • user ignored the PCM volume control thinking it does not change or thinking it does not matter. It does matter.
  • user is trying to play sound with a browser, while another application has seized the sound device and is not sharing the device.
  • user has multiple sound devices, and the top priority device in the KMenu > Configure desktop > multimedia does not match the top priority device (sound card 0) in YaST > Hardware > Sound
  • user has a sound engine selected in KMenu > Clonfigure Desktop > multimedia that is NOT properly configured to play flash audio

Often KDE users will have the xine sound engine selected, but have not tuned it.

Also, what web sites have you tried?

Yes I have sound in other apps, I can even play mp3 files in Firefox. The only problems seems to be with Flash. I can also watch .mov videos in my browser.

My PCM volume is set at maximum. I don’t have any other apps playing audio. I already changed my sound card priority since my NVIDIA card first had the priority.

I looked at Configure Desktop > Multimedia but I am not sure how to know if it is configured correctly to play Flash audio. When I looked at the Xine configuration it only had the DVD option checked in Deinterlacing. The Deinterlacing method is set to use_vo_driver. I tried selecting the DVC and File options as well but it didn’t help, even after restarting my browser.

I tested on YouTube and Vimeo.

You might want to run test 13 in the latest mmcheck like this:

13. Show if Flash Packages are Installed from openSUSE ...                  

Command: rpm --query --all --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' '*flash*'

pullin-flash-player-11.3.1-2.1.1-x86_64 -> openSUSE
flash-player-10.1.102.64-0.2.1-i586 -> openSUSE

You should expect to have only two Flash Packages Installed which will be:
----------------> pullin-flash-player <----- from the openSUSE Repository.
----------------> flash-player <------------ from the openSUSE Repository.

Do this to determine what Flash Files you have loaded. Here is the link to mmcheck:

MMCHECK - Check Your Multimedia in 10 Steps - Script File, as proposed by RedDwarf

Message #40 has the most recent version of mmcheck to download.

Thank You,

Hi James,

As I mentioned I already used the mmcheck script. Here is my output of option 13:
pullin-flash-player-11.3.1-2.1.1-i586 -> openSUSE
flash-player-10.1.102.64-0.2.1-i586 -> openSUSE

Thank you for your precious help.

In order to check the xine configuration, assuming you have the program xine installed, you need to launch ‘xine’ and go to ‘settings’ > ‘setup’ and change its permissions to ‘master-of-the-known-universe’ and then restart ‘xine’ and go to ‘settings’ > ‘setup’ > ‘audio’ and try a different setting under the ‘audio driver to use’ . I recommend you try “oss” setting, but if that fails try some others. Note you may need to restart in order for these settings to be fully applied (I do not know).

Can you also provide the output URL/website address given by running the script:

/usr/sbin/alsa-info.sh 

and select the share/upload option and then pass here the URL/website address it gives.

and also pass here the output of the command:

cat /etc/modprobe.d/50-sound.conf 

That will hopefully allow us to check the veracity of your assessment wrt the order of your sound devices. A screen print of what you see in YaST > Hardware > Sound and also a screen print of what you see in MENU > Configure Desktop > Multimedia > Music may also help us understand your problem. Don’t go changing the backend settings there unless you really know what you are doing.

To share/post images to illustrate a configuration, a site to use is ImageBam - Fast, Free Image Hosting and Photo Sharing. Post the image there and post here the URL/website address provided. You can even embed the BB code into your post to have a thumbnail of an image, if you so wish.

Under Xine 0.99.6, I don’t have any options to set permissions under Settings>Setup nor any options to change the drivers to use under Settings>Setup>Audio. What version are you using?

I believed there was a conflict between both of my sound card so I disabled the NVIDIA. But this didn’t change much. Now I can play media in Kaffeine and VLC but Totem or Banshee are crashing. VLC output this warning: “VLC failed to initialize your sound output device (if any). Please update alsa-lib to version 1.0.23-2-g8d80d5f or higher to try to fix this issue.” But when I go to reinstall Alsa I get a warning I would break many packages so I didn’t try.

Here are the screenshots.

You will notice Xine doesn’t show up anymore on the backend tab but it was before. I am not sure of what I’ve messed up but I think it change since I switched vendor in the Software Management Repositories tab after I changed PackMan repository to have priority.

Here is the output of alsa-info.sh.

Content of cat /etc/modprobe.d/50-sound.conf:
options snd slots=snd-hda-intel

dtXw.nEyxvXOZ_i5:VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)

alias snd-card-0 snd-hda-intel

Oups, I just figured out how to change the Xine permissions. I will test with different drivers and let you know the output.

I tried the OSS and Alsa drivers with no more success.

I think I now need to take a step back and understand how these components are working together. I don’t understand how Xine is used by the Flash plugin through the Multimedia settings so it’s hard to try to figure out what could go wrong.

Thanks for your help. I won’t give up until I get it working…

It looks to me that you have gstreamer setup for your desktop (and hence browser) sound.

That could be the problem right there. Normally Gnome users will use gstreamer and KDE users will use xine.

I recommend you install “phonon-backend-xine” and then under KMENU > Configure Desktop > Multimedia > backend, change your backend to xine.

You may also need to restart KDE after doing this.

I installed phonon-backend-xine and I changed the Multimedia backend to Xine without more success.

I also tried to enable both sound cards in Yast and tested both as primary sound card and it didn’t help either.

Do you think everything looks OK in the alsa-info report?

No, the order of sound devices looked wrong in the alsa-info. … but that was a mute point as you did not have xine sound engine, and also a mute point if you have changed in YaST.

Can you confirm now you have selected xine as your backend to KDE, and you have restarted KDE after doing so. Confirm in xine oss is xine output audio mode.

Confirm order of sound devices in KDE configure desktop > multimedia matches that in yast?

And since you changed ? NEW settings in yast , provide gain screen prints of “configure destkop > multimedia” and of “yast > hardware > sound” and output URL/website address from running again :

/user/sbin/alsa-info.sh 

Here are the screenshots of my current settings.

Here is the also-info output.

I’ve been trying what is recommended there but I couldn’t find the codec name in the documentation file they mention. I will now look at this thread where you helped someone with an Intel-HDA card.

There is something strange there …

I note KDE > Configure Desktop > Multimedia has "HDA VIA VT82xx (ALC 883 Analog) as the primary sound device. That makes sense to me as I do not think it should be digital. Should it ? (Digital makes no sense to me).

I note YaST as sound device “0” has VT 17081A (Azalia HDAC)(VIA High Definition Audio Controller). I assume that is the same device as seen in KDE’s configuration.

BUT what puzzles me is the script has:

!!Soundcards recognised by ALSA
!!-----------------------------

 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe87c000 irq 25
 1 [VT82xx         ]: HDA-Intel - HDA VIA VT82xx
                      HDA VIA VT82xx at 0xfe9fc000 irq 17

Thats a clear problem. It has your HDA VIA VT82xx as the SECOND device. … ie alsa can not (for the desktop and hence for the browser) find your audio device.

Thats a problem.

I don’t know why that is there, nor do I know how to fix it.

I wonder if there is anyway to blacklist the nVidia HDMI device ?

Yes, I was also trying to fix this earlier. I found the file where these settings are written but I could not save my changes on the order, the file was getting overwritten right away.

When I launch alsamixer, I also see the NVidia card as the default one. I have to hit F6 to see the settings for the HDA card. On the Nvidia card, there are no sliders at all, neither in alsa mixer or Kmix.

I just noticed something else that is strange when I run these test commands:

> speaker-test -Dplug:front -c2 -l5 -twav
speaker-test 1.0.23

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels

WAV file(s)
Playback open error: -2,No such file or directory

> speaker-test -c2 -l5 -twav
speaker-test 1.0.23

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave

Please note that with my current configuration I have no sound in avi video nor in .mov as well and only Kaffeine, VLC and MPlayer can play mp3 files. So this is more than a Flash issue as I first thought…

My recommendation is do not waste any more time on this here on the forum (unless someone comes up with a solution that specifically addresses this).

Instead write a bug report on openSUSE-11.3 component “sound” on the “incorrect order of sound devices when alsa boots” (or something like that), or “problem with desktop sound due to alsa sound device order” (or something like that). This will get the immediate attention of the SuSE-GmbH sound packager for openSUSE, who is also an alsa developer. Attach to the bug report the text file ‘/tmp/alsa-info.txt’ that is produced by running:

/sbin/alsa-info.sh --no-upload 

… the attachment control to the bugzilla bug report page is toward the bottom of the page. Use your openSUSE forum user name and password when logging on to bugzilla. There is guidance here: openSUSE:Submitting bug reports - openSUSE

Note the SuSE-GmbH packager will NOT read a forum thread, so your bug report MUST be complete.

Then track the response, and do any tests/answer any questions the SuSE-GmbH sound packager asks. When you answer a question, be CERTAIN to clear the ‘NEED INFO’ flag. If the two of you produce a solution, please post the same here!

Thanks!