No sound in flash player

Ok I am noob here and this is my first attempt installing opensuse.
I have just installed 11.2 (Kde x64), and everything seems to be working but I can get no sound in the flash player in firefox (or konqueror for that matter).

I have tried following the advice in and various pages linking to it:

No sound works from anything other than sound test - openSUSE Forums

I have sound working fine in amarok and vlc, but still no sound in flash.

It seems to be the done things to attach the out of the following commands:

rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' '*layer*' '*vlc*' | grep -v avahi | sort                             


zypper lr -d
# | Alias                               | Name                        | Enabled | Refresh | Priority | Type   | URI                                                             | Service
1 |                  | Packman Repository          | Yes     | Yes     |   90     | rpm-md |                     |
2 | | Updates for openSUSE 11.2-0 | Yes     | Yes     |   99     | rpm-md |                       |
3 | nVidia                              | nVidia                      | Yes     | Yes     |   99     | rpm-md |                        |
4 | openSUSE 11.2-0                     | openSUSE 11.2-0             | Yes     | No      |   99     | yast2  | cd:///                                                          |
5 | repo-debug                          | openSUSE-11.2-Debug         | No      | Yes     |   99     | NONE   |  |
6 | repo-non-oss                        | openSUSE-11.2-Non-Oss       | Yes     | Yes     |  120     | yast2  |    |
7 | repo-oss                            | openSUSE-11.2-Oss           | Yes     | Yes     |  120     | yast2  |        |
8 | repo-source                         | openSUSE-11.2-Source        | No      | Yes     |   99     | NONE   | |

I not quite sure how best to proceed, but would appreciate advice before I do the usual thing of trashing my system.



Thanks. I see:

I’m still curious though about some other apps you may have related to flash support.

Please, can you provide the output of:
rpm -qa ‘flash
rpm -qa ‘wrapper
so we can better assess what needs to be done to address your problem?

Here is the output:

rpm -qa '*flash*'


rpm -qa '*wrapper*'

I’ll sneakily slip in a comment; I had a person today in IRC who said they had complete sound in the system otherwise but none in Flash. It turned out to be because Flash was using the first detected soundcard in the system, listed in /proc/asound/cards rather than the real card they wanted.

I do not understand that, given you have BOTH flash-player and pullin-flash-player installed. Did you change something since your previous post, as this makes NO sense to me. Note before you advised you had installed:


Sorry incorrect cut and paste correct code reads:

rpm -qa '*flash*'

that files contains:

 1 [XFi            ]: SB-XFi - Creative X-Fi
                      Creative X-Fi 20K1 SB073x

I don’t really know what it is supposed to say, but I am certainly running an X-Fi soundcard.

That also does not make sence. Typically when one types **rpm -qa ‘flash’ **they will get:


without the architecture (i586 and x86_64). Yet you are getting that.

Hence I do not think you are giving me the output of **rpm -qa ‘flash’ ** but rather you are giving me what you think I want to see, as opposed to what I am asking. … Or is that a new 11.2 feature (to include the architecture with the command ) ? If not (a new 11.2 feature), this can lead to the very copy and paste error that just happened, and when struggling to understand someone’s difficulty, what you did is incredibly frustrating for someone like me.

… anyway, … I do not know what your problem is.

My recommend is to remove both flash rpms, remove the nspluginwrapper rpm and then restart, and BEFORE you run any browser, re-install all 3 at once.

… apologies … just checked with my sand box PC running 11.2.

Its a NEW 11.2 feature. wow!

Anyway, try the removal and re-install of those rpms.

Sorry about the pasting error oldpc.

I can assure you that I have copied and pasted, as I don’t know anywhere near enough to tell you what you want to see.

Just to be sure I repeated and I get:

tom@linux-0j6y:~> rpm -qa '*flash*'

I will try your suggestions.



Tried removing and re-installation but that does not fix it.

Unless you have any other suggestions thanks anyway for your help.


I’m no 64-bit expert, and this could be 64-bit specific. When you re-installed flash-player, did it also install libflashsupport?

Anyway, keep checking here, as someone who knows more than I may chime in with a suggestion.

What web sites did you check ? Youtube?

I’m a little curious as to why his asounds file reports the card as #1, as I recall Flash tries to desperately use #0 as the output card by default but I guess it’s intelligent enough to pick #1 if it exists.

Also, did you check your PCM mixer levels? :smiley:

I suppose we could check into this further, but I do not know if I know enough to debug this.

Please run this diagnostic script:
with your pc connected to the internet. Select to share/upload the information. Post here the output URL it provides after the script has completed. Just post the URL.

Also, when trying to play sound with flash, post here the output of:

 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

and when NOT trying to play sound (with firefox closed) post here the output of the same:

 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

So the script output is at:

Other output is:

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
knotify4 2989  tom   13u   CHR  116,9      0t0 5100 /dev/snd/controlC1
kmix     3762  tom   11u   CHR  116,9      0t0 5100 /dev/snd/controlC1

and with firefox closed and no sound playing:

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
knotify4 2989  tom   13u   CHR  116,9      0t0 5100 /dev/snd/controlC1
kmix     3762  tom   11u   CHR  116,9      0t0 5100 /dev/snd/controlC1

I have checked the PCM mixer levels and pretty much unmuted everything with no change.

Generally I test in, but bbc iplayer doesnt work either.

Would it be worth copying the #1 card in asound to #0 incase flash is not that intelligent?


Thanks. The only thing I note there is only one sound device is recognized:

!!Soundcards recognised by ALSA
 1 [XFi            ]: SB-XFi - Creative X-Fi
                      Creative X-Fi 20K1 SB073x

Both of those are the same. Typically when playing flash, you will see npviewer …

It does not appear pulse is running on your PC, … and I am not saying it should, as pulse has caused problems with many users.

But typically, when I play a video on youtube on my 64-bit PC (on openSUSE-11.1) I get:

pulseaudi 5617  oldcpu   20u   CHR  116,9      0t0 5484 /dev/snd/controlC0
pulseaudi 5617  oldcpu   25u   CHR  116,4      0t0 5420 /dev/snd/controlC1
kmix      5628  oldcpu   10u   CHR  116,9      0t0 5484 /dev/snd/controlC0
kmix      5628  oldcpu   11u   CHR  116,4      0t0 5420 /dev/snd/controlC1
npviewer. 8489  oldcpu  mem    CHR  116,6          5465 /dev/snd/pcmC0D0p
npviewer. 8489  oldcpu   12u   CHR  116,2      0t0 5254 /dev/snd/timer
npviewer. 8489  oldcpu   13u   CHR  116,6      0t0 5465 /dev/snd/pcmC0D0p
npviewer. 8489  oldcpu   14u   CHR  116,9      0t0 5484 /dev/snd/controlC0

The above is from my 64-bit PC with openSUSE-11.1.

I was a bit puzzled by knotify4 still running, but I note the same is true for my 32-bit PC running openSUSE-11.2 PC (installed a few hours ago). I also note on my 32-bit openSUSE-11.2 PC that I also have 3 npviewer instances running when playing back a youtube video (and also 1 kmix instance).

My test video: don’t know.

I removed the pullin-flash-player and sound got the sound back.

That doesnt work for me either.

Give up and I will try the 32-bit edition see if it makes any difference.

Thanks for you efforts.

This is going to sound really nuts, but: close all audio apps.

Open a terminal, run su - and then run alsaconf - save settings. Open a browser and see if it works.

When I start alsaconf all the sound cards are removed and then alsa cant find anything,

Looking in KDE media I am just left with a non-functioning pulse