No sound in flash on 64bit opensuse 11.1

I think I’m about ready to give up on opensuse 11.1 and move to another distribution that’s more friendly w.r.t. audio troubleshooting. Hopefully (and despite struggling with this issue for several days now) there is a simple fix.

I installed opensuse 11.1 x86_64 by upgrading from my previous opensuse 10.3 x86_64. After the upgrade, I’ve had all kinds of problems with getting sound to work. The Yast sound tool doesn’t seem to work and it’s volume tab has a GUI error (what’s up with that?). The only way I could get any sound out of kde3/amarok (in kde4) was to manually pick the OSS engine. Alsa, pulse etc. don’t work. Similarly the only way I get sound out of smplayer, kkmplayer, vlc etc. is by picking the OSS engine (which is just /dev/dsp I think).

Anyway, I’m running 32bit firefox and I installed Adobe’s 32bit flash player and plugin. I get video and no audio. When accessing a flash audio page, the errors I get are

User name: anand
Host Name: agape-server
Server Name: pulseaudio
Server Version: 0.9.12
Default Sample Specification: s16le 2ch 44100Hz
Default Sink: alsa_output.pci_1106_3059_sound_card_0_alsa_playback_0
Default Source: alsa_input.pci_1106_3059_sound_card_0_alsa_capture_0
Cookie: b956c5a4
E: shm.c: Invalid shared memory segment size

Could this be a 32bit/64bit mismatch between pulseaudio, alsa, flash (and god knows what)? Can anyone help? I’ve installed all the 32bit libraries for alsa and pulseaudio as well with no luck. Perhaps I should install 32bit libraries for xine, yaypup(?), esd, oss, jack, ao, openal, and gstreamer (and the many more linux audio libraries) :-)?

From my experience so far, sound in opensuse 11.1 is totally borked. I cannot recommend this distro any longer to people looking for a fairly polished linux desktop.


Before you completely give up you may might want to take a look at another thread where I listed all the sound related packages I’ve installed.

I got audio fully working with those, running x86_64 11.1 like you do.

After some looking around in YaST software management it seems that I’m running a 64 bits Firefox with 32 bits flash:
libflashsupport 1.2-4.20-i586

And pullin-flash-player … but that seems to be openSUSE thing to warn you about needing a non-open source package.

The problem is that things like this shouldn’t even be an issue. All the sound issues present show a total lack of polish, and shows something much worse when you consider that many people(including myself) had no sound problems with 11.0(except for my laptop).

11.1 is a big step down from 11.0, which is pretty funny.

I think I’ve solved the problem.

My PC has two soundcards, a VIA thingamajig on the motherboard and a Soundblaster PCI card. I set up the soundcards under Yast and made the Soundblaster card the default. Or so I thought. The failure of Yast to allow me to set default volume or play a test sound should have tipped me off. (And the Yast GUI error complaining of wrong syntax or somesuch is the absolute limit. opensuse 11.1 should NEVER EVER EVER HAVE BEEN RELEASED IN THIS WOEFUL STATE.>:()

Since opensuse 11.1 now uses pulseaudio (in addition to alsa, arts, gstreamer, esd, jack, libao, SDL, openAL, xine, yaypup(???), oss), pulseaudio decides who the default card is and it picked the onboard card. When I changed the default to the soundblaster card, I expected everything to work as in audio in flash but no dice. Because Yast and pulseaudio lied. The onboard card is the default and I could only get flash audio on the onboard card.

I then took an extreme step and deleted the onboard card in Yast. Then I checked pulseaudio and sure enough it doesn’t show my onboard card. Now with only one card to pipe stuff through, audio in flash finally WORKS.

I wish the linux sound guys would give us more sound libraries though. I only see around 10 or so. I want more options. How about shooting for 25 libraries in opensuse 11.2 :P? Please, please. One can only hope.

I’ve got exactly the same problem! BTW: I too made exactly the same upgrade, from 10.3 to 11.1 x86_64. I too am very disappointed with 11.1 – don’t even ask me about KDE4.

Anyway, did you find a solution, Anand?

Yes, please see previous post. I disabled the onboard sound device and made my PCI soundcard the default in pavucontrol. That worked and I now have flash audio on my preferred sound device.

  • I have tried to make sound work following the instructions in this thread - setting the PCI card as the primary card and deleting the onboard card . This works fine until I restart .
    After restart - no sound . Adding and deleting the onboard card makes it work again , but I don’t think it is an acceptable solution .
    By the way I’m running KDE 3.5 and everything else I need works fine .

If you are using an addon sound card, did you disable onboard sound in your bios?

Various things can interfer with the loading of a sound driver. For example, other possibilities, besides having the wrong card selected, is something like ndiswrapper, or acpi, interfering with the alsa load.

After a reboot, when your sound is not working, did you attempt a simple restart of alsa sound driver with: **su -c ‘rcalsasound restart’**enter root password when prompted, then restart your mixer, and test your sound.

If that works, one can then add “rcalsasound retart” to one’s /etc/init.d/boot.local as a work around (to have it run every boot).

Q. If you are using an addon sound card, did you disable onboard sound in your bios?

A. No - I didn’t because on OpenSUSE 11.0 it worked by setting the PCI-card as the primary card in Yast → sound . ( I dualboot the PC with 11.0 and 11.1 ) .

Thanks RCCrouch . I have now disabled the onboard sound in the bios and sound now works after restart . I guess it’s an acceptable solution since I didn’t use the onboard sound anyway .

I still have some problems with with stuttering sound quality .
I’m running on a 2.6 Ghz so I don’t think CPU is the problem .
In amarok i have changed xine engine plugin from autodetect to Alsa and that works fine . Flashplayer still stutters but that can probaly be solved . Thanks again for the tip about the bios .

Some users have problems with pulse audio and stuttering sound. I do not know if this is what you are experiencing. Some of these users were able to work around the problem by applying the following work around:
SDB:AudioTroubleshooting - a possible fix for choppy_skipping sound - openSUSE

I’m having similar troubles on a 32 bit system. Video plays ok on youtube but no audio whatsoever. I have everything with alsa, gstreamer, swfdec, and flash in the name installed as far as I know.

I am getting the error that ‘Connection failed: Invalid server’ if I try to open ‘volume control’ in pulseaudio device chooser.

I have tried setting sound to Alsa in control center/sound and every other setting. I’ve tried countless other things…too many to remember.

I tried doing and the output is here:

Also the only reason that I have pulseaudio running in the output is because in root I manually started it. It gave me this weird output (below) which I have ignored…

mypc_rootmode# pulseaudio --system
W: ltdl-bind-now.c: Failed to find original dlopen loader.
W: main.c: Running in system mode, but --disallow-exit not set!
W: main.c: Running in system mode, but --disallow-module-loading not set!
N: main.c: Running in system mode, forcibly disabling SHM mode!
N: main.c: Running in system mode, forcibly disabling exit idle time!
W: main.c: Home directory of user ‘pulse’ is not ‘/var/run/pulse’, ignoring.
W: pid.c: Stale PID file, overwriting.

I get the error ‘Connection failed: Invalid server’ from pulseaudio after making changes to the sound preferences. Usually when this occurs, it is a good idea to either get out of gnome/kde or even better to reboot the system.

If you’re running gnome, have you run gnome-sound-properties and tried out the choices? That could help.

Also, when I hear you say that you manually started pulse, that sounds pretty scary. Either pulse should be running by itself or not at all.

yes I’ve tried gnome sound properties…had it on every setting. It’s set to autodetect now.

Q: After a reboot, when your sound is not working, did you attempt a simple restart of alsa sound driver with: su -c ‘rcalsasound restart’.

A: I have tried the command : su -c ‘rcalsasound restart’ as suggested by oldcpu . No luck . For now I’ll go along with disabling the onboard sound in the BIOS . In OpenSUSE 11.0 setting the PCI card as the primary card worked . This is how I think it logically should be .

Hi. I had a similar problem. No audio in flash player but everything else fine. I have a Toshiba Laptop M70-360, not sure about my soundcard, intel chipset I think.

I uninstalled flash player and all related software. Version Then installed again the same version and avoided installation of “libflashsupport” and “pullin-flash-player”. After that sound worked in flash and everything fine so far.

Hope this helps someone.

Thanks for posting this solution! I just had this same issue, found your solution with a search, and it worked like a charm.

I had the same problem. I found out later that it was related to flash player plugin needing a wrapper to work under 64bit Linux. But not anymore, Adope had released a native 64bit flash player for Linux. Find the following link on how to download and install it on SuSE 11.0 and 11.1 64bits : » Blog Archive » Installing native 64bit Flash Player on Linux

I used it and it worked like a charm.

Ahmed Samir