No sound in Flash, Browser, Totem, etc: SOLVED

You need to know that these instructions work for anyone who has more than one way to play sound on the computer: For instance, I have a onboard sound card on my motherboard AND an ATI HD Video card that produces HDMI sound.

These are the steps I took, but I recommend that you skip down to step 6 to see if that’s all you need:

  1. download and install codecs-kde.ymp
  2. download and install codecs-gnome.ymp
  3. download and install w32codecs-all.ymp
  4. In Konsole as user (NOT root) pulseaudio -D --start
  5. KDE Menu/Applications/multimedia/volume control/pulseaudio volume control
  6. in Konsole as user (NOT root): cd (to where you have a music file), then mplayer “filename” replacing “filename” with the name of the music file
  7. notice errors about Alsa - This is what I got: [AO_ALSA] alsa-lib: pcm_hw.c:1325:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: No such file or directory
  8. keeping in mind what was described as No such file or directory in the error: in Konsole as user (NOT root): fuser -v /dev/snd/*

I got:
/dev/snd/controlC0: trekjunky 3202 F… kmix
/dev/snd/controlC1: trekjunky 3202 F… kmix
/dev/snd/pcmC0D3p: trekjunky 8135 F…m firefox
/dev/snd/timer: trekjunky 8135 f… firefox

so I did:
9) in Konsole as root (NOT user): cd /dev/snd then ln -s pcmC0D3p /dev/snd/pcmC0D0p

Notice I linked pcmC0D0p to pcmC0D3p

It worked after that.

Good Luck!!!

Turns out this isn’t a permanent fix. The ln -s command creates a link, but when I rebooted, that link was gone. I need to do some more research to find a permanent fix.

Sorry Folks,

Workaround, but will fix it permanently:

1)Open Dolphin
2) Navigate to your home directory
3) Right click and choose create new text file
4) Name it
5) Open it with Kate
6) copy the text below and paste it into the Kate document making sure that the pcmC0D0p and pcmC0D3p reflect your devices:

cd /dev/snd
ln pcmC0D3p /dev/snd/pcmC0D0p

  1. save the kate document

  2. in Konsole as root (NOT user): cp /home/yourname/ /etc/cron.d/

  3. still in Konsole as root, use the lessons of this website to edit a cron job:
    How do I add jobs to cron under Linux or UNIX oses?
    The line I put into my cron job list looks like this:
    @reboot /etc/cron.d/
    some key commands when editting cron:
    :quit! will quit without saving
    :w will write your changes to the file
    :quit after :w will exit while saving your changes

  4. reboot and test you browser

  5. if it is not working:
    a) double check your script in the directory /etc/cron.d/ called
    b) double check your cron entry with the following:
    i) in Konsole as root (NOT user): cron -l
    it should look like this with your editted line at the bottom:

Enterprise:/home/trekjunky # crontab -l

DO NOT EDIT THIS FILE - edit the master and reinstall.

(/tmp/crontab.XXXXJNQ84b installed on Sat Jun 19 05:45:29 2010)

(Cron version V5.0 – $Id: crontab.c,v 1.12 2004/01/23 18:56:42 vixie Exp $)

@reboot /etc/cron.d/
Enterprise:/home/trekjunky #

If you need help, feel free to email me at I will respond within 24 hours.

Thanks and goodluck!!!

I don’t remember how to edit this post, so I am quoting my first entry and changing the quote to what it should be: