No Sound in Firefox with Suse 11.2

Hi @ all!

I´ve got the problem that i get no sound with adobe Flash 10.0.32.18 in Firefox 3.5.4 on my Suse 11.2

What i´ve done:

After Suse 11.2 installation i installed Audiocodecs by using 1 click installation from:

Restricted Formats/11.2 - openSUSE-Community

Switched default Sound to USB Device in Sound Options in Task bar.

After this i uninstalled the Adobe Flash plugin and reinstalled the Flash Plugin (after uninstall of Plugin, it still appears in Firefox as “10.0r32”) by using the install Option direct from the adobe homepage as Yast Installation.

I get sound with Koffein, can play mp3, everything fine, but Flash Clips are without sound.

For sound i use usb speakers plugged in direct to the USB port of my Asrock motherboard.

Suse also find the on board Nvidia Soundchip, but i only use the usb speakers.

For further test i installed VLC Player. Here i also got no Sound, but Video is still playing.

Could somebody help me?

THX for Support

I’m having a very similar problem with flash in firefox. I’ve tried uninstalling/installing adobe flash and the pullin-flash-plugin to no avail. The other thing I looked at was making sure my PCM volume was turned up.

If neither of those two work then your stuck in the same boat as me right now.

VLC I can probably help you with however. First this fix only works if you have the videoLAN repo active. If so uninstall/delete VLC from your system. Afterwards do the exact same with the videoLAN repo itself (you DO NOT want it on your system).

Open up a terminal and type in the following:

rpm -qa --queryformat '%{NAME} -> %{VENDOR}
’ | grep -i VideoLAN

That should give you a list of all the packages installed from the videoLAN repo you just deleted. Go through and uninstall every package EXCEPT for the libdvdcss package. After your done removing all of those packages just reinstall VLC through YaSt or zypper and you should be good to go.

The PCM Sound is up, the VLC HowTo i will try in a view hours.

Think this Flash Problem is hard to fix. Google can´t find good/no solution for this problem :’(

It is hard to fix and it’s starting to tick me off a bit. There has to be a developer out there that uses flash…

Please, when using firefox to play sound, ensure you have no other multimedia devices playing.

Please also confirm you see shockwave flash player listed, when you type in your location bar of firefox:

about:plugins

You also need to advise if this is a 32-bit or 64-bit PC.

And if 64-bit confirm the command I gave also indicates the presence of the “nspluginwrapper”.

On my 64bit PC, when I type:

rpm -qa '*flash*' '*wrapper*' 

I get

nspluginwrapper-1.2.2-5.6.1.x86_64
pullin-flash-player-11.2-2.1.x86_64
flash-player-10.0.32.18-3.1.1.i586

Flashplayer works for me.

Note my repositories are very simple, and have always been simple since I installed 11.2. I only have OSS, Non-OSS, Update and Packman. There was no possibility of rpms that could break my PCs functionality being mistakenly installed from another repository.

It is important you keep checking this.

I had a similar problem with flash audio and after some troubleshooting I discovered that my PCM volume was set to 0.

The solution was:

Open Yast -> Go to Sound -> Other -> Volume -> PCM++ & Master++

I personally installed pulseaudio too on purpose to help out with multi sound support.
Pulse is no perfect so thats why its not in the default install.

Nice, I have CA0106 card. I don’t see any PCM sliders:(
I just see a lot of IEC958 sliders.
Anyway, if I start Firefox as root from terminal, YouTube works with sound.
So for me it’s a permission problem…now I have to find out where…:\

If using KDE, note you can in kmix go to settings > configure channels and add extra controls.

Thanks for your answer, oldcpu!
When I open my kmix channels I found all options on, nothing is off. And there is no pcm, this is what I have in my CA0106:

amixer |grep control

Simple mixer control ‘Master’,0
Simple mixer control ‘Line in’,0
Simple mixer control ‘Mic’,0
Simple mixer control ‘Phone’,0
Simple mixer control ‘IEC958’,0
Simple mixer control ‘IEC958 Center/LFE’,0
Simple mixer control ‘IEC958 Front’,0
Simple mixer control ‘IEC958 Rear’,0
Simple mixer control ‘IEC958 Unknown’,0
Simple mixer control ‘Aux’,0
Simple mixer control ‘Analog Center/LFE’,0
Simple mixer control ‘Analog Front’,0
Simple mixer control ‘Analog Rear’,0
Simple mixer control ‘Analog Side’,0
Simple mixer control ‘Analog Source’,0
Simple mixer control ‘CAPTURE feedback’,0
Simple mixer control ‘Digital Source’,0
Simple mixer control ‘Shared Mic/Line in’,0

rpm --query --all ‘flash’ ‘wrapper’ ‘gecko’ ‘rplug’ | sort

flash-player-10.0.32.18-3.2.1.i586
nspluginwrapper-1.2.2-5.6.1.i586
pullin-flash-player-11.2.1-0.1.1.i586

rpm -qa “alsa*”

alsa-utils-1.0.21-3.1.i586
alsa-docs-1.0.21-3.2.noarch
alsa-oss-1.0.17-25.2.i586
alsa-1.0.21-3.2.i586
alsa-plugins-1.0.21-3.3.i586

cat /proc/modules |grep snd

snd_pcm_oss 51648 0 - Live 0xf8349000
snd_mixer_oss 18464 1 snd_pcm_oss, Live 0xf8253000
snd_seq_midi 8032 0 - Live 0xf8224000
snd_seq_midi_event 8480 1 snd_seq_midi, Live 0xf81fd000
snd_seq 64752 2 snd_seq_midi,snd_seq_midi_event, Live 0xf81a3000
snd_ca0106 41632 5 - Live 0xfa36e000
snd_ac97_codec 119364 1 snd_ca0106, Live 0xfa33a000
ac97_bus 1920 1 snd_ac97_codec, Live 0xfa2e9000
snd_usb_audio 95712 1 - Live 0xfa2b9000
snd_usb_lib 21600 1 snd_usb_audio, Live 0xfa28e000
snd_pcm 97444 8 snd_pcm_oss,saa7134_alsa,snd_ca0106,snd_ac97_codec,snd_usb_audio, Live 0xfa172000
snd_rawmidi 26784 3 snd_seq_midi,snd_ca0106,snd_usb_lib, Live 0xfa145000
snd_seq_device 8556 3 snd_seq_midi,snd_seq,snd_rawmidi, Live 0xfa131000
snd_hwdep 8580 1 snd_usb_audio, Live 0xfa123000
snd_timer 27176 2 snd_seq,snd_pcm, Live 0xf9e10000
snd 75076 25 snd_pcm_oss,snd_mixer_oss,snd_seq_midi,snd_seq,saa7134_alsa,snd_ca0106,snd_ac97_codec,snd_usb_audio,snd_usb_lib,snd_pcm,snd_rawmidi,snd_seq_device,snd_hwdep,snd_timer, Live 0xf8671000
soundcore 9120 1 snd, Live 0xf8405000
snd_page_alloc 10248 2 snd_ca0106,snd_pcm, Live 0xf831d000

lspci -nn |grep audio

02:03.0 Multimedia audio controller [0401]: Creative Labs CA0106 Soundblaster [1102:0007]
(It is Soundblaster Audigy SE)

I’ve never encountered such a problem.

But I do know of cases where users who have inappropriately run as root, have created ugly permission problems.

I assume that is not the case here, and so lets hope the solution is easy.

Did you install from an 11.2 CD ? 11.2 DVD ? … or do some other install ?

You could check to see what devices root is using when playing audio in firefox and what devices a regular user is playing (or not playing) when trying to play audio in firefox. Guidance is here: SDB:AudioTroubleshooting - openSUSE - determine device user is accessing
ie see if this can tell you what user is accessing what device and then copy to a text file for later comparison between various attempts:

 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

:slight_smile: Well, I am not such user, I only use my system as other user, not root. What I see with lsof is mostly this (in cases with or without playing YouTube):

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
knotify4 9042 jan 13u CHR 116,14 0t0 5354 /dev/snd/controlC0
kmix 9067 jan 11u CHR 116,14 0t0 5354 /dev/snd/controlC0
kmix 9067 jan 13u CHR 116,4 0t0 5078 /dev/snd/controlC1
kmix 9067 jan 14u CHR 116,16 0t0 5677 /dev/snd/controlC2

And sometimes I see this (when I hit lsof >10x):

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
knotify4 9042 jan 13u CHR 116,14 0t0 5354 /dev/snd/controlC0
kmix 9067 jan 11u CHR 116,14 0t0 5354 /dev/snd/controlC0
kmix 9067 jan 13u CHR 116,4 0t0 5078 /dev/snd/controlC1
kmix 9067 jan 14u CHR 116,16 0t0 5677 /dev/snd/controlC2
npviewer. 9519 jan 13u CHR 116,12 0t0 5321 /dev/snd/pcmC0D0p
npviewer. 9519 jan 14u CHR 116,10 5300 /dev/snd/pcmC0D1p

  • I already had found out I have sound when I startup Firefox from root.
  • and now I found I have a kind of ‘rattle’ sound from my back speakers when I am playing YouTube. It seems sound is not going to right device?
  • I have tried instructions in other forum too: SDB:AudioTroubleshooting - openSUSE
    But without succes.

Anyway, thanks for your help!!! (do you like soundproblems? :slight_smile: )

and ??? … what is the output of that 'lsof … ’ command when audio is playing with root permissions?

Did you go to YaST > Hardware > Sound and ensure the audio device you wish to use is the main audio device?

If using KDE did you go to KMenu > Configure Desktop > Multimedia and ensure you have the correct device selected there?

YouTube in Firefox from root:

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
knotify4 9042 jan 13u CHR 116,14 0t0 5354 /dev/snd/controlC0
kmix 9067 jan 11u CHR 116,14 0t0 5354 /dev/snd/controlC0
kmix 9067 jan 13u CHR 116,4 0t0 5078 /dev/snd/controlC1
kmix 9067 jan 14u CHR 116,16 0t0 5677 /dev/snd/controlC2
npviewer. 9818 root mem CHR 116,12 5321 /dev/snd/pcmC0D0p
npviewer. 9818 root 12u CHR 116,2 0t0 4720 /dev/snd/timer
npviewer. 9818 root 13u CHR 116,12 0t0 5321 /dev/snd/pcmC0D0p

fuser /dev/snd/*

/dev/snd/controlC0: 9042 9067
/dev/snd/controlC1: 9067
/dev/snd/controlC2: 9067
/dev/snd/pcmC0D0p: 9898m
/dev/snd/timer: 9898

ps -c 9067

PID CLS PRI TTY STAT TIME COMMAND
9067 TS 19 ? S 0:00 kdeinit4: kmix [kdeinit] -session 10979b6d7300…

Don’t know how to interpret the lsof command.

Oh, and yes, I have checked my configuration with Yast and personal settings in KDE.

first output device = Audigy SE [SB0570] (CA0106)
Backend = Xine (via Phonon Xine backend 0.2.60).

:shame:

Oops, I didn’t tell I have a .asoundrc file in my home dir:

cat .asoundrc

pcm.!default {
type route
slave.pcm surround51
slave.channels 6
ttable.0.0 1
ttable.1.1 1
ttable.0.2 1
ttable.1.3 1
ttable.0.5 0.5
ttable.1.5 0.5
}

Hope this is not making a mess of my soundsystem. In root I only have 2-channel audio. I have made this asoundrc to have “surround” sound and it works for VLC at least.

:X

npviewer is accessing the audio device for your firefox audio.

what happens when you briefly remove it and restart and test? I assume that file is NOT in root’s home, and hence there is a difference there between the regular user and the root user.

No sound on www. <- Did you try that?