No sound in firefox with Open Sound System


I recently installed the x64 rpm of OSS on my Opensuse 11.2 installation (alsa does not have drivers for my lynx card). Sound works beautifully in KDE (login sounds, apps produce sound, etc), EXCEPT for firefox. I can get no sound at all from firefox. I am baffled at why only firefox does not play audio. I need some help.

OpenSuse 11.2 (it is a pretty fresh install)
OpenSoundSystem 4.2
KDE 4.4 (updated from factory repos)

Please post result of

zypper lr -d

Have a look here
SDB:Audio troubleshooting - openSUSE

KDE-4.4 ? openSUSE-11.2 comes with KDE-4.3.1 with an official update to KDE-4.3.5. KDE-4.4 is NOT official and hence has NOT been tested to the same extent as KDE-4.3.5. Should you be doing such an update if you can’t get something like sound in firefox working? :\

Note sound could be streamed as a flash (.flv) file or it could be streamed as an .mp4. If its the .flv then you need flash-player and if .mp4 you will need other codecs and such.

Provide the information caf4926 requested so that we can assess what might have gone wrong (wrong besides complexities that were introduced as a result of updating to KDE-4.4 ).

Also, in the case of flash, there could be a few different reasons for your problem, and the solution provided may different dependent on your desktop (because each desktop handles sound differently).

Some suggestions

  • start a video in Firefox and then check the mixer PCM level. That needs to be moved up in volume and it may have dynamically moved down to zero
  • If KDE check YaST > Hardware > Sound and note the priority of audio devices. The device in which you wish to play audio from in Firefox should typically be chip-0. Then go to KDE kickoff application launcher > Configure Desktop > Multimedia and ensure the priority of audio devices there matches what you observed in YaST.
    Often users with 2 sound devices will struggle a bit with Firefox and flash videos until they sort this.
  • Go to Firefox > Edit > Preferences > Applications > Shockwave Flash file and change the selection to “use Flash Player (default)”. You may need to restart firefox afterward.

Good luck

Hi there— my understanding is that the latest Flash plugin only works with ALSA, not OSS.