no sound in Banshee with openSUSE-11.2 Gnome 2.28.0


having spent the last few days trying to solve the sound problems,
I have moved a step further, but still some help would be higly

I have a fresh installation of OpenSuse 11.2 32-bit. My soundcard
is Terratec EWX 24-96. The card is detected in Yast, and I can play
test sound from the Yast/Sound panel. All volume sliders are set
to maximum values (I have also double checked it in alsamixer).

I can hear the sound when doing this test from the Gnome terminal:

speaker-test -Dplug:front -c2 -l5 -twav

However to make this test work:

speaker-test -c2 -l5 -twav

I had to remove the asound-pulse.conf file. After removing this
file the second test (speaker-test -c2 -l5 -twav) works. Removing
this file also solved the problem of missing sound in Youtube
videos played in Firefox. The original contents of the asound-pulse.conf
file was:

pcm.pulse {
type pulse

ctl.pulse {
type pulse

pcm.!default {
type plug
slave.pcm {
type pulse

ctl.!default {
type pulse

The problem is I can’t play any audio files (.wav or .mp3) in Banshee.

I am sure the .wav file I use while testing is OK as I can play it with

When I try playing the .wav file, Banshee does not complain about any
missing codecs. The slider moves as the file is being played. I have
also started Banshee with the --debug option, but there were no errors
in the output.

So my guess is that Banshee is playing the files, it’s just that
it sends the data to the wrong device/channell or whatever it is.

All of the gstreamer packages I have installed are from the Packman

When I run gstreamer-properties, the only setting on the Audio tab that
gives me sound is: ALSA (for the Plugin) and Default (for the Device).

May I ask for more help, please?


In case anyone else has the same problem, here is what has worked in my case:

  1. Using Yast/Hardware/Sound panel I disabled PulseAudio support for my sound card.

  2. I stopped PulseAudio server (with pulseaudio --kill command from Gnome terminal).

  3. Using gstreamer-properties I set ALSA for Plugin, and Default for Device on the Audio tab.
    I set the obove values both for Default input and Default output.

  4. I have no ~/.asoundrc file.

  5. I have removed asound-pulse.conf.

Lots of frustration, but finally it works :slight_smile:

Banshee plays bot wav and mp3 file. I do have sound in Youtube videos (Firefox).

I still don’t know why the thing didn’t work with Pulseaudio enabled.

Glad to read you have it working now. Thanks for sharing your solution.