No sound in Audacity

I am having trouble with Audacity on openSUSE 11.1 (KDE4/Phonon). I cannot get it play any audio. The first time I ran it after installation I just selected “ALSA:default” as the output from Audacity’s output selection and it worked fine; however, after that first run the “ALSA:default” option disappeared. Now I have the following options for output: “ALSA:HDA Intel” (my onboard sound chip); “ALSA:iec958”; “ALSA:spdif”. However, the Audacity input selection has more options, including all of the above, plus “ALSA:default” and “ALSA: M Audio Delta” (my real soundcard).

I have two sound cards on my machine, the HDA Intel sound chip and a beefier M-Audio Delta interface. All other audio aware apps use the Delta (which is my preference in the KDE4 Sound settings) just fine. However, Audacity won’t use either, even when I select the HDA Intel, I get no audio from the card.

I really want to get Audacity playing through the Delta card, but right now anything would be better than nothing. Does anyone else have problems with Audacity on openSUSE? I have had almost identical problems with Audacity since openSUSE 10.3.