No sound in Astromenace on openSUSE 12.1

Hi all,

I downloaded one of my favourite games from their website, Astromenace: Viewizard - AstroMenace (free for Linux users)

I use openSUSE 12.1, 64bit (KDE 4.8.1 / Gnome 3.2). The game runs fine but there is no sound, with the sound options in the settings menu saying “Not available”. Sound everywhere else in the OS works fine. However, I also installed a repository version of Astromenace, and there IS sound on THAT version, but that version is out of date and I’d rather use the website version (1.2.80115).

I am completely unsure why this is so. I do, however have a similar issue on Ubuntu which is caused by this:

Looks like Ubuntu 8.10 don’t like libopenal0a any more. Only libopenal1 is “proper” openal lib now and all games MUST be recompiled with this one.
Hmmm… sorry, looks like Ubuntu 8.10 want to have separate debs in our repo, plus separate game build… errr.
I’ll provide such debs in future, as soon, as Ubuntu 8.10 will be installed on my pc.

From:

Can’t install Astromenace in Ubuntu 8.10 - Broken packages

… This is fixable on Ubuntu by installing the Ubuntu Hardy version of libopenal0a. Sound then works on Ubuntu with Astromenace again. However, on openSUSE 12.1 I have installed “libopenal0-soft” and “libopenal0-soft-32bit” from the repos, sound still doesn’t work. I don’t know however, if the Ubuntu sound issue is the same as the openSUSE sound issue, since if I remember, sound options aren’t greyed out in the game settings in Ubuntu, just no sound. I mention the Ubuntu sound issue as that’s the only thing I have to go on, not sure if it’s related.

For what it’s worth I did have sound working fine in Astromenace in openSUSE 11.4, if I remember rightly.

Any ides? This is one of my favourite games and I really want the uptodate website version, not the one in the repos.

Thank you for your time and assistance.

EDIT: For what it’s worth, I DO use PulseAudio but that shouldn’t matter as it’s worked with PulseAudio before.

Specs:

CPU: Intel Core 2 Duo E6750 @ 2.66GHz stock
GPU: Nvidia GTS 250 512MB (re badged 9800GTX+) with openSUSE drivers.
RAM: 4GB DDR2 800MHz Kingston
OS: openSUSE 12.1, 64bit with KDE 4.8.1

I suggest you want to look at the following blog and to install the PulseAudio Volume Control. Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

I have a nVIDIA Video card that also includes sound and I must always disable it, using the Profile of off, for anything found except for the actual sound card I want to use. I also have a script that can be useful you can find here:

S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.12 - Blogs - openSUSE Forums

I also installed the game you pointed out and it works and it has sound. I did need to load several dependencies, but that was it. It was great find and thanks for letting us know about it.

Thank You,

openSUSE 12.1 x86-64 here and it works just fine, sound included.
I guess you are using the “game_launcher”? That way it uses the ooooold openal from the lib32/lib64 directory… and probably has no sound because that openal never had a pulseaudio backend. Just run the binaries directly or delete the lib32/lib64 directories (then game_launcher doesn’t do anything useful).

Don’t I feel like and idiot :shame:
12 years of Linux experience, and the one thing I didn’t try was the game without the launcher.

Thank you very much, yes it works fine now. By the way, if anyone is interested, you can make your own levels for Astromenace via XML, very easily. Here is the documentation for it:

http://www.viewizard.com/astromenace/script_en.pdf (English)
http://www.viewizard.com/astromenace/script_ru.pdf (Russian)

Thanks for your help everyone. I’ll post another thread now with another, more complex issue I have with another game.