No sound in Amarok 1.4.10 pm 64 bit

I have all of sudden a problem with Amarok. No sound any more and apparently the program has conflicts. I have pulseaudio installed. All other audio applications work flawlessly, included VLC and Kaffeine. In these applications the sound is perfectly normal.

**Version of Amarok: from PM
Version of KDE: 3.5.10 release 73
The problem does not seem KDE related, nor does the sound system seem to be generally compromised. All other applications and system sound seem normal.

Symptoms: Opens and you can normally select files, plays but without sound, no error messages.
If you open configuration it is on auto. If you select Pulseaudio it is ok, no sound but works. If you select ALSA or OSS the application ceases to respond. No error messages. You have to kill the app. to get rid of the frozen window. Reopens in the last state - of course with no sound.
Anybody else with this problem? Suggestions?

Installed sound engine is xine.

Is this 11.2?

Can you explain what you mean by “all of a sudden” ? Did it work before?

If it worked before, then it could be some application has seized the audio device and is not sharing it. In which case close amarok, and then you could restart alsa with su -c ‘rcalsasound restart’ and enter root password when prompted, and then if using kde type ‘kmix’ to restart your mixer. Then restart amarok.

If amarok has never played before on this openSUSE version, then you may need to sort your codecs with a NON-crippled version of xine (ie Packman packaged and not Novell/SuSE-GmbH packaged).

Sorry for not mentioning it. It is 11.1.
As I tell, all the rest of application and system sound works. I would go for the doubt it is what Oldcpu said, some app does seize the resources. Will now try with the console and tell you the result.

About “all of a sudden”: no install processes concerning Amarok were done.

I used the console following your advice. The sound device was displayed. I noticed the following device list:
Intel HDA analog
Intel HDA digital

were listed. But only analog does effectively work with “test” button.
I changed the imposition for “interlaced” in back-end and checked all options: also file. Now Amarok and VLC seam to work flawlessly. Interestingly I found out that if you use Amarok and then also VLC, now you have no problem. Nice “cacophony” if you put to distinct songs. But…
If I use Kaffeine then I have an phonon error message that the analog device does not work and that it is shifting to HDA digital…which does not work.

For me seeing this, it comes to my mind that this app, yes had an update. And time period could coincide. Therefore Kaffeine sequesters the resource and then does not free it anymore.
Amarok then apparently has a problem, vlc not.

Kaffeine is 4.3.4 which installed during an update substituting the the 3.5 version. I thought this was intentionally but now maybe I will look to shift it back to 3.5 because this version seems not work too well together with 3.5 and does also quite frequently crash (still pre). Was it supposed to install in automatic? Hope the 3.5 version is still available.

Any suggestion how I could make HDA digital work?

It would be helpful to know if this 11.1 system is running kde3 or kde4

Sorry but this was actually posted in bold:
Version of Amarok: from PM
Version of KDE: 3.5.10 release 73

Post result of

rpm --query --all '*amarok*'

rpm --query --all ‘amarok


Ok, then if I understand correctly, amarok works now?

Note Linux has never had a good reputation for providing the capability of multiple applications to share one sound device. That was one of the reasons why pulse audio was introduced, was to provide that capability. However pulse is buggy and many of us (I for one) do not know how to properly configure pulse, nor how to work around the bugs inside pulse with pulse.

I do note that for many audio hardware devices, that one can select the alsa API in one’s multimedia application, and the alsa API (unlike many sound servers/daemons) will share the audio device with other applications that also use the alsa API. Hence on my PCs I tend to select the alsa API where appropriate.


It always worked for me but that was back in 11.0 I used kde4 development in 11.1
But I always have xine backend, with Alsa
Those packages look ok.

You could try unconditional update in Packman

Yes it works now. On what alsa: I noticed this before. But if you tried to do it, amarok would “freeze”.
If it should reproduce, I will un-install the Kaffeine pm 9.something version and put again the kaffeine 8… and flag it do not modify - hoping that this will definitely solve the problem.

But strangely enough, the three hooks in the phonon regulation did the trick. And thank you so much, I did find them through your command. Did not even know that phonon was installed on this machine.

11.1 was first nearly unusable. But recently I feel quite comfortable again…

Thanks for your help.

@caf: I will try, but I have to be on the University network, not enough GB available on my poor EDGE card. :wink: Thanks for the suggestion.

No worries if it’s working