No sound in a certain user's KDE session

Hi all,

I have read (and learnt from) many postings here before but this is the first time I was not able to solve my problem by just searching and reading. Nevertheless, I’m confident that your collective wisdom can help me.

So, here’s the problem: Quite some time ago I managed to get sound working perfectly on my DELL Inspiron 1720 under openSUSE 11.2 and KDE 4.3.5. Then suddenly some months ago for one of the four regular users on my system sound stopped working! KMix is always muted after KDE session startup for this user and even if you unmute it there’s still absolutely no sound; in particular, the command

speaker-test -c2 -l5 -twav

doesn’t generate any sound (while I do see the printed output which doesn’t contain any error messages). Even if I su to root in the very same Konsole window speaker-test remains silent!

Since sound is OK for the three other regular users I’ve already compared KMix settings as well as System Settings > Multimedia for each of the regular users but found absolutely no differences. BTW: In System Settings > Multimedia I have XINE set as the backend and “PulseAudio” has priority over “HDA Intel (STAC92xx Analog)” for all sort of audio output, and - perhaps needless to mention - all the four regular users are members of group “audio”.

What might be the reason for this mysterious system behaviour?

Best regards,
Seven-of-Nine

The same happened to me yesterday. However, as I was tired of this kind of things I ended up disabling pulseaudio (I do not need it anyway :wink: )

Regards

It must be down to user settings or borked config files.

If other users are fine and if say you create a new user and it is OK, then the system must be OK.
Did you try a temporary new .kde4?

Honestly, I don’t know either whether I need PulseAudio or not. I only pushed it to the top of the audio output priority lists because Phonon kept notifying any user right after login that

“The audio playback device HDA Intel (STAC92xx Analog) is not working. Falling back to PulseAudio.”
(Despite of this message sound was all right then, but I really wanted to get rid off that confusing note.)

What exactly do you mean by “disabling pulsaudio”? De-install it?

Best regards
Seven-of-Nine

Have you checked to see if the order in which users login make any difference? How many users logged in at the same time?

Wow, this is really weird, folks!

Following caf4929’s suggestion I’ve added a new regular user to my system. Sound was perfectly OK for this user - well, apart from that Phonon message about the not working playback device “HDA Intel (STAC92xx Analog)” because this device is given top priority by default.

However, right after adding that new regular user and testing sound for him I re-tested sound for the “problematic” user who had no sound before. And you know what? Sound was back working for this user as well!!!

Once again KDE has rocked my picture of the deterministic world of software… :wink:

Thanks for your quick responses, anyway, and
Best regards
Seven-of-Nine

You can try to kill and restart the daemon:

pulseaudio --kill
pulseaudio --start

If it doesn’t work, you can do run the fist command (kill) as root and the second (start) as user.

  • sorry, didn’t see the problem has been solved in the meantime. Please disregard that advice.

Hi oldcpu,

only 1 user is logged in at the same time. However, some time back I was able to “fix” a similar problem by just logging in and out with different users and finally all users got working sound again. Your question sounds as if you suspect any special reason for this behaviour. If so I would be very interested to cure my system permanently.

Best regards
Seven-of-Nine

setup-pulseaudio --disable

And reboot the system. That’s the way to disable pulseaudio (you’ll use plain alsa with dmix[to mix sound from different inputs] on top of it)

As you are seeing that error in the kde start, there’s is something wrong with your pulseaudio installation/configuration. Could you please run “pulseaudio --check”?

Regards

I know from experience that Linux (and not just openSUSE Linux) has a notorious reputation for multimedia applications not sharing the audio device. This means that if user-a was using a multimedia application, and closes the application (but the application does not close properly and still seizes the audio device) and then logs out (but does not reboot) then the next user who logs in will find the audio device is seized and sound will appear not to work.

Also, some multimedia devices will automatically load them selves upon boot, dependant on a user’s setting (for example Amarok is notorious for doing this) and if that multimedia application has seized the audio device and is not sharing it, then it can appear that a user can not play audio, when in fact they could if only the bad application that has seized the audio device will let go of it.

Of course this is only the tip of the iceburg, and there is more to this. Hopefully that explanation is more clear than mud. :slight_smile:

This is not what happened to me. When this happens, I get a missage that the audio device can’t be opened.

My guess is that there is some kind of bug with pulseaudio.

If an application has seized the audio device, then other applications can not open it. In that case, one will get the EXACT message you just described.

I’m afraid neither of the two cases applied in my most recent situation. The user who had no sound also had no sound after reboot, and apart from KMix no sound application was autostarted upon reboot.

Thanks anyway
Seven-of-Nine

Since the issue resolved automagically I haven’t tried setup-pulseaudio --disable, yet. But I’ll definitely give it a try next time, thanks ****shock!

Running pulseaudio --check neither produced any visible output when I ran into the problem nor does it now. By adding the option -v I just got (and still get) the following info message:

I: main.c: Daemon runs as PID <pid>

Best regards
Seven-of-Nine

I wasn’t clear, sorry. I was not getting that message, I tryed to point out that I get it when I’m in the situation you described :wink:

Then again, I vote for a pulseaudio problem.

Regards

Sometimes its not so obvious that a multimedia application is running and was automatically started up at boot. Amaork in particular is notorious for only appearing in the lower right corner, but there being no window present.

If a user has no sound upon boot, one way to check to determine what application is using one’s sound device, copy and paste the following into a terminal or a konsole:

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/* 

Be careful with syntax. That is “/dev/snd/" and NOT "/dev/snd

NOTE, if one runs the above line at different times, when one’s sound is working and not working, one can learn better as to what the output means, and be better able to " point one’s finger " at the offending application that has seized the audio device. Running the above just once and posting it on a forum thread is of no use/help.

Also, if one’s sound does not work upon boot, and if one is certain that their checks for sound were adequate, then one can also try a restart of alsa, with root permissions, by typing:

rcalsasound restart 

and then test one’s audio.