No sound in 12.2/kde

This laptop is a Del XPS M1530 and has used Opensuse for 2 years. This is the first version that the sounds is not working.

In hardware it sees the Intel 82801H ICH8 Family HD Audio controller. The Kmix icon shows a “dummy output”. In the settings, it sees dummy output for playback. Going to "audio setup/device preference shows a greyed out internal audio analog stereo, and a Dummy output. Audio hardware setup shows blank. NOTHING. Nothing to select. So if I were a guessing man, I’d guess it is Kmix, not the hardware detection.

SO I’m looking for some guidance on what to do to trouble shoot this on where to start. Thanks in advance.

I am having the same problem. Everything was fine in 12.1. Interestingly it works under root but not a normal user, you may want to try this to confirm. I’m thinking it’s a permission problem somewhere.

Thanks for that! That thought crossed my mind, but then I forgot to try it. Just logged in a root and voilla! So you are correct sir. Permissions seems like the problem. I’m going to go look at the logs and see what I can find. Must be a small buglet that snuck through somehow. Probably from Kmix.

lshantz wrote:

> Thanks for that! That thought crossed my mind, but then I forgot to try
> it. Just logged in a root and voilla! So you are correct sir.
> Permissions seems like the problem. I’m going to go look at the logs and
> see what I can find. Must be a small buglet that snuck through somehow.
> Probably from Kmix.

No bugs that I know of
And logging in as root is the kiss of death.

Pulse audio is probably the culprit as it was for me. Previous suggestions are to either remove Pulse Audio, or go into the Sound settings in YaST2 (Hardware section), there’s a choice to Enable PulseAudio Support under the “Other” drop-down box. Un-check it, log out and back in.

It is a bug I’m pretty sure. I went and did some digging. Someone has posted it as a bug in July it turns out. :frowning:

While I agree you do NOT want to go logging into root as a work around, it IS a good way to help troubleshoot.

I have tried it in Gnome. Same thing, so it is not a KDE thing. I’m seeing errors in the log about alsa already being loaded multiple times, but can’t imagine how this is the cause.

Hey Wrath5000, I’m all ears. Please help me out… (later… I figured it out)

Yast admin/hardware/sound/other (far bottom right) pulse audio configuration.

It was already checked. Get this… play test sound plays sound! So this is not a pulse audio issue. One thing I noticed is that I did 166 updates that it suggested. Now Kmix won’t even come up. Just a white box. I did a forced update and still no joy.

so my thoughts are, NOT alsa. IS either kmix or something in between. KDE control module is now showing the hardware. It did not before. Kmix shows a blank playback stream. Just tried alsamixer and got snd_ctrl_open failed for default: permission denied.

I’m betting it is as simple as a file flag set wrong, or a directory set wrong. Wish I was smart enough to track this down quickly and report back.

Check the settings in system settings for kde
Hardware > Multimedia > Phonon
Make sure you have the correct preferred device in ALL sections

I’ve also had success in the past by deleting and redoing my audio configuration.

I have a weird audio issue where playing the test sound works fine in YaST, but GNOME reports no available playback devices besides “dummy.” I assume it must be a permissions issue, but I have no idea how to fix it.

I found a relevant bug from beta 2 :[Bug 769570] New: No sound, only dummy output device is found](

Reading through the bug report, it looks like it’s a problem with sysvinit versus systemd. It’s possible that my machine is using sysvinit, but I’m currently at work and can’t verify this.

12.2 is using both sysinit & systemd I believe. Anyhow I am using the workaround of joining the audio group for now until sombody can pin point the issue.

Okay, confession time. I KNOW I’m gonna catch it from admin, but I gotta come clean.

I did NOT do a fresh/clean install. I did the upgrade. I know I know… So this morning, I popped in a second HD and did a complete clean install and guess what? Sound works. Soooooo… after recovering my shot off toes, I think it is time to put the other drive back in and look at the “home” directory. I’m guessing we can salvage our upgraded systems by cleaning out the old config files for sound.

I’m assuming you guys having the same problem did an upgrade and not clean install?

Yep did an upgrade which in itself shouldn’t be a ‘bad’ thing.

Yeah, I upgraded, and I don’t really want to have to do a clean install.

In the past it was highly discouraged. The last couple of updates were fairly painless, but there can be issues with an upgrade. There are so many variables that come into play. There are a couple of things that may work. backup your home directory. Do a fresh install, then place your “stuff” you want to keep back into it. That may work. You would save your bookmarks, files, downloads etc that way, but not muck up the sensitive data like sound. ?? I’m going to try to rename the .alsa and sound directories, and reinstall the sound and see if that fixes it. (didn’t) I’ve done so much to it at this point, that I can’t even get the kmix icon to show up right. It keeps telling me that mixer can’t be found.

Okay later:

****, thought I had fixed it. Inadvertently logged in as root. More later.

Are you kidding me!? I can not do a clean install and NOT format the /home directory? We have ALWAYS been able to do that. The do not format option gives a few choices, none of which are acceptable. New topic I know, but I’m just venting. I can’t even take my own advise and do a clean install, without moving my home directory somewhere else and copying it back. That makes no sense to me.

I have several critical databases, etc and it scares the heck out of me if I screwed something up on a clean install. Anyway the problem does not orginate in the home directory. Create a new user and the no sound problem is there.

UGH! NOT what I wanted to hear. I’m in the process of backing up my /home directory now. Will take a couple of hours.

Sooo… if a new users is created and it still doesn’t work, then maybe it is as simple as wiping out everything in /tmp! There is a lot of data there that is user specific. Since it worked for me on a clean install, but not an upgrade… I made the leap it may be /home specific. I can’t think of anything else that could mangle it. Can you try that and let me know? I’m stuck for a couple of hours on a backup.