No Sound in 11.3 64-Bit

I just moved from 11.2 to 11.3 and I find that I’m unable to get my sound working. I get this output from dmesg:

    6.414532] EDAC MC0: Giving out device to 'amd64_edac' 'RevF': DEV 0000:00:18.2
    6.414550] EDAC PCI0: Giving out device to module 'amd64_edac' controller 'EDAC PCI controller': DEV '0000:00:18.2' (POLLED)
    6.506460] Error: Driver 'pcspkr' is already registered, aborting...
    6.550919] ppdev: user-space parallel port driver
    6.566742]   alloc irq_desc for 17 on node 0
    6.566746]   alloc kstat_irqs on node 0
    6.566755] HDA Intel 0000:20:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    6.566808] HDA Intel 0000:20:01.0: setting latency timer to 64
    6.566821] BUG: unable to handle kernel paging request at ffffc90011ed0000
    6.566944] IP: <ffffffffa03e9d0b>] azx_probe+0x3ee/0x939 [snd_hda_intel]
    6.567061] PGD 7f86f067 PUD 7f870067 PMD 7f10e067 PTE 800000fd00000173
    6.567177] Oops: 0009 #1] SMP 
    6.567234] last sysfs file: /sys/devices/pci0000:00/0000:00:12.0/net/eth0/type
    6.567348] CPU 0 
    6.567380] Modules linked in: snd_hda_intel(+) snd_hda_codec snd_hwdep ppdev snd_pcm parport_pc amd64_edac_mod snd_timer sr_mod parport floppy snd asus_atk0110 edac_core shpchp soundcore pcspkr k8temp usbhid edac_mce_amd usb_storage cdrom serio_raw snd_page_alloc via_rhine i2c_viapro pci_hotplug button sg preloadtrace ext4 jbd2 crc16 uhci_hcd ehci_hcd sd_mod usbcore fan processor ata_generic pata_via sata_via libata scsi_mod thermal thermal_sys
    6.568009] 
    6.568009] Pid: 702, comm: work_for_cpu Not tainted 2.6.34-12-default #1 M2V-MX SE/System Product Name
    6.568009] RIP: 0010:<ffffffffa03e9d0b>]  <ffffffffa03e9d0b>] azx_probe+0x3ee/0x939 [snd_hda_intel]
    6.568009] RSP: 0018:ffff88007e1f3e70  EFLAGS: 00010286
    6.568009] RAX: ffffc90011ed0000 RBX: ffff880037cf0028 RCX: 0000000000000004
    6.568009] RDX: 0000000000000004 RSI: 0000000000000246 RDI: ffff88007d7ebe6c
    6.568009] RBP: ffff88007daef000 R08: ffff88007d7ebe00 R09: 0000000000000040
    6.568009] R10: 0000000000000008 R11: 0000000000000003 R12: 0000000000000000
    6.568009] R13: ffff88007cc65428 R14: ffff88007daef090 R15: 0000000000000000
    6.568009] FS:  00007ff14be01700(0000) GS:ffff880001e00000(0000) knlGS:0000000000000000
    6.568009] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
    6.568009] CR2: ffffc90011ed0000 CR3: 000000007f138000 CR4: 00000000000006f0
    6.568009] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
    6.568009] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
    6.568009] Process work_for_cpu (pid: 702, threadinfo ffff88007e1f2000, task ffff88007ee1e040)
    6.568009] Stack:
    6.568009]  0000000000013e80 0000000000000005 0000000000013e80 ffff88007cc65428
    6.568009] <0> ffff88007e1f3fd8 ffff88007d7fdcf8 ffff88007e1f3ef8 ffffffff8106cb90
    6.568009] <0> ffff88007d7fdcf8 0000000000000000 0000000000000000 ffffffff81260872
    6.568009] Call Trace:
    6.568009]  <ffffffff81260872>] local_pci_probe+0x12/0x20
    6.568009]  <ffffffff8106cb9b>] do_work_for_cpu+0xb/0x20
    6.568009]  <ffffffff81070cee>] kthread+0x8e/0xa0
    6.568009]  <ffffffff81003cf4>] kernel_thread_helper+0x4/0x10
    6.568009] Code: f4 01 00 00 ef 31 f6 48 89 df e8 71 d4 ff ff 85 c0 0f 88 9e 03 00 00 48 89 ef e8 91 40 e7 e0 8b 7b 40 e8 79 a1 cc e0 48 8b 43 38 <66> 8b 00 66 89 44 24 08 8b 43 14 83 e8 03 83 f8 01 77 35 31 d2 
    6.568009] RIP  <ffffffffa03e9d0b>] azx_probe+0x3ee/0x939 [snd_hda_intel]
    6.568009]  RSP <ffff88007e1f3e70>
    6.568009] CR2: ffffc90011ed0000
    6.568009] --- end trace 78c9bacde777b965 ]---

I get this from rpm -qa | grep alsa:

alsa-plugins-jack-1.0.23-1.9.x86_64
alsa-plugins-1.0.23-28.1.x86_64
alsa-firmware-1.0.23-1.2.noarch
alsa-plugins-32bit-1.0.23-28.1.x86_64
alsa-tools-1.0.23-1.8.x86_64
alsa-utils-1.0.23-20.1.x86_64
alsa-oss-1.0.17-53.1.x86_64
alsa-1.0.23-2.12.x86_64
alsa-oss-32bit-1.0.17-53.1.x86_64
alsa-driver-kmp-default-1.0.23.20100816_k2.6.34.0_12-1.1.x86_64
alsa-docs-1.0.23-2.12.noarch
alsa-plugins-jack-32bit-1.0.23-1.9.x86_64

and this from rpm -qa | grep pulse:

libpulse0-0.9.21-65.1.x86_64
libpulse-mainloop-glib0-0.9.21-65.1.x86_64
libxine1-pulse-1.1.19-1.pm.44.3.x86_64

My /etc/modprobe.d/50-sound.conf looks like this:

options snd slots=snd-hda-intel
# UTtW.PfnGitoKusE:VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)
alias snd-card-0 snd-hda-intel

The card appears in YaST, but if I make any changes or attempt to remove it and re-add it YaST hangs.

I don’t seem to get any sound out of any speaker tests, they all return that the device is missing, but I’ll try others (I can’t remember exactly which commands I’ve tried at this point, I’ve been scouring the web looking for things to try).

I’m game for suggestions. Thanks in advance,

To get more information, can you also run in a terminal:

/usr/sbin/alsa-info.sh 

and you should get something like this (select OK):
http://thumbnails33.imagebam.com/9280/a5973e92794041.jpg](ImageBam)

followed by this (select the SHARE/UPLOAD option):
http://thumbnails30.imagebam.com/9280/5e84f992794044.jpg](ImageBam)

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :
http://thumbnails32.imagebam.com/9280/214da092794048.jpg](ImageBam)

followed by this (where in RED is the URL).
http://thumbnails23.imagebam.com/9280/d9858092794051.jpg](ImageBam)

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Run the above as a regular user. If you are told there is an ‘update available’, run it again with root permissions in a terminal, and once update complete, exit root in the terminal and run again as a regular user.

If you can not get that, then run this with the no upload option:

/usr/sbin/alsa-info.sh --no-upload

which will create the file /tmp/alsa-info.txt. Copy that file and paste it on Pastebin.com and press submit. That will give you a URL address. Please post that URL address here.

There is an audio troubleshooting guide here, but its getting a bit dated:
SDB:Audio troubleshooting - openSUSE

As requested: http://www.alsa-project.org/db/?f=c78997bbd6fcc75b67e8a2dab81d8e0ca1d48edf. Thanks!

Thats pretty clear:

!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards --- 

Rather than your ‘picking and choosing’ what you think we want to see from the dmesg, can you reboot and then IMMEDIATELY after a reboot, copy the entire content of your dmesg to Pastebin.com - #1 paste tool since 2002! and post here the address/URL it gives.

I note you updated alsa from the multimedia web site. You did not advise us of that failed attempt in your 1st post. What else did you try that you are not telling yet ? Knowing this might save me some time from suggesting things that are not relevant given what you have done.

While waiting for a URL for a complete dmesg, I note these versions:

Instead you may wish to go here: Index of /repositories/multimedia:/libs/openSUSE_11.3/x86_64 and install these versions instead:


alsa-plugins-jack-1.0.23-28.1.x86_64.rpm     
alsa-plugins-32bit-1.0.23-28.1.x86_64.rpm  
alsa-tools-1.0.23-9.1.x86_64.rpm     
alsa-utils-1.0.23-20.1.x86_64.rpm      
alsa-1.0.23-66.1.x86_64.rpm     
alsa-plugins-jack-32bit-1.0.23-28.1.x86_64.rpm  
libasound2-1.0.23-66.1.x86_64.rpm   

and from here http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.3/noarch/:

alsa-firmware-1.0.23-8.1.noarch.rpm   
alsa-docs-1.0.23-66.1.noarch.rpm       

and since you are updating, install the latest kmp driver from here http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.3/x86_64/:

alsa-driver-kmp-default-1.0.23.20100817_k2.6.34.0_12-2.1.x86_64.rpm 

… out of curiousity, where did you get the information to try the changes you made above in your 1st post from ?

Sorry, took me a few days to make it back to this. My current output from rpm -qa | grep alsa:

alsa-tools-1.0.23-9.1.x86_64
alsa-plugins-1.0.23-28.1.x86_64
alsa-firmware-1.0.23-8.1.noarch
alsa-plugins-jack-1.0.23-28.1.x86_64
alsa-oss-1.0.17-53.1.x86_64
alsa-driver-kmp-default-1.0.23.20100818_k2.6.34.0_12-1.1.x86_64
alsa-1.0.23-66.1.x86_64
alsa-docs-1.0.23-66.1.noarch
alsa-utils-1.0.23-20.1.x86_64

I’ve removed the 32-bit drivers at this point - I had those installed because I seem to recall (possibly from 11.1 or 11.2) that I was able to get sound in 32-bit but not in 64-bit. I can’t remember fully if I actually had to use the 32-bit version of SuSE for that to work.

Also as requested, here is the full dmesg: 0.000000] Initializing cg - G-d-d-c - dBA6317L - Pastebin.com](http://pastebin.com/dBA6317L).

Thanks for the help guys. Sorry if I sounded perturbed at first. I appreciate the assistance a great deal.

I can’t see anything obviously wrong there. Did you remember to update libasound2? There is no mention of it in your post. It is essential.

How about the script:
/usr/sbin/alsa-info.sh ?
… did you run it again after a reboot after the update?

What is your test for sound ?

Updated alsa-info.sh: http://www.alsa-project.org/db/?f=c7514eb341a649b20f6683899e90db914f98820f

rpm -qa | grep libasound:

libasound2-1.0.23-66.1.x86_64
libasound2-32bit-1.0.23-66.1.x86_64

speaker-test commands I’ve tried:

speaker-test -c2 -l5 -twav

speaker-test 1.0.23

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4154:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4154:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4154:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4633:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
Playback open error: -2,No such file or directory
speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.23

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,No such file or directory

In YaST if I attempt to configure the sound card the program hangs. I also have a notification each time I log in from Phonon that informs me that “The audio playback device ALSA default output does not work. Failing back to .”

That says it all … ie :

!!Soundcards recognised by ALSA
!!-----------------------------
--- no soundcards ---

Are you certain your sound is switched on in your PC BIOS ?

I recommend you write a bug report on component "sound " on openSUSE-11.3. There is guidance here: openSUSE:Submitting bug reports - openSUSE

Attach to your bug report the file alsa-info.txt which you can obtain by running:

/usr/sbin/alsa-info.sh --no-upload

Put all the salient information in the bug report as the SuSE-GmbH package won’t read a forum thread.

Note that packager is also an alsa driver developer and he may have some update for you to try. If they work, then he will apply them to the alsa package and all Linux users will benefit.