No sound in 11.1 x86_64

I have a Dell Lattitude E6500 and I’m running openSUSE 11.1 and am mostly very happy. I have a problem with sound though - there is none.
I have looked through the forums to at least find out what I need to provide to get some help, so here goes…

uname -a
Linux linux-elkk #1 SMP 2009-02-25 15:40:44 +0100 x86_64 x86_64 x86_64 GNU/Linux

rpm -qa | grep alsa

rpm -qa | grep pulse

rpm -qa | grep libasound2

cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel

u1Nb.SGxGJCiH+82:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel


I tried to run this: wget && su -c ‘bash ./tsalsa’ but it returned an Error 404

Hope you can help

That script is no longer being maintained. IRC freenode channel #alsa user “gnubien”, who developed that script, is no longer maintaining it. Instead he is helping IRC #alsa user “wishie” with the maintenance of the “” script, where that later script is now incorporated in alsa (as of 1.0.17 of alsa).

OK, I see your Dell has the IDT 92HD71B7X codec, and you have the updated kernel, BUT you still have the original alsa version that came with openSUSE-11.1. The kernel broke the sound on users PCs with the IDT 92HD71B7X codec, and the openSUSE/alsa developer put out an update to alsa on a build service repository. I documented how to apply such updates in this URL: Alsa-update - openSUSE

In your case, that means open a terminal or a konsole, type “su” (no quotes, enter root password when prompted) and with your PC connected to the internet, into that terminal/konsole copy and paste the following 6 zypper commands one at a time, in sequence, executing them:

zypper ar multimedia
zypper install alsa alsa-plugins alsa-plugins-pulse alsa-utils alsa-tools alsa-tools-gui alsa-oss alsa-oss-32bit alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

then restart your PC (so as to unload the old drivers, load the new alsa drivers) and test your audio. Pay careful attention to your mixer settings.

I recommend a simple test to see if your sound works, which is to open a konsole or xterm, and type (it may be easier to copy and paste this into your konsole/xterm):
speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 75%. Note the test for surround sound is different.

If that test yields errors, try instead this more simple test:speaker-test -c2 -l5 -twavIdeally you should hear a lady’s voice saying ‘FRONT LEFT’,‘FRONT RIGHT’ 5 times. Try as both a regular user and with root permissions. Typically one (but often not both) of those sound tests will work, indicating basic sound functions.

Its possible that your sound still may not work, in which case there is an excellent probabilty that applying a custom edit to your /etc/modprobe.d/sound file, together with the above update of alsa to 1.0.19 will fix your PC’s sound problem. I can provide the proposed edit(s) if it comes to that.

Thank you oldcpu. That works perfectly.

Great! Glad to read it worked.

I have been looking around for some time for this. At first I thought PulseAudio was the culprit so I removed it without any success. But now my sound is working, hurrah :slight_smile:

Thank you very very much

Excellent. Glad to read it worked.

I’ve been struggling as to how to capture this sort of information ( “kernel-x” update broke “hardware-audio-codec-y” with “alsa-z” ) … If I was better organized, I would maintain a wiki, recording this sort of information in a succinct easy to read table, such that it could be updated and available to all. But I’m not very organized. :frowning:

Sometime back I wrote the openSUSE audio troubleshooting guide SDB:AudioTroubleshooting - openSUSE and the alsa update page … but IMHO thats only a start, and only for basic audio.

Often sound problems require a complex diagnosis, followed by a complex fix, and its difficult to migrate the methodogy to follow into a simple guide (more simple that what I have written).

And then when one gets into 5.1 or 7.1 sound, and/or into USB sound devices, the audio troubleshooting guide does not help. We need another guide for each of those.

And then there are the cases where users have software (audio) codec problems, and believe their problem is a misconfiguration of their sound card, when in fact its just a missing codec or a misconfigured multimedia player. Its difficult to separate those cases.

And now recently, there are cases where audio associated with High Definition video stutters, when in fact its not an audio configuration problem per say, but rather its due to the CPU being maxed out trying to display the video, when it can not manage the H.264, or MPGEG1/2 or VC-1 (wmv) decoding.

… anyway, I ramble … there is still many aspects that the volunteers to openSUSE need to sort … :stuck_out_tongue:

Once again, I’m glad to read your sound is working now. …

My colleagues are also very happy that my sound is working again… >:)

I have a fairly fresh install of OpenSUSE so my sound didn’t work from the start. Figuring out what the cause is can take quite some time. I just started at the bottom and worked up from there.

Although I probably couldn’t have figured out on my own that a specific kernel broke my sound. :wink: I was glad that you posted this here so I could fix it.

As a reward I give you the virtual helmet of the indestructible giving you a +1 bonus to all your stats. :slight_smile: